WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] XML error: Reserved XML Name at line 2, column 38 (7 posts)

  1. cnymike
    Member
    Posted 4 years ago #

    Today I transferred my WP installation to a new server. Everything seemed to go well. However, I am getting an error with the RSS Widget. The error is XML error: Reserved XML Name at line 2, column 38

    I have checked my wp-config.php file to ensure there are no blank lines at the end of the file. Curiously, there was no closing ?> but I'm not sure if that is relevant to this problem or not. It didn't make any difference whether the ?> was there or not.

    Any ideas what might be causing this error? I don't really even know which files I should be checking or what I am to look for.

  2. esmi
    Forum Moderator
    Posted 4 years ago #

    Curiously, there was no closing ?> but I'm not sure if that is relevant to this problem or not.

    It isn't relevant to your problem. In fact, it's not a problem at all.

    Is this an issue with your RSS feed? If so, a link to your site might help.

  3. cnymike
    Member
    Posted 4 years ago #

    Upon further inspection it appears the XML error was a combination of two things... WP 2.9.2 and a several versions old plugin (All In One SEO Pack). Upgrading the plugin made the error go away.

    So for me this is solved.

  4. pwrdesign
    Member
    Posted 4 years ago #

    Bumping this one!

    I've done a "package" of wp-sites/blogs for a company.
    All of them are updated to the latest version of WP, and all the plugins are updated.

    Take a look at: http://www.marialangen.se/ it should display the RSS feed of "Sverredal & Langen" with the adress: http://www.svelan.se/?feed=rss

    This is not working as you can see.
    What I've done so far:

    I've turned off all the plugins on svelan.se, and suddenly the feed started to work on some of the other wordpress-sites, for example: http://www.krisinstitutet.se/

    But on http://www.marialangen.se/ and http://www.dromwebben.se/ it still dosnt work.

    I've looked for blank rows in my wp-config, function.php.

    If I try to validate the RSS feed it says: http://validator.w3.org/feed/check.cgi?url=http%3A%2F%2Fwww.svelan.se%2F%3Ffeed%3Drss

    So it looks like the first empty row is causing this?
    Any more ideas about where to search?

  5. pwrdesign
    Member
    Posted 4 years ago #

    Solved!

  6. kadius
    Member
    Posted 3 years ago #

    pwrdesign, please let us know how it was solved.

  7. kadius
    Member
    Posted 3 years ago #

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags