WordPress.org

Ready to get started?Download WordPress

Forums

MimeTypes Link Icons
[resolved] xlt missing (9 posts)

  1. aebli
    Member
    Posted 2 months ago #

    Hello, I would like the Excel-Icon on .xlt-files. Can I just add ".xlt" somewhere in the settings?
    Thank you very much!
    Dominik

    https://wordpress.org/plugins/mimetypes-link-icons/

  2. jrf
    Member
    Plugin Contributor

    Posted 2 months ago #

    Hi Dominik,

    You could, but you'd also need to copy the image files you'd want to use and rename them for using them with .xlt.
    Once you've copied the files, you can just add the extension to the $mime_types array in both the main file (round line 200) and the style.php file.

    Am I correct in that .xlt is the Excel template file format ? Both 'normal' excel file formats ( '.xls' and 'xlsx' ) are supported.

    Smile,
    Juliette

  3. aebli
    Member
    Posted 2 months ago #

    Hi Juliette
    Thank you so far for your answer. Yes, the "xlt" are Excel-template-Files. It would be fine if these files are using also the general excel-icon. I'm not sure regarding your first advice "also need to copy the image files you'd want to use and rename them for using them with .xlt.".

    What I made: inserted "xlt" to (around) line 200 of
    mimetypes-link-icons/mime_type_link_images.php.

    This line looks now like this:
    'xls', 'xlsx', 'xlt', 'xml', 'xpi',

    And in the beginning of the file:
    mimetypes-link-icons/css/style.php

    with this: 'xls', 'xlsx', 'xlt', 'xml', 'xpi',

    But this is not enough to work; the plugin don't know to put the right excel-Icon.

    Thanks for your help!
    Dominik

  4. jrf
    Member
    Plugin Contributor

    Posted 2 months ago #

    Hi Dominik,

    The code changes you made look fine.

    But this is not enough to work; the plugin don't know to put the right excel-Icon.

    That's why you also need to copy the image files. In the plugin directory, there is an images directory. In this directory you should find the following 10 files:
    xls-icon-16x16.gif
    xls-icon-24x24.gif
    xls-icon-48x48.gif
    xls-icon-64x64.gif
    xls-icon-128x128.gif
    xls-icon-16x16.png
    xls-icon-24x24.png
    xls-icon-48x48.png
    xls-icon-64x64.png
    xls-icon-128x128.png

    Copy those and replace the 'xls' in the file name of each file with 'xlt' (and place them in the same directory again).
    Then it should work ;-)

    Smile,
    Juliette

  5. aebli
    Member
    Posted 2 months ago #

    Thanks a lot Juliette; I've done this;

    http://www.gemeinde-spluegen.ch/formulare

    the first File should shown with the Excel-Icon… Maybe one of the php-fils is still not enough updated by the "xlt"-ending (there are about 12 files in the plungin-Editor for your plugin, but as shown above, I updated correctly mimetypes-link-icons/mime_type_link_images.php. and mimetypes-link-icons/css/style.php. But this is not that urgent.. maybe, the "xlt" will be included in one of the following updates ;)

    Dominik

  6. jrf
    Member
    Plugin Contributor

    Posted 2 months ago #

    Hi Dominik,

    It should work, but you do have to enable the extension on the MTLI settings page. Did you do that ?

    Smile,
    Juliette

  7. aebli
    Member
    Posted 2 months ago #

    Yes. Naturally did I enabled the "new" extension! Naturally NOT!! ;o)
    Thank you very much, id works now fine! OMG... ;))

  8. jrf
    Member
    Plugin Contributor

    Posted 2 months ago #

    *grin* Glad to hear that solved it. Would you mark this thread resolved please ?

  9. aebli
    Member
    Posted 2 months ago #

    Thanks again; .xlt it now showed up :)

Reply

You must log in to post.

About this Plugin

About this Topic