WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] XHTML validation fails under WP2.2 for Multi Cat blogroll (12 posts)

  1. 200feet
    Member
    Posted 7 years ago #

    I use 3 main Categories for my blogroll at 200feet.com - yet after upgrading to WP2.2 XHTML validation fails with the following Errors...

    1.  Error  Line 119 column 8: ID "links" already defined.
    
          <li id="links" class="widget widget_links"><h2 class="widgettitle">200feet digs.
    
          An "id" is a unique identifier. Each time this attribute is used in a document it must have a different value. If you are using this attribute as a hook for style sheets it may be more appropriate to use classes (which group elements) than id (which are used to identify exactly one element).
    
       2. Info Line 108 column 8: ID "links" first defined here.
    
          <li id="links" class="widget widget_links"><h2 class="widgettitle">'Ave a look a
    
       3. Error Line 135 column 8: ID "links" already defined.
    
          <li id="links" class="widget widget_links"><h2 class="widgettitle">200feet knows
    
       4. Info Line 108 column 8: ID "links" first defined here.
    
          <li id="links" class="widget widget_links"><h2 class="widgettitle">'Ave a look a

    I used to use the sidebar widgets plugin but am now using the native version.
    Is this because I am using 3 Categories for blogroll and not 1? Or is it related to my theme? It validated fine before WP2.2.
    Pls help..... I understand the basics but am def not a programmer.

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    This is an unforeseen issue with some of the enhancements to the links widget. It's not critical, actually, but I'll put in a ticket anyway.

  3. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    Reference to trac ticket, for continuity:
    http://trac.wordpress.org/ticket/4287

  4. 200feet
    Member
    Posted 7 years ago #

    Hi - thanks for checking for me and for doing that - I wasn't sure if it was me doing something wrong.
    I will keep an eye on it for progress.

  5. 200feet
    Member
    Posted 7 years ago #

    UPDATE!
    OK - something else to throw into the mix - is it related or should I start a different topic?
    Some of my other plugins using sidebar widgets have either stopped displaying their 'titles' (e.g. Martin Fitzpatrick's Adsense Manager), or are not saving the changes I make to the title in the configuration pop-up of the native widgets page (e.g. Andrew Ferguson's Countdown Timer).
    Related, or separate?

  6. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    Separate.

  7. whooami
    Member
    Posted 7 years ago #


  8. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    nm delete me

  9. jostorh
    Member
    Posted 7 years ago #

    I have the same problem with the sidebar widget and links.
    Is there a way I can fix this?

  10. whooami
    Member
    Posted 7 years ago #

    sure, edit the function. do you know php?

    if not, bookmark the link to trac that otto provided and wait until it's addressed there.

  11. jostorh
    Member
    Posted 7 years ago #

    I know some php, and I have found the function in widgets.php, do you know what I shall edit?

  12. apgates
    Member
    Posted 6 years ago #

Topic Closed

This topic has been closed to new replies.

About this Topic