WordPress.org

Ready to get started?Download WordPress

Forums

Xampp with WP: A better tutorial? (52 posts)

  1. KattheLeopardess
    Member
    Posted 8 years ago #

    http://www.tamba2.org.uk/wordpress/xampp/

    This is the page I have had come up in my google searches for how one might install wordpress and using xampp for testing your wordpress on your local machine first.

    Anyhow, I find this tutorial not to be specific enough. Im lost on a few things. One being the order of which you create a sql account ("wordpress" being the default name) and username/password. Which do i do first?

    Secondly, I am trying to understand how one generates the config PHP file. I had seen there on the above link that it is a matter of coding it manually. However on other informational pages, it looks like wordpress will do that for you.

    Overall I wish there was a clearer way to get this to work.

    -Kat

  2. moshu
    Member
    Posted 8 years ago #

    1. I don't think the order matters. Create a database and the user is (usually) root. On that local install you don't even really need pw, but for security reasons XAMPP will bug you to do so :)

    2. No, WP does NOT create the wp-config (better to say, don't let it do), just do it in the old-fashioned manual way. You have to put in 4 words in the sample file.

  3. KattheLeopardess
    Member
    Posted 8 years ago #

    Is there anything in that site shown that you could clarify, give me better detail of? do you mean that the user is "root" literally or that it is the root directory name?

    -Kat

  4. moshu
    Member
    Posted 8 years ago #

    Literally. At least on my XAMPP install.
    I remember I've created a database named "test" (I was as scared of the whole process as you are now:), then without "asking" me the user in it was 'root'... and things just started to work.

  5. KattheLeopardess
    Member
    Posted 8 years ago #

    Hmm

    getting this error:

    define('DB_NAME', 'wordpress'); // The name of the database define('DB_USER', 'root'); // Your MySQL username define('DB_PASSWORD', ''); // ...and password define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value // You can have multiple installations in one database if you give each a unique prefix $table_prefix = 'wp_'; // Only numbers, letters, and underscores please! // Change this to localize WordPress. A corresponding MO file for the // chosen language must be installed to wp-includes/languages. // For example, install de.mo to wp-includes/languages and set WPLANG to 'de' // to enable German language support. define ('WPLANG', ''); /* That's all, stop editing! Happy blogging. */ define('ABSPATH', dirname(__FILE__).'/'); require_once(ABSPATH.'wp-settings.php'); ?>
    Warning: require_once(ABSPATH/wp-admin/admin-functions.php) [function.require-once]: failed to open stream: No such file or directory in C:\xampplite\htdocs\wordpress\wp-admin\upgrade-functions.php on line 3

    Fatal error: require_once() [function.require]: Failed opening required 'ABSPATH/wp-admin/admin-functions.php' (include_path='.;C:\xampplite\php\pear\') in C:\xampplite\htdocs\wordpress\wp-admin\upgrade-functions.php on line 3

    I have the following in my wp-config.php file

    define('DB_NAME', 'wordpress'); // The name of the database
    define('DB_USER', 'root'); // Your MySQL username
    define('DB_PASSWORD', ''); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value

    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix = 'wp_'; // Only numbers, letters, and underscores please!

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');

    /* That's all, stop editing! Happy blogging. */

    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    ?>

    Basically I copied and pasted verbatim in the way that that tamba2.co.uk page told me to. They dont mention if i am to replace the contents with my directory name and such or not. Thats what strikes me as the part that doesnt seem to be written clearly. Anyhow, now what?

  6. moshu
    Member
    Posted 8 years ago #

    You should turn on PHP. If you see all that "garbage" PHP is not running on your server.

  7. KattheLeopardess
    Member
    Posted 8 years ago #

    And how do I do that?

  8. moshu
    Member
    Posted 8 years ago #

    Sorry, I really can't remember. Don't forget, please, that setting up a local server on your own computer is not a genuine WordPress question.
    I assume XAMPP also has intructions, user manual... something. We try our best to help WP users, but there are certain issues which are beyond the scope of this forum. Like troubleshooting your local server.
    When the server is up and running we will be glad to help you with WP install if it is needed.

  9. Chris_K
    Member
    Posted 8 years ago #

    ... and to follow up: XAMPP has that little app (orange X) running down in your tray. The Xampp control panel I think it is called. Click it and make sure that Apache and MySQL are both "running". If not, click the start buttons.

  10. KattheLeopardess
    Member
    Posted 8 years ago #

    Well both were started (apache and mysql)

    Im still getting that error. could it have to do with teh config file?

  11. Mark (podz)
    Support Maven
    Posted 8 years ago #

    Unzip the download
    Open the folder that is mde until you see the one called just 'wordpress'

    xampp/httpdocs/
    You copy the entire wordpress folder into that directory

    wp-config-sample.php
    Rename that to
    wp-config.php

    For an 'out of the box install' you edit wp-config.php to have these details (as detailed on the xampp page)
    You edit with Notepad, BBedit, Notepad++ or similar. Nothing else. Just plain text editors.

    define('DB_NAME', 'wordpress'); // The name of the database
    define('DB_USER', 'root'); // Your MySQL username
    define('DB_PASSWORD', ''); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value

    You change nothing.

    If you have then done everything, it will work.

  12. KattheLeopardess
    Member
    Posted 8 years ago #

    My wordpress folder is located here:

    C:\xampplite\htdocs

    Following from the Tamba page I created a database called "wordpress"

    I dont think I ever created a username/password for the Tamba page did not really specify to do so.

    So right now my wp-config.php reads like this:

    define('DB_NAME', 'wordpress'); // The name of the database
    define('DB_USER', 'root'); // Your MySQL username
    define('DB_PASSWORD', ''); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value

    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix = 'wp_'; // Only numbers, letters, and underscores please!

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');

    /* That's all, stop editing! Happy blogging. */

    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    ?>

  13. resiny
    Member
    Posted 8 years ago #

    You might consider nuking everything and starting over, sounds like you probably screwed something up along the way

  14. Shelby DeNike
    Member
    Posted 8 years ago #

    If you are having issues with the XAMPP install I would give Web Server On a Stick a try. (http://www.chsoftware.net/en/useware/wos/wos.htm) ... its free and abotu as simple as it gets.

  15. KattheLeopardess
    Member
    Posted 8 years ago #

    I have done this "starting over" at least twice. Like I said, I think that the tamba tutorial really doesnt do well. I try and follow it verbatim and no matter what I get the same result. You might be right on using something outside of Xammp, desptie that someone who uses wordpress and is experienced in web design has sworn by it.

    Would there be a tutorial for Web Server On a Stick that I could look at and see if that one works better?

  16. Shelby DeNike
    Member
    Posted 8 years ago #

    I have never used XAMPP, I have only heard of it being a nice package. I have never tried to use the Tutorial on Tamba, but after looking it over it looks like it might not be complete or atleast out dated. Webserver On a Stick is as simple as you unzip and install the program. After that you load up http://localhost/phpmyadmin/ , create a database and create a user who has access to that database. Grab a copy of WordPress and install it to the www/ directory that WOS creates. After that load up the browser and head over to http://localhost/wordpress (or whatever you called it) and follow the installer...

  17. Mark (podz)
    Support Maven
    Posted 8 years ago #

    Please tell me how incomplete it is and how outdated it is so I can improve it.
    That page is also one of the top 5 there and gets a huge amount of hits so it cannot be entirely bad.
    Blasting it here and offering no constructive advice helps no-one.

    On that site is also a WOS install.

    I await the pointers to improve.

  18. KattheLeopardess
    Member
    Posted 8 years ago #

    I cant really say how outdated the Tamba tutorial is. Its just more or less unclear in certain places. For example, the part where you are to edit wp-config.php they are unclear as to the username and the password setup. It almost seems like setting up a username/password was a step that was left out.

    AS for WOS, I should give it a try. I was mistaken about my friend's knowledge of Xampp, rather that was the link I was referred to. I cna try WOS and see how that works. Ill defintily be telling my friend about which I experienced better as someone who is not all that versed in PHP type stuff.

    -Kat the Leopardess

  19. resiny
    Member
    Posted 8 years ago #

    I used Podz's tutorial and it worked just fine for me, perhaps this is a case of PEBKAC?

  20. Shelby DeNike
    Member
    Posted 8 years ago #

    The only thing that I saw on the tutorial that I didn't think was needed was the whole editing the wp-config.php, I have never done that on a local install. I have always been able to setup the dbase and then run the wordpress 5 min install. Thats the only thing I noticed that was either outdated... shouldn't have said not complete as it is a VERY complete tutorial. Sorry about the confusion from my part.

  21. Scope
    Member
    Posted 8 years ago #

    yeah, the tut page is good...i cant count the number of times a passed along that link.

    ---

    For example, the part where you are to edit wp-config.php they are unclear as to the username and the password setup. It almost seems like setting up a username/password was a step that was left out.

    ---

    at that point You are just going along with a regular wordpress install and would be filling in Existing Database info from phpMyadmin.

    phpmyadmin User is root, no password...thats the xampp default setup. i guess that could be noted in the tutorial page to reduce confusion...

    define('DB_NAME', 'wordpress'); // The name of the database
    define('DB_USER', 'root'); // Your MySQL username
    define('DB_PASSWORD', ''); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value

    it would make it transparent why the db_user and password is what it is in the wp_cofig info you are supposed to be using.

  22. Mark (podz)
    Support Maven
    Posted 8 years ago #

    Scope - thanks :) I'll add that.

  23. KattheLeopardess
    Member
    Posted 8 years ago #

    So where have I gone wrong?

    Should I just start over all over again (for about the 3rd time)

  24. KattheLeopardess
    Member
    Posted 8 years ago #

    Oh yeah...

    Is there a hidden step to create a username/password in MyPHP?

    -Kat

  25. Shelby DeNike
    Member
    Posted 8 years ago #

    After looking over the tutorial it should go with out a hitch. By MyPHP I assume you mean phpMyAdmin? You may want to do a search on google if you are having issues using phpMyAdmin.

  26. KattheLeopardess
    Member
    Posted 8 years ago #

    But where in the tamba tutorial do they specify that one needs to go into PHPadmin and create an account there? I sure didnt see it.

    As for the editing of config.php....I am still confused since sdnike seems to use a different way of inputting that information, rather than going into the file and editing with notepad.

    -Kat

  27. KattheLeopardess
    Member
    Posted 8 years ago #

    Im still getting this error:

    define('DB_NAME', 'wordpress'); // The name of the database define('DB_USER', 'wordpress'); // Your MySQL username define('DB_PASSWORD', 'bullwhip'); // ...and password define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value // You can have multiple installations in one database if you give each a unique prefix $table_prefix = 'wp_'; // Only numbers, letters, and underscores please! // Change this to localize WordPress. A corresponding MO file for the // chosen language must be installed to wp-includes/languages. // For example, install de.mo to wp-includes/languages and set WPLANG to 'de' // to enable German language support. define ('WPLANG', ''); /* That's all, stop editing! Happy blogging. */ define('ABSPATH', dirname(__FILE__).'/'); require_once(ABSPATH.'wp-settings.php'); ?>
    Warning: require_once(ABSPATH/wp-admin/admin-functions.php) [function.require-once]: failed to open stream: No such file or directory in C:\xampplite\htdocs\wordpress\wp-admin\upgrade-functions.php on line 3

    Fatal error: require_once() [function.require]: Failed opening required 'ABSPATH/wp-admin/admin-functions.php' (include_path='.;C:\xampplite\php\pear\') in C:\xampplite\htdocs\wordpress\wp-admin\upgrade-functions.php on line 3

    -----------

    this is after i granted permissions to a new phpadmin "account" named "wordpress"

    My config file looks like this:

    define('DB_NAME', 'wordpress'); // The name of the database
    define('DB_USER', 'wordpress'); // Your MySQL username
    define('DB_PASSWORD', 'bullwhip'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value

    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix = 'wp_'; // Only numbers, letters, and underscores please!

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');

    /* That's all, stop editing! Happy blogging. */

    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    ?>

    --------

    What is going on?

  28. moshu
    Member
    Posted 8 years ago #

    Two questions:
    Are you sure the XAMPP is turned on and the Apache and MySQL is started and running? (above there was a mention about the little orange gizmo...)

    Are you sure your WP files are uploaded in the proper location and that they have the expected directory structure?

  29. Mark (podz)
    Support Maven
    Posted 8 years ago #

    What program are you opening the wp-config.php file with?
    We need to know it's exact name.

  30. KattheLeopardess
    Member
    Posted 8 years ago #

    Both apache and sql are started.

    right now, the wordpress folder is in C:\xampplite\htdocs. I thought that is what the tamba instructions said

Topic Closed

This topic has been closed to new replies.

About this Topic