WordPress.org

Ready to get started?Download WordPress

Forums

xampp static ip (28 posts)

  1. sherif.yousseff
    Member
    Posted 7 months ago #

    Hi , i'm building a test website on my computer using wordpress , and xampp server, i have a static ip that i can show my work to client, i did the forwarding in the router page , the wordpress in a folder called wordpress in my xampp server, when i enter my ip adress/wordpress
    it shows the website except the pictures doesn't show
    Can anyone help, or where should i ask this...
    Thank you so much please helpp

  2. catacaustic
    Member
    Posted 7 months ago #

    Look at the source code of your site, and I'm sure that you'll see that the images are served something like this:

    <img src="http://localhost/wordpress/wp-content/uploads/2013/01/image.jpg" />

    The problem is that changing your sites URL or IP doesn't change the hard-coded links for images and links in posts/pages.

    The easiest tool that I've found for this is here. That lets you change everything to what it will need to be for the site ot show externally. Just be aware that you'll have to continue accessing it from the external IP address becuase you can't just change it back without going through the whole process again.

  3. sherif.yousseff
    Member
    Posted 7 months ago #

    Oh my God thank you very much for the answer , so the problem that i need to change the physical address , of each picture to the static ip address instead of localhost , but then it won't work locally, i got it , and again thank you so much ,you're just a life saver.
    and if i can just ask one more question , if i wanted to move a wordpress site after working on it to another server is there is an easy way to do that right away like a plug in or a script or something like that ?

  4. catacaustic
    Member
    Posted 7 months ago #

    I know there's some plugins out there that do the same thing as this script does, but that script is the eaiest way that I've found to do it so far.

  5. sherif.yousseff
    Member
    Posted 7 months ago #

    Thanks again , i will do that , i have another problem i can't access my wp-admin page when accessing it from another computer using my static ip address how to fix this please help

  6. catacaustic
    Member
    Posted 7 months ago #

    Hard to say without a lot more info. What is happening? Are you getting an error?Page not found? Redirection? Wrong URL returned? etc? etc? etc?

  7. sherif.yousseff
    Member
    Posted 7 months ago #

    its a server error in application error 404 not found

  8. catacaustic
    Member
    Posted 7 months ago #

    The first thing I'd do is check the access and error logs on your server and see what they say. There should be more details in there that can point you in the right direction. As it's a 404, there's got to be some actions logged on your server somewhere.

  9. sherif.yousseff
    Member
    Posted 7 months ago #

    This is a print screen from the error page if that helps

  10. sherif.yousseff
    Member
    Posted 7 months ago #

  11. catacaustic
    Member
    Posted 7 months ago #

    I can't see anything there, but if it's a 404 a screenshot won't do any good anyway. As I said before, the answers are in your servers Apache logs. Most likely the error log, but also possible the request log.

  12. ClaytonJames
    Member
    Posted 7 months ago #

    Hi , i'm building a test website on my computer using wordpress , and xampp server

    The 404 error message appears to be reported by an IIS server, not by XAMPP.

    C:\inetpub\wwwroot is for IIS. XAMPP uses apache, and its webroot is more likely to be something like; "C:\xampp\htdocs".

    If you want to run XAMPP, then disable IIS if you have no legitimate need for it on that machine. Don't run two web servers on the same port on the same machine.

    XAMPP "how to" WordPress

  13. sherif.yousseff
    Member
    Posted 7 months ago #

    Thank you for answering it's just driving me crazy
    I just checked my windows features IIs is disabled

  14. sherif.yousseff
    Member
    Posted 7 months ago #

    That's the weird part my IIs isn't running at all and it's looking in my iis root ?

  15. ClaytonJames
    Member
    Posted 7 months ago #

    If you are seeing that error page - the one that says 'Internet Information Services' in the top right corner - I would think that the Windows IIS server is probably running.

  16. sherif.yousseff
    Member
    Posted 7 months ago #

    Is there is another way to make sure that it's running aside from checking my add and remove features cause i have checked that page , and beside internet information service there is no check , its just driving me crazy

  17. sherif.yousseff
    Member
    Posted 7 months ago #

    http://i44.tinypic.com/2s16uc8.jpg
    This is a screen shot of my windows features

  18. ClaytonJames
    Member
    Posted 7 months ago #

    I don't know what to suggest, other than the 404 page in the image is clearly an IIS document, and the path being referenced in the error message is "C:\inetpub\wwwroot", not XAMPP. If you don't have any instance of IIS installed or running, I can't think of anything else that would make a browser automatically look in "C:\inetpub\wwwroot" for web pages. Very puzzling. This is just a guess, but do you have any other applications installed that might be running an IIS Hostable Webcore service?

  19. sherif.yousseff
    Member
    Posted 7 months ago #

    No not at all , just xampp running apache and mysql

  20. sherif.yousseff
    Member
    Posted 7 months ago #

    I don't know what i'm doing wrong i have asked all over the internet but no one knows, i installed xampp locally then installed wordpress so far all is good , then got the static ip , did the ip forwarding with the exact ports of xampp apache and mysql , when i access the page work with no pictures , and the wp-admin page on an error , do you see anything i did wrong here ?

  21. ClaytonJames
    Member
    Posted 7 months ago #

    I think I may be closer to understanding what is happening. Could you confirm a couple of things?

    1) Look at the root of your C:\ drive on the computer where you have installed WordPress, and see if there really is a folder named "inetpub". I suspect the answer is going to be no.

    2) Where is your WordPress actually installed, is it C:\XAMPP\htdocs\wordpress, or something different?

    i can't access my wp-admin page when accessing it from another computer using my static ip address

    3) Do your WordPress addresses in your dashboard still have the word "localhost" in them, and if so, does the computer that you used to access your site when you took the screenshot of the error message have IIS installed on it?

  22. sherif.yousseff
    Member
    Posted 7 months ago #

    1) no there is no such a folder on my c drive
    2) my wordpress is in "D:\Website-SErver\htdocs\wordpress"
    3) i don't understand ,when i access it from the local machine i type localhost in the address bar so it says that , is that what you wanted to know ?
    and the other computer yes have IIS installed on it i checked

  23. ClaytonJames
    Member
    Posted 7 months ago #

    when i access it from the local machine i type localhost in the address bar so it says that , is that what you wanted to know ?

    You see the 404 error page on the other computer (the one running the IIS server) because at least one of your WordPress URLs probably still has "localhost" in it. Every computer uses "localhost", so when the browser sees that in a URL, it tries to look on the local computer, rather than on your site.

    Basically you are right back at the point where @catacaustic was explaining that it would be necessary to change all of the URL's in your database in order to access your site from other computers.

    That includes your WordPress URL's. If you don't have a proper domain name, then it would need to be your static numeric IP address instead of the word "localhost", in order to view the site from other computers.

    Some reference materials that might help bring things into focus a little better: Changing The Site URL

  24. sherif.yousseff
    Member
    Posted 7 months ago #

    I will try that , i really hope it works thank you very much

  25. sherif.yousseff
    Member
    Posted 7 months ago #

    Is there is a way to install the wordpress site directly on the ip address not the localhost , i look around in that but i got no where

  26. ClaytonJames
    Member
    Posted 7 months ago #

    Is there is a way to install the wordpress site directly on the ip address not the localhost ,

    Sure.. For a fresh installation, you will need to remove the existing tables from your WordPress database first*

    *Caution: This will delete ALL of your content, so be sure it is what you want to do!

    Now go to another computer and type in the browser address bar;

    http://your.static.ip.address/wordpress/wp-admin/install.php

    I think that should do the trick. You just won't be able to view it properly from the machine it's installed on after that without some additional efforts.

  27. sherif.yousseff
    Member
    Posted 7 months ago #

    Again i can't really thank you enough for your help

  28. ClaytonJames
    Member
    Posted 7 months ago #

    No problem. I hope you have good luck this time!

Reply

You must log in to post.

About this Topic