WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] XAMPP, Local Network with WordPress problems (9 posts)

  1. Syamil MJ
    Member
    Posted 2 years ago #

    Hi guys,

    I have XAMPP running on my PC. I was able to access my localhost for files like html, php etc from another computer on the same network.

    However, trying to access my WP-site on my PC will return server not found.

    For example, I am able to access 192.168.1.34/myhtmlsite/index.php just fine from another computer on the same network, but if I try to go to 192.168.1.34/mywpsite, it will return server not found.

    Is there any configurations inside WP that causes this?

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    What urls did you enter in General -> Settings?

  3. Syamil MJ
    Member
    Posted 2 years ago #

    Do you mean the Permalink Settings? I set it to "default"

  4. esmi
    Forum Moderator
    Posted 2 years ago #

    No. In Settings -> General (I was typing backwards...)

  5. Syamil MJ
    Member
    Posted 2 years ago #

    My apologies, should have added that I was using Multisite.

    I installed another instance of WordPress, changed the URL for both Site & WordPress URL and now I am able to access from another computer. Thanks for the tips!

    Is there similar settings in Multisite where I can change these URLs? I've tried looking into both Network & Site admin, but there are none.

  6. esmi
    Forum Moderator
    Posted 2 years ago #

    You may need to actually edit your database for a multisite install.

  7. Syamil MJ
    Member
    Posted 2 years ago #

    You mean I have to search for every instance of "localhost/" and change it to my local network IP?

    I'd appreciate if you can offer a more detailed answer or point me to the right direction where this was done successfully.

  8. ClaytonJames
    Member
    Posted 2 years ago #

    You mean I have to search for every instance of "localhost/" and change it to my local network IP?

    That's probably the case, if you reinstalled using "localhost" instead of the pc's static LAN ip address.

    If that was really your only issue, all you needed to do was just add an entry to your hosts file to resolve localhost (127.0.0.1) to 192.168.1.34.

    That should allow you to access the site from both your LAN, and the browser on the PC where you installed xampp.

  9. Syamil MJ
    Member
    Posted 2 years ago #

    Thank you James. I went ahead and do "search & replace" of my SQL database. then changed 2 lines on wp-config from "localhost" to my static local ip. It works great!

    As for resolving localhost, I'd probably do that later since there are a few other installations here that still runs on localhost as the base url. Thanks for the tip anyway.

    Also thanks to esmi for the pointers. :)

    Cheers.

Topic Closed

This topic has been closed to new replies.

About this Topic