WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] XAMPP - Error establishing a database connection localhost (3 posts)

  1. eritzman
    Member
    Posted 6 years ago #

    There are many threads attempting to assist users with new installs of WordPress on "localhost" utilizing the Xampp service that seem to lead everyone into speculative circles with no solution. Fortunately, having had some difficulty myself and getting very frustrated, I finally resolved my issue and have the solution available for others.

    This install is on Win.XP-Pro system.
    Install suggestions are partly thanks to WP Designer.com and Geeks are Sexy blogspot

    To begin, download and install Xampp as per the instructions found on "Geeks are Sexy". I personally disabled my antivirus and windows firewall prior to install.
    When editing your 'wp-config.php' file as described in the tutorial, be sure to select the yourpasswordhere part of the define ('DB_PASSWORD', 'yourpasswordhere'); // ...and password portion. Once you have selected it, delete it (if you are following the instructions verbatim). Do not use a space or delete the two apostrophes on either side of "yourpasswordhere" as it will cause you to get the error of unable to connect to database.
    Happy blogging to all.

  2. 4thwave
    Member
    Posted 6 years ago #

    Hello all. I installed xampp lite and followed the instructions on the Geeks are Sexy blogspot site. I still get:

    "Object not found!
    The requested URL was not found on this server. If you entered the URL manually please check your spelling and try again.

    If you think this is a server error, please contact the webmaster.

    Error 404

    Here is the code in the wp-config.php file. as it currently reads.

    // ** MySQL settings ** //
    define('DB_NAME', 'wordpress'); // The name of the database
    define('DB_USER', 'root'); // Your MySQL username
    define('DB_PASSWORD', ''); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value
    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');

    I must be missing something (sure am feelin' stupid right about now!
    Any help would be appreciated!!!!!!!!!!!!!!!!!!!!

    4thwave

  3. 4thwave
    Member
    Posted 6 years ago #

    4thwave again.
    I figured this out and as usual it was a "speed" error.
    I was in a hurry to get the local install done so I could get some work done. . . anyway I followed the instructions given

      step by step
    and it worked flawlessly

    Major cudos to geeksaresexy.blogspot.com topic is resolved! Remember to secure the SQL server and the Apache server in the security console.

    Thank's all!

Topic Closed

This topic has been closed to new replies.

About this Topic