WordPress.org

Ready to get started?Download WordPress

Forums

WYSIWYG text editor stripping out paragraph formatting (4 posts)

  1. dnx
    Member
    Posted 6 years ago #

    I'm running WP 2.3.2

    When entering a number of paragraphs in the text editor within the admin section, once Save or Save & continue editing is selected, all the paragraphs become one large paragraph and all paragraph formatting is lost.

    Is there a fix for this?

  2. moshu
    Member
    Posted 6 years ago #

    Disable the wysiwyg: it is NOT expecting code, it's expecting content (plain text). If you know code, you don't need wysiwyg.

    Switching between visual/code - means the wysiwyg is ALWAYS on. Turn it off: admin > Users > Your profile.

  3. dnx
    Member
    Posted 6 years ago #

    Thanks moshu, I found that it was a problem the only occurred for me in Safari - works fine in Netscape. Don't know what's up there.

    I wasn't putting any code into the Visual editor, it would just create one big paragraph instead of the amount I created. Even if I coded it correctly using the code view, then switched to the visual editor, it would strip out all the <p> tags I put in!

  4. akulavolk
    Member
    Posted 6 years ago #

    This is happening for me as well. It also was causing a problem with blog posts I submitted using Flickr's "Blog This" export to my WordPress blog. The Flickr entry would look great, but if I'd go through WPAdmin to add tags or categories, it would remove all paragraph breaks and generally wreak havoc with formatting. I followed moshu's recommendation for turning off WYSIWYG option (even though I'm not doing any WYSIWYG editing) and it fixed the problem. Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic