WordPress.org

Ready to get started?Download WordPress

Forums

More Fields
[resolved] WYSIWYG field broken in WordPress 3.2 (25 posts)

  1. Aaron Adams
    Member
    Posted 3 years ago #

    The WYSIWYG field type doesn't work in WordPress 3.2. It's just a plain old textarea.

  2. kalstrom
    Member
    Plugin Author

    Posted 3 years ago #

    Strange. It's not like that for me …

    I have a styling issue (the background is transparent/grey).

    Plugin conflict?

  3. Aaron Adams
    Member
    Posted 3 years ago #

    I figured out how to reproduce:

    The visual editor no longer works for custom post types that don't support editor.

    Here's my custom post type:

    register_post_type('spider_fyb_item', array(
    	'label' => 'fyb',
    	'public' => true,
    	'rewrite' => array(
    		'slug' => 'fyb',
    	),
    	'supports' => array(
    		'title',
    		'author',
    	),
    ));

    If I add 'editor' to the 'supports' array, it works. So my guess is that WordPress 3.2 no longer enqueues the TinyMCE JavaScript when it isn't needed; More Fields will probably need to enqueue it explicitly when a WYSIWYG field is present.

  4. Aaron Adams
    Member
    Posted 3 years ago #

    http://dannyvankooten.com/450/tinymce-wysiwyg-editor-in-wordpress-plugin/

    Check out the bottom of this post, "UPDATE 06-07-2011 – WordPress 3.2." I think it explains the issue!

  5. kalstrom
    Member
    Plugin Author

    Posted 3 years ago #

    Right. Thanks!

  6. jamesrwhite
    Member
    Posted 2 years ago #

    Sorry to dig this up again but it's the only thread I've seen on the issue. I've read through the link that Aaron posted but I'm not sure where you are meant to put the line of code they suggest fixes the issue?

    wp_preload_dialogs( array( 'plugins' => 'wpdialogs,wplink,wpfullscreen' ) );

  7. whiteorb
    Member
    Posted 2 years ago #

    So what's the solution to this issue? So what's the solution to this issue? I don't see anything within More Fields that references wp_tiny_mce_preload_dialogs()

  8. jamesrwhite
    Member
    Posted 2 years ago #

    Yep, I had a look through all the plugin files as well and I didn't find it anywhere.

    The adding support for the editor fix Aaron mentions does work but obviously I'd rather the editor wasn't there.

  9. whiteorb
    Member
    Posted 2 years ago #

    In order to use Aaron's fix you would have had to make the Post_Type manually. I'm using More_Types.

  10. jamesrwhite
    Member
    Posted 2 years ago #

    Oh I see, I've got mine set up manually and while it does work it isn't really a fix.

  11. Zoe
    Member
    Posted 2 years ago #

    Looking for this fix as well - I'm using Custom Post Type UI and would love to diable the editor on some post types, but it gets rid of the visual editor for all the custom fields.

    Any known fix?

  12. JTWilcox
    Member
    Posted 2 years ago #

    Also looking for a fix for this. Don't want the editor but want the WYSIWYG functionality in the text boxes.

  13. whiteorb
    Member
    Posted 2 years ago #

    I spoke with @Kalstrom on twitter he said they would not be working on this for a indefinite period of time. Sounds like someone needs to take up the cause and reiterate these plugins or nag @Kalstrom and @hm6612 to resolve these issues.

  14. kalstrom
    Member
    Plugin Author

    Posted 2 years ago #

    Our schedules are just too hectic right now. But we will fix this issue.

    I don't think we'll have a release for you before early October.

  15. kalstrom
    Member
    Plugin Author

    Posted 2 years ago #

    We know you've been patient.

    Just this moment we posted an updated More Fields 2.1 with compatibility for WYSIWYG fields on created post types.

    Flattr us https://flattr.com/thing/386416/More-Plugins

  16. OlafB
    Member
    Posted 2 years ago #

    I found a bug in with german translation WP, wysiwyg not replace the strings. Related to this entry: http://core.trac.wordpress.org/ticket/15102

    Commented out line 81 in more-fields-settings-object.php solved this for me:
    //wp_tiny_mce( false ); // true gives you a stripped down version of the editor

  17. cisoprogressivo
    Member
    Posted 2 years ago #

    Same problem as OlafB, solved like he suggest.
    Thank you

  18. Anne-Claire
    Member
    Posted 2 years ago #

    Same problem as OlafB and cisoprogressivo, solved like he suggest.

  19. gerobe
    Member
    Posted 2 years ago #

    Same problem as OlafB and cisoprogressivo, solved like he suggest.
    Great! Thank you!

  20. iQuid
    Member
    Posted 2 years ago #

    Same problem as OlafB and cisoprogressivo, solved like he suggest.
    Merci

  21. Francesco Canovi
    Member
    Posted 2 years ago #

    Same problem as OlafB and cisoprogressivo, solved like he suggest.
    Grazie!

  22. gnilebein
    Member
    Posted 2 years ago #

    thank you for this post. I spent hours looking for a solution... :)

  23. revolutionaut
    Member
    Posted 2 years ago #

    OlafB solved this for me as well! Cheers!

  24. DanClarkePro
    Member
    Posted 2 years ago #

    I cannot see this on line 81 of more-fields-settings-object.php.
    Is there anything else that I could try?

    Disabling More types or More Fields brings the visual editor back into play, but it seems there is nothing I can try which will make it work when both are enabled.

    I look forward to your reply.

  25. DanClarkePro
    Member
    Posted 2 years ago #

    Sorry, WordPress took it's time to tell me there was an update, however the error for me wasn't in more fields, it was in more types.

    The file more-types-settings-object.php on line 29

    wp_enqueue_script('tiny_mce'); was commented out, after uncommenting, it worked.

    Note: this was only affecting user level "Editor", it was fine for the admins..

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic