WordPress.org

Ready to get started?Download WordPress

Forums

WYSIWYG Editor not working after upgrade to 3.0.1 (25 posts)

  1. Karoken
    Member
    Posted 3 years ago #

    Hey,

    Title says it all, i just got my hands on an older website i want to update for some friends and when i upgraded automatically to 3.0.1 my visual editor is now gone in pages and posts.

    Plugins seem fine, i activated/deactivated and played around.
    Theme is not the problem either, checked that.

    Is there something wrong with the installation or JS?

    Any help would be awesome! Thanks

  2. What version did you upgrade from?

    Can you try a manual upgrade? It's possible not all the files got overwritten correctly, and you may need to delete the wp-admin and wp-includes files to force the new ones up.

  3. Karoken
    Member
    Posted 3 years ago #

    Hey,

    I re-uploaded WP manually which did nothing, then i deleted the wp admin and includes and replaced them and still nothing.

    Any other ideas?

    :(

    Thanks for the help so far.

  4. Karoken
    Member
    Posted 3 years ago #

    Im an idiot for not trying this earlier, but it works with IE..

    So maybe its a problem with the theme?

  5. chantaspell
    Member
    Posted 3 years ago #

    I am having this problem in both chrome, opera, firefox and IE so its not a browser/theme issue (i tried changing theme)...had it on two blogs but now one has corrected itself (!) so maybe the other one will as well...let's see

  6. It could be a problem with a plugin. They have the ability to goober admin side.

  7. david0d0lindner
    Member
    Posted 3 years ago #

    I am having the same problem, and it's not a plugin for me. I deactivated them all and still didn't have a WYSIWYG editor. Also, text is white on old posts.

    I'm thinking it's a server issue. In fact, I'm pretty darn sure. 5 of my blogs are on one server, and they don't have the editor. I have one blog on a different server and the editor is working just fine.

    something with php?

  8. tylerheon
    Member
    Posted 3 years ago #

    I'm having the same issue- Safari, IE, FireFox. Visual editor bug. The editor initially loads, you see the toolbar and then it disappears. You can click on HTML editor and the toolbar appears but when you click over to visual, the html code stays but the toolbar disappears.

    Anyone got any help? This seems to be a known issue with no known fixes that I can find. Been scouring the interwebs for days!!

    Any help is appreciated!

  9. tylerheon, try deactivating all plugins. If that resolves the issue, reactivate each one individually until you find the cause.

    If that does not resolve the issue, try switching to the Twenty Ten theme to rule-out a theme-specific issue (theme functions can affect the admin panel).

    If you need further assistance, please start your own topic.

  10. mosonday
    Member
    Posted 3 years ago #

    I am using Thesis 1.8 on WP 3.0.1

    I did all of the above and editor is still not working.

    Activated the Default WP Theme - nothing doing
    Twenty Ten activated and still nothing

    While page is loading the WYSIWYG Editor is visible, but disappears once the page has loaded.

    All text in the edit area is also not visible.

    Is there perhaps any other solution?

  11. simonbugler
    Member
    Posted 3 years ago #

    I had a similar problem.

    No Plugins were at fault.

    Theme not at fault.

    Turned out to be a file permissions error - which may account for the comment above on servers.

  12. StefanoFonzarelli
    Member
    Posted 3 years ago #

    simonbugler,

    thanks for your hint. It sound familiar. But could you please tell us which files/directories and what their permission should be?

    That would really help.

  13. godlikemouse
    Member
    Posted 3 years ago #

    If you run into the problem where your toolbar disappears from your WYSIWYG editor as well as the WYSIWYG editor not working at all after upgrade to wordpress version 3.1, try this.

    go to your wp-includes/js/tinymce/langs and create a symbolic link to wp-langs-en.js as en.js.

    ln -s wp-langes-en.js en.js

    Looks like someone forgot to rename a file on the upgrade.

  14. pdsketchbook
    Member
    Posted 3 years ago #

    Can you please explain this to a non-programmer? How do you create a symbolic link? Is it a matter of creating a folder or adding a line of code in the file? I have read your solution but do not know what to do with this (ln -s wp-langes-en.js en.js). I use dreamweaver as a passthrough and file transfer only but can edit code if I know exactly where an what to change. - Thanks

  15. govpatel
    Member
    Posted 3 years ago #

    when I upgraded to 3.1.1 my editor was not working so I went in profile and tick
    Disable the visual editor when writing
    and save
    then untick and save that and when clicked on posts I show the editor back so may be I just reset the setting in database.

  16. andregalegos
    Member
    Posted 3 years ago #

    govpatel,
    I have the same problem

  17. andregalegos
    Member
    Posted 3 years ago #

    govpatel,
    I have the same problem

  18. govpatel
    Member
    Posted 3 years ago #

    have tried what I did

  19. pdsketchbook
    Member
    Posted 3 years ago #

    govpatel - yes i have tried what you did and it did not work. I also tried every other suggestion I could find in this or any other discussion. I tried the master list, removing hotlink protection, disabling all plugins, switching themes, reinstalling 3.1, switching browsers, updating javascript, installing a different visual editor, defining cocanate script, and verifying permissions.

    Still no luck!

    I don't know if it makes any difference but I recently moved my blog from a different directory on the same server. When I did, I had troubles with the images and solved it by removing the forced path for image uploads.

    This is very frustrating and I am about to start up a new blog and possibly something other than WordPress.

  20. andregalegos
    Member
    Posted 3 years ago #

    I also tried disabling all plugins, switching themes, switching browsers, installing a different visual editor.
    nothing yet

  21. pdsketchbook
    Member
    Posted 3 years ago #

    andregaleos - i finally got the visual editor working by 1. disabling all the plugins 2. reinstalling wordpress(automatic install) 3. enabling plugins 1 at a time until i found the culprit....in that order.

    btw, i still can't get ckeditor to work but at least i have the basic editor working.

    good luck

  22. andregalegos
    Member
    Posted 3 years ago #

    First excuse me for English (Google translator).
    I followed the steps. But do I the Visual Editor of wordpress did not work.
    I installed the plugin CKEditor for wordpress , and it worked.
    At least now I can edit.
    Thank you very much

  23. plant802
    Member
    Posted 3 years ago #

    No WYSIWYG, no "Quick Edit" after moving from MAMP development environment to live server. Same version of WP (3.1.1). Tried all the fixes above (Plugins on/off, fresh wp-admin and includes folders, checked permissions on tiny_mce files). Won't run any 3rd party editor plugin either. Did anyone ever solve this? It has to be something in the server vs. WP but...seems like a serious WP instability to me. Will be a deal-killer on future WP projects as I can't hand over a site to a client w/o WYSIWYG. :-(

  24. bulpal
    Member
    Posted 3 years ago #

    I had the same problem when I upgraded from 3.0.4v4 to 3.1.1 on a fresh WP install so
    no plugins were active and using the default theme. Tried re-installing the wp-admin and wp-includes but no effect. The solution was that given by godlikemouse. I didn't create a symbolic link but just copied the wp-langes-en.js as en.js.
    Many thanks godlikemouse.

  25. mellanedavies
    Member
    Posted 3 years ago #

    Many thanks to all who took the time to solve this issue and than post about it! I have been looking for a solution for weeks now and finally reached my goal. Thank you again especially to godlikemouse and bulpal!

Topic Closed

This topic has been closed to new replies.

About this Topic