WordPress.org

Ready to get started?Download WordPress

Forums

WYSIWYG Editor Not Showing (15 posts)

  1. domue
    Member
    Posted 6 years ago #

    Dear community,

    All of a sudden, my blog's visual editor is not showing anymore. I can only make posts and edit them in the CODE editor, currently. Also, some special characters in the blog posts are not showing correctly anymore. They're now some sort of strange #ä"§($ etc.

    I really don't know how to fix this, as I've already installed the new WP version (the problem had started while using WP 2.1.3) and it still doesn't work. It's work in all of my blogs but this one, and I haven't changed or broken anything as far as I can tell.

    This is my main blog, so I'm really dependent on your help and it will be highly appreciated!

    Looking forward to your replies. Thank you so much!

  2. Chris_K
    Member
    Posted 6 years ago #

    If you visit Users -> Your Profile, is the top option checked?

  3. domue
    Member
    Posted 6 years ago #

    Thanks for your help, HandySolo. Feeling a bit stupid now as I really should have seen it. ;) So no, the option was not checked.

    Unfortunately, the special characters are still showing up as some obscure letter combinations and I guess I'll have to fix it in the posts manually, or has this happened to anybody before too, and if yes, do you know how one can fix it?

    Thank you again.

  4. holocron
    Member
    Posted 6 years ago #

    I'm having this problem as well. I first noticed it when I upgraded a site to 2.2.2. then I went and checked a site that is still on 2.2.1.

    And I've looked at both of these with two different computers. No RTE/TinyMCE. I even installed TinyMCE-Advanced on the 2.2.2 install and that doesn't work.

    IS it possible that java was deactivated on the server side somehow?

  5. Chris_K
    Member
    Posted 6 years ago #

    No java is involved.

    Javascript is, and that would be totally client side. have YOU deactivated it in your browser? If so, turn it back on.

    Any security suites on your machine keeping you safe by blocking evil web stuff? Turn 'em off and try.

    Clear your browser's cache (what browser, btw?).

    Make sure the wysiwyg is on (my earlier post in this topic).

  6. holocron
    Member
    Posted 6 years ago #

    No, java is not deactivated in my browser.

    No security suite blocking it. It worked prior to upgrade and this is repeatable on different machines. (Oddly another user of the same website that logs on from the same machine as me still has RTE.)

    Cache cleared. Java cache cleared.

    WYSIWYG is checked on for all users.

    I'm using Firefox 2.0.0.6

    UPDATE: I just booted up an NEW install of Ubuntu I did last night on a separate computer. Using Firefox 2.0.0.6 on Ubuntu I logged on and had the same problem. No RTE. No "Visual" or "Code" tabs. Just a text field when writing a post.

  7. Chris_K
    Member
    Posted 6 years ago #

    WYSIWYG is checked on for all users.

    Humor me: Check for YOUR user. Users -> Your Profile, top checkbox?

  8. longtex
    Member
    Posted 6 years ago #

    PMFJI - I'm fighting a different problem, but this exchange made me take a look at mine. I'm curious as to "top" checkobx - my 2.2 user profile has only one checkbox (the rtf one) and it's at the -bottom- of the page. So... "top"??

  9. Chris_K
    Member
    Posted 6 years ago #

    That doesn't sound like 2.2!

    "Use the visual editor when writing" should be at the top for 2.1 and up.

  10. longtex
    Member
    Posted 6 years ago #

    The footer says 2.2 - does it come from elsewhere?

    Just putty'ed over to it (on daughter's Windoze box) and profile.php is dated 1/18/2007

  11. longtex
    Member
    Posted 6 years ago #

    Curiouser and curiouser... I started comparing times and sizes of files from the WP2.2 distro zip with what's in their blog dirs, and I'm seeing several .js files in the blog that aren't in the distro. I'm assuming (so far) they must have one or more plugins that have added code to wp-admin... perhaps that's where an "old" profile.php would have come from...

  12. holocron
    Member
    Posted 6 years ago #

    @handysolo:

    Humor me: Check for YOUR user. Users -> Your Profile, top checkbox?

    Yes, it is checked for MY user. I unchecked it. Saved changes. Then rechecked it and saved. Confirmed that it was checked on MY user and still nothing.

  13. holocron
    Member
    Posted 6 years ago #

    Another thread indicated that a "realpath" setting server side might be an issue. Any thoughts on that?

    Also another indicated that it might be a stuck value in the database for these users. But I'm having trouble finding the data in the database.

  14. holocron
    Member
    Posted 6 years ago #

    Hmmm, this seems to be promising and that it is an error in the version of Tinymce that is included with WP. I'll try the update and see if that helps.

    Update: must be server side...replacing the files didn't help.

  15. RmREoI9Le
    Member
    Posted 6 years ago #

    I had a problem with the tinymce visual editor as well. The edit options were not showing in the editor and there was not an "enable visual editor" option under the user profile. It turns out that in Win 2003, maybe other versions as well, some files are "blocked" when extracting out of a zip file.

    The problem was that the js files were not being extracted and copied to any WordPress directory - though the other files were. The web site "worked" for the most part but a few things like the editor didn't.

    I solved this problem by:
    1. Uncheck the "block" properties for the zip file; it is on the properties for that file (right-click, properties). You should see a message like "Windows has blocked access to these files to protect your computer" under properties.

    2. After unblocking the files delete the original temp directory where the files were extracted to originally and then re-extract the files.

    3. Next, re-install all the WordPress directories/files

    Now, the editor worked.

    Win 2003, IIS 6, PHP 5.2.5

Topic Closed

This topic has been closed to new replies.

About this Topic