WordPress.org

Ready to get started?Download WordPress

Forums

WYSIWYG editor in Firefox broken (missing buttons) (8 posts)

  1. bothermenot
    Blocked
    Posted 8 years ago #

    hi-

    i installed wordpress and it seems to work... except for the WYSIWYG toolbar for writing new posts in firefox.

    here is a screenshot showing how the toolbar is different... it's missing lots of buttons:

    http://img122.imageshack.us/img122/7529/toolbar8jv.jpg

    why is this happening? anyone have any ideas?

  2. Eissoorg
    Member
    Posted 8 years ago #

    This is happening on my WP too. But not even on IE this bar appears.

    Does anybody know hot to fix this?

  3. Eissoorg
    Member
    Posted 8 years ago #

    I just got the answer. Here it goes:
    "Please try re-uploading your wp-includes and wp-admin directories. It's possible that all the files didn't make it."

    This worked for me.

  4. devilmaycry
    Member
    Posted 8 years ago #

    Same here, simply re-uploading the files worked a treat.

  5. Anne-Lise
    Member
    Posted 7 years ago #

    This worked for me for the WP2.0.+ versions. With 2.1 it didn't work. I get the visual rich editor in two of my blogs in the other two however I don't. I checked and double checked if all the files where there and if they had the correct size and they had. So what can be the problem? And how do I solve it?

  6. stevejohnson
    Member
    Posted 7 years ago #

    Anne-Lise, try dumping your browser cache. In IE, Tools > Internet Options, click on the 'remove temporary internet files' button. In Firefox, Tools > Options > Advanced > Network then the 'clear now' button on the cache line.

  7. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    One person who had this problem recently had an ad blocker or some other kind of javascript blocker interfering. The new 2.1 uses a lot of javascript code, so it's recommended that you add your site to any whitelists you may have, or disable those sorts of things in some way.

  8. Anne-Lise
    Member
    Posted 7 years ago #

    It was indeed a 'problem' with Adblock. It turned out I had already switched that plugin off in for the blogs where the wysiwyg editor worked. Thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags