WordPress.org

Ready to get started?Download WordPress

Forums

WYSIWYG Editor For WordPress Update (18 posts)

  1. Joe
    Member
    Posted 9 years ago #

    Just a notice that I posted a new version of Wysi-Wordpress to my site today. The editor now includes clickable smilies/emoticons.

    http://mudbomb.com/archives/2005/02/02/wysiwyg-plugin-for-wordpress/

    -------------------------------------
    This plugin replaces the WordPress "quicktags" with a wysiwyg(what you see is what you get) editor in IE and Mozilla. It allows you to format post text just as you would in any word processor or email program.

  2. XeroCool
    Member
    Posted 9 years ago #

    Great :)

    A problem im having is with HTML. I add a small code to this img:

    <img src="blah blah.png">

    Thats how it is right now an when I add:

    <img src="blah blah.png" style="margin:1em;" alt="" />

    It doesnt update. Even after I click save and update.

  3. Joe
    Member
    Posted 9 years ago #

    The old version didn't "like" inline styles on images. This is fixed in the new version. :-) Download it at the same link above.

  4. sgazzetti
    Member
    Posted 9 years ago #

    Slightly off-thread, but I'm also experiencing a problem with WYSI. Bear in mind that I'm brand-new to WP, so this question is probably as basic as could be.

    I've got WYSI installed and running as a plug-in with no problems, except for the image browser. When I click on the icon, the box opens and at the top of it the pull-down menu lists the folder where my pictures are, but at the bottom, in the 'image upload' area, it tells me "library doesn't physically exist".

    So my questions are 1) does WYSI see a difference between a directory and a library? and 2) what is that difference and what can I do about it?

    Otherwise I think WYSI is extremely elegant in its simplicity (a real plus for such an abject beginner), but I'm getting a bit bent by my repeated failures to insert pictures in entries.

    I'm running WP 1.5 with WYSI-Wordpress 2.0, installed according to the readme, and Firefox 1.0.

    Thanks in advance to anyone who can help me up this learning curve.

  5. BillRamby
    Member
    Posted 9 years ago #

    @Joe
    Quick question about the screenshot on your site. How did you get the editing area so large?

    Probably something simple that I'm missing, but the default small editing area is frustrating to me.

  6. BillRamby
    Member
    Posted 9 years ago #

    Nevermind, I found it.

    Regards
    Bill R.

  7. PirateKing
    Member
    Posted 9 years ago #

    I have a suggestion for the next version of WYSI-Wordpress.
    Let me turn it on or off within the editor. I have some people who post on my site that want to use it, and others that don't. Can you adapt the plugin so that it defaults to on or off, and there is a quicktag button to toggle as necessary while editing?
    Even if you can't make it "on the fly" while a post is actually in progress, just a way to leave it off unless the quicktag button is pressed would be great. I'm looking into what would be necessary for that now...

  8. BillRamby
    Member
    Posted 9 years ago #

    Would it be possible to add a "Tables" feature to WYSI-Wordpress? Something simple like a dialog to ask rows and column's that then inserts the code?

    Regards
    Bill R.

  9. PirateKing
    Member
    Posted 9 years ago #

    I have come up with a modification to wysiwordpress.php so that you can disable the editor at will. It isn't an on/off toggle or anything, just a simple way to turn off the WYSI-Wordpress without losing any data.
    Add to the wywiwordpress.php before the add_action lines:

    function wysi_add_button()
    {
    if( (!strstr($_SERVER['PHP_SELF'], 'post.php') && !strstr($_SERVER['PHP_SELF'], 'page-new.php')) || $_GET["action"] == 'editcomment' )
    return 0;

    echo <<<END
    <script language="JavaScript" type="text/javascript">
    <!--
    document.getElementById("quicktags").innerHTML += "<input type=\"button\" class=\"ed_button\" id=\"ed_list\" value=\"!WYSI\" onclick=\"tinyMCE.removeMCEControl('mce_editor_0');\");\" />";
    //-->
    </script>
    END;
    }
    add_action('admin_footer', 'wysi_add_button');

  10. Dalby
    Member
    Posted 9 years ago #

    PirateKing,

    That's a great mod especially as I am stuck on a 28Kbps dialup.

    Is there a way to make OFF as the default mode as I only use the editor occasionally because of the time it takes to download it each time?

    Thank you.

  11. PirateKing
    Member
    Posted 9 years ago #

    I wish I could tell you there was. That is what I spent most of the day working on. However, it appears that if the code isn't initiated as the page loads, for some reason the whole page goes blank when activated. I am still going to work on it, and hopefully find a definitive answer quickly.

  12. Dalby
    Member
    Posted 9 years ago #

    Thanks for the answer.

  13. PirateKing
    Member
    Posted 9 years ago #

    Woo hoo! I found it!
    Sort of. It won't stop it from having to load the ~100k javascript file, but it will prompt you to use it. When you load the page, it will not fully initialize. But when you tab or click into the editing area, it will ask you once if you want to use the wysiwig editor.
    In the plugins/Wysi-Wordpress folder, edit the wordpress.js file. add the following line:
    ask : true,
    somewhere in the middle of the init. I put mine under the relative_urls line. But this is a great compromise!

  14. PirateKing
    Member
    Posted 9 years ago #

    OK... one more thing. Apparently the TinyMCE source file and the standard loading file are too different.
    You have to make one more change, which unfortunately makes the download about 24k longer.
    In the wysiwordpress.php file in the plugins folder, you have to change it from loading the Wysi-Wordpress/tiny_mce.js to the Wysi-Wordpress/tiny_mce_src.js file instead.
    Takes a little longer to load, but works better.

  15. sicro
    Member
    Posted 9 years ago #

    Nice editor. Exactly what I was looking for.

    Thanks.

  16. rshol
    Member
    Posted 9 years ago #

    Problem with install.

    -Downloaded Wysiwyg for WordPress 1.5.zip from mubomb.com.
    -Extracted contents to a directory on local machine.
    -uploaded wysiwordpress.php and entire contes of folder Wysi-Wordpress to ~/wp-content/plugins.
    -Went to the plugin admin page for my blog, got an error message about permissions related to Wysiwyg.
    -Changed permissions on wysiwordpress.php to 775.
    -Went back to the plugin admin page wysiwordpress entry looked normal, clicked activate it appeared to activate.

    But, no Wysiwyg editor in the write section, just the same interface as before. Any clue as to what I did wrong?

  17. rshol
    Member
    Posted 9 years ago #

    Permission problem, chmod -R 755 on ~/wp-content/plugins/Wysi-Wordpress and things work fine now. Don't know if those are optimal permissions from a security standpoint though.

  18. Joe
    Member
    Posted 9 years ago #

    Apologies to anyone who tried to post a comment on my site yesterday. I'm working on a new anti-spam hack and because of some bad code, everyone trying to comment got the message: "You are a rotten blog-spamming bastard. Go away." LOL

    Should be fixed now(crosses fingers).

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags