WordPress.org

Ready to get started?Download WordPress

Forums

WYSIWYG editor does not work with 2.1 !!!!!! (40 posts)

  1. ginoxy
    Member
    Posted 7 years ago #

    Hello ,

    just upgraded from 2.0.6 to 2.1 it is a nice version and i like it, so far everything is OK with me but seems that WYSIWYG editor is not working correctly with WP 2.1

    now im not able to write/upload anything unless i deactivate it

    any idea how to fix this problem ?

    Thnaks in advance

  2. Sjayne
    Member
    Posted 7 years ago #

    Is it that you haven't turned it on? You have to go into your profile and enable it.

  3. ginoxy
    Member
    Posted 7 years ago #

    Well as i said before editing works fine if WYSIWYG deactivate but if its ON non of the editing will be saved !

  4. AussieSapphire
    Member
    Posted 7 years ago #

    I am having same problem. Draft posts load normally and I can save if visual editor not turned on. As soon as I turn it on (I would prefer to use it), everything disappears as soon as the buttons load up on the editor.

    This was auto upgrade from 2.0.6 to 2.1 on my host. I am seeing "Done with errors on page" message at bottom of page.

    Temporarily deactivated my plugins and cleared cache - no change.

    Help please.
    Leah

  5. buggs
    Member
    Posted 7 years ago #

    I too am having problems with the visual editor. When I click to publish it does not publish anything. It works Ok without the WYSIWYG editor option.

  6. ginoxy
    Member
    Posted 7 years ago #

    okay now i need to upload pictures without FTP progs. any other idea ?

  7. opaco
    Member
    Posted 7 years ago #

    Same problem too. When upgrading from 2.0.6 to 2.1 everything ran fine until I played around with discussion settings to disallow readers to post comments. At this point, editor only saved title but not post and couldn't switch between visual and code.
    I tried it to be solved allowing comments back but it failed.
    Now, the only way to save and publish posts is disabling visual editor from User Profile.

  8. buggs
    Member
    Posted 7 years ago #

    This is horrible too many problems, why would they release such unstable/bugged upgrade? Visual editor not working, link page not working, etc, , ,
    Good thing I backed up, went back to the original version, all back to normal now.

  9. tidruG
    Member
    Posted 7 years ago #

    I'd like to bump this topic please. I upgraded from 2.0.7 to 2.1 and am facing a somewhat similar problem. I can see the visual editor, but clicking on the Code button does nothing. Also, anything I post doesn't display, although comments work.

    I am on a server with PHP 4.4.4 and also a supportive mySQL (I can see all the old posts, just have a problem making new ones)

  10. wpvince
    Member
    Posted 7 years ago #

    Brand new install of 2.1 using Fantastico
    Anything I creat, gives a page not found.
    Not sure if related bug to everyone else here.

    - V

  11. bdieu
    Member
    Posted 7 years ago #

    When I activate the rich editor option, I see neither the
    the WYSIWYG nor the Code. When I uncheck it, I see the code but not rich editor. Go and figure.
    B.

  12. spammerhamster
    Member
    Posted 7 years ago #

    I had the same problem. I had to dive into the database and set the RT-editor value to true in the options table.

    Normal users weren't affected, only admin.

  13. Chris_K
    Member
    Posted 7 years ago #

    spammerhamster - wouldn't Users -> Your Profile and checking the box at the top of the page (use the rich editor) have worked a bit easier?

  14. AussieSapphire
    Member
    Posted 7 years ago #

    HandySolo,

    I think what I and others in this thread are trying to say is that checking the box in My Profile to visual editor does not work - ie. for me, it did work to make WP2.1 use the visual editor but that the editor did not actually work properly.

    I have given up and rolled back to my previous version. A couple of the new features would have been nice but I can live without them if it means actually being able to write and edit posts.

    Two killer problems for me:
    * cannot work out how to get the visual editor to work at all,
    * cannot upload images (keeps asking me to login unsuccessfully)
    * and the search pages plugin does not work with 2.1 (the alternative "searcheverything" plugin does not work with either of the two themes I have selected for 2 sites I maintain).

    cheers

  15. robertocasiraghi
    Member
    Posted 7 years ago #

    I just can't use the new version, it's full of bugs and is unpredictable in its general behaviour. My worst problem is managing categories but after wasting almost a whole day trying to understand what's wrong I've just decided to keep my old installations, abstain from upgrading until a new stabler version comes along, which I hope will be very soon.

    What I find horrible in the present situation, is the amount of cover-up moderators are showing. Maybe cover-up is too strong a word but you know what I mean. Announcing a bugs fix release wouldn't be such a bad PR move, dear Moderators. Microsoft is no longer ashamed to admit their problems, why should WordPress?

  16. Chris_K
    Member
    Posted 7 years ago #

    Dear roberttocasiraghi - Moderators have zip, zilch and nada to do with determining what goes into a release and when a release is turned loose.

    We're here to solely to offer support. To help. (as volunteers and unpaid, I might add). We're not here to "cover-up" or act as PR.

    And if you think mods don't mention problems, you've clearly not been here long.

  17. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    @AussieSapphire: I think what I and others in this thread are trying to say is that checking the box in My Profile to visual editor does not work - ie. for me, it did work to make WP2.1 use the visual editor but that the editor did not actually work properly.

    I think we all understand that, but here's the thing: It does work for me and a whole lot of other people.

    All the people whom I've helped with this issue had problems with their browsers, somehow. Either greasemonkey or an adblocker or a javascript blocker was messing with it, or they needed to clear their cache, or something else along those lines.. I'm not saying that this necessarily is the problem you're having as well, but I've been able to get the thing to work on every machine I've tried it on.

    The new editor is very heavy on the javascript. If you have anything interfering, it will probably break. That can't be helped, your browser doing weird things is sorta your problem. Clear your browser's cache's. Try turning off adblockers. Don't go through proxies. Enable javascript. Make sure you uploaded *all* the files from the WordPress ZIP file to your site (including all the JS files). Whatever works, yeah?

    Or don't. Turn off the visual rich editor and use the normal one. It will work without any of that stuff. Not as pretty, but hey.

    @robertocasiraghi: I just can't use the new version, it's full of bugs and is unpredictable in its general behaviour.

    Then don't use it. Look, I think it's great. It makes things a lot more consistent, it's a lot faster, and I find it to be a lot easier to use. But if you don't like it, then that's okay with the rest of us. Stick to 2.07. Or switch to a different blog package. The fundamental thing that you have to understand is that *we don't care* about what you do. That's your call.

    If you do want to try to use 2.1, and need some help, I'm more than willing to help you with any problems you may be having. But taking some kind of attitude that the people on this site somehow owe you because you're using a piece of free software, well, that's just uncalled for.

    @robertocasiraghi: Announcing a bugs fix release wouldn't be such a bad PR move,

    Find a bug, submit it to trac, and maybe it'll get fixed. Or fix it yourself and submit the fix. Or whatever. This is free software. Until you pay somebody for it, your room to complain and assume this kind of attitude is extremely limited.

  18. till
    Member
    Posted 7 years ago #

    I have a question, I upgraded from 2.0.5 to 2.1 this morning and it looks like the rich text editor is more broke than ever.

    I am trying to deactivate it, but the option is MIA in Options > Writing. There used to be a check box, which is now gone.

    I searched the wp_options table for anything with *rich* in the option_name column - nothing.

    I also tried to manually insert it into wp_options - did not working (probably missing some context here).

    Also, when I switch inside the interface to "code", that box is all the way to the right. The styling of the interface seems to be broken there. Switching back and forth makes it worse. ;-)

    (System: Mac OS X, Firefox latest)

    I'd like to get rid off the editor. So what's going on? My last resort is switching to Safari to blog, because Safari does not support the editor.

  19. Chris_K
    Member
    Posted 7 years ago #

    Users -> Your Profile.
    Top checkbox.

    (as mentioned earlier in this very thread)

  20. till
    Member
    Posted 7 years ago #

    Must have overread that. Thank you!

    Did anything occur on how to fix this issue? Because some of the writers will want to have it pretty.

  21. Chris_K
    Member
    Posted 7 years ago #

    Assuming no FF plugins (adblock, some greasemonkey scripts) are in the way, I'd suggest trying a good ol' fashioned ctrl-F5 while on the Write screen. Forcing the reload gets the proper CSS (instead of the old cached) loaded.

  22. ilbliege
    Member
    Posted 7 years ago #

    In fact, I had only one problem : I didn’t see the WYSIWYG section.
    It was not because of the browser and JAVA or the checkbox in the profile section !
    It was the “WordPress Plain Text Paste Plugin Version 0.3″ (see http://www.ndsinternet.com/blog/archives/2007/01/wordpress-plain-text-plugin.
    Activated, I didn't see the WYSIWYG. Deactivated, all is ok.

  23. c-ray
    Member
    Posted 7 years ago #

    Try blogdesk another similar tool, but make sure your password is under 10 characters. I'm using it with 2.1

    http://www.blogdesk.org/en/download.htm

  24. RadioFreeAmsterdam
    Member
    Posted 7 years ago #

    Just upgraded to WP 2.1 and when I want to switch from 'visual' to 'code' I get this error message:

    Stack overflow at line:500

    What does that mean? And more important, HOW to solve this?

  25. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    That would likely be a javascript problem, and I suggest clearing your browser cache. It's entirely possible that some javascript from the old version is leftover in your cache, and until you clear it out and force it to load the new stuff, you can get weird random errors.

  26. RadioFreeAmsterdam
    Member
    Posted 7 years ago #

    That does not solve it, I was using IE7 and switched to Firefox and in firefox it also doesn't swich between 'visual' and 'code' and when I click 'save and continue editing' I get the 'are you sure you want to navigate away from this page' box pop up and when I clcik yes the new post just vanishes. Either way, it does not let me post.

  27. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    Well, if clearing the browser doesn't solve it, then you don't have all the files on your server, or have the wrong files on the server, or something. Because the editor does work for me in every browser I have available to test with. It does require the ability to download a lot of javascript from your server though, so if any of it is missing or otherwise unavailable, the results can be weird.

  28. squatter
    Member
    Posted 7 years ago #

    My experience : Yes, I did get messed up pages initially after upgrade but a refresh sorted this out. I did have problems with Firefox (not IE7) and the Dashboard admin page where it would not display the wordpress notices stuff but complain about "The number of request header fields exceeds this server's limit". In "about:config", I changed "network.http.sendRefererHeader" from 2 to 1 and this problem disappeared.

    When writing, the visual option was not available. I am sure I was using this before but had to go to "Options,My Profile" to enable it. Then everything was fine. I probably fiddled for a couple of hours to achieve these 2 successes, fiddles I had never had to do before on previous upgrades.

    I accept that by using free software, from time to time I may have to sweat over something but historically, the user community usually sorts everything out in the end, and no slower than many commercial vendors.

    I live in a remote location so upgrading my server on the other side of the planet is a bit harder than it used to be. Note that I upgraded from 2.0.4 to 2.1

  29. jamalak
    Member
    Posted 7 years ago #

    Hi,

    I had the same WYSIWYG problem with IE & Firefox. After deactivating all plugins and reactivating them one by one I manage to figure out that it was WP-ContactForm 1.4.3 that was posing problems.

    Hope it will help

  30. thehuby
    Member
    Posted 7 years ago #

    I don't have any plugins installed (fresh install and new to WordPress) and my posts have two tabs, Visual & Code - neither seems to do anything and I have double checked that I have the visual editor thing turned on (if I don't have it on then I have the more simple HTML building one).

    Got a screen grab here: http://002.e-connected.com/wordpress_issue.png

    When I had previously played with a WordPress blog the WYSIWYG editor had worked 'out of the box' - I have no plugins (the default ones are in there but are disabled).

    I have used the JavaScript console in FF and found two issues with the tiny_mce_gzip.php file:

    "s has no properties" with reference to this line of code:
    trim : function(s) {return s.replace(/^\s*|\s*$/g, "");},

    and

    "editorTemplate has no properties" with this line of code:
    _onAdd : function(replace_element, form_element_name, target_document) (snipped the code to make it tidy)

    Is this something that can be passed onto the dev team to help them?

    There are a shed load of CSS issues but I assume these wouldn't effect it.

    I am getting the same issue in FF and IE6

    If I wanted to install a previous version, how would I get hold of one?

    Thanks,

    Rick

Topic Closed

This topic has been closed to new replies.

About this Topic