WordPress.org

Ready to get started?Download WordPress

Forums

www vs. public_html folder--source of errors? (13 posts)

  1. joelwalsh
    Member
    Posted 9 years ago #

    I get this error on my site, http://endometrialcancer.org even though the folders are indeed there and chmodded to be server-writable. Could the problem be that the site is in the www folder rather than the public_html folder? My web host says no.

    It doesn't look like you can use the file upload feature at this time because the directory you have specified (/home/endometr/public_html/wp-content) doesn't appear to be writable by WordPress. Check the permissions on the directory and for typos.

  2. Jonathan Dingman
    Member
    Posted 9 years ago #

    I'm not seeing an error on this site, is this still a problem?

  3. joelwalsh
    Member
    Posted 9 years ago #

    The error is in using the file upload module; it's not something I think you'd see on the site itself unless you're logged in (did you see file upload anywhere on the site?).

    The file upload feature is in the admin panel.

    Anyway there are a number of plugins that return error messages referencing public_html when I try to install them.

    Thanks

  4. Mark (podz)
    Support Maven
    Posted 9 years ago #

    www=public_html
    One and the same thing (in 99.99999999999% of cases)

    I'm guessing that you have put a path where a url is wanted.

    because the directory you have specified (/home/endometr/public_html/wp-content)
    that should be
    http://endometrialcancer.org/wp-content/

  5. joelwalsh
    Member
    Posted 9 years ago #

    Thank you for the advice. But I haven't written in anything, I don't think, except maybe wp-config, and that only asks for the database name. Am I missing something? It's all been done automatically otherwise.

    As for www=public_html, I don't really understand the whole thing except that when I FTP, the www folder is full, and the public_html directory is empty except for two folders I can't delete. Plus, it's a common problem that search engines tend to see http://www.domain.com and domain.com as different. And have seen sites where http://www.domain.com yields something different from domain.com

  6. joelwalsh
    Member
    Posted 9 years ago #

    Another note, according to the receipt from Fantastico, the WP database in question was installed in public_html, which pretty much takes the issue of file paths out of my control:

    Full installation path: /home/endometr/public_html Public URL: http://endometrialcancer.org/ Admin URL: http://endometrialcancer.org/wp-admin/

  7. Mark (podz)
    Support Maven
    Posted 9 years ago #

    http://endometrialcancer.org/wp-content
    That shows permission errors ?

    Have you chmod'd /home/endometr/public_html/wp-content to 777 ?

  8. joelwalsh
    Member
    Posted 9 years ago #

    Yes, the directory has been chmod'd to 777 all along.

  9. Mark (podz)
    Support Maven
    Posted 9 years ago #

    If WP says the folder it's trying to use does not have the right permissions, it's never wrong.
    How are you changing the permissions ?
    What is showing the permissions ?

  10. joelwalsh
    Member
    Posted 9 years ago #

    I was using ftp to chmod it.

    Of course, it's not /home/endometr/public_html/wp-content

    It's

    /home/endometr/www/wp-content

    And I think that's the source of the problem. Are you sure that www vs. public_html has no effect?

  11. In 99.999999% of cases, www is actually a shortcut to your public_html folder.

  12. CuongMC
    Member
    Posted 9 years ago #

    I can believe that there're so many posts about the upload features of WP. But in somehow, i dont know why i still have the problem like this:

    It doesn't look like you can use the file upload feature at this time because the directory you have specified (/home2/cuongmc/public_html/wp-uploads) doesn't appear to be writable by WordPress. Check the permissions on the directory and for typos.

    I've created an folder named: wp-uploads in public_html and CHMOD it to 777.

    In my Miscellaneous Options i set:
    Destination directory: /home2/cuongmc/public_html/wp-uploads
    URI of this directory: http://www.cuongmc.com/wp-uploads
    and checked Allow file uploads

    So where is the problem anyway? Anybody help me! Thank you very much.....

  13. joelwalsh
    Member
    Posted 9 years ago #

    I'm still having the exact same problem. Anyone know if this is hidden somewhere in the codex?

Topic Closed

This topic has been closed to new replies.

About this Topic