WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WWW to non-WWW fail on FireFox 3.6, OK on IE8 (5 posts)

  1. Tomas Mackevicius
    Member
    Posted 4 years ago #

    Hello everybody,

    I'm testing beta an so far no big problems :)

    Only thing that caught my attention is fail to load site when using WWW version of the address. Interesting, this problem is only on FireFox 3.6.3, IE 8 loads page to non WWW just fine.

    I have about 5 blogs (WP 2.8.4) on the same server with the same settings and all of them convert www also w/o problems. For that purpose I'm using .htaccess lines:

    RewriteEngine On
    RewriteCond %{HTTP_HOST} .
    RewriteCond %{HTTP_HOST} !^site.org$ [NC]
    RewriteRule ^(.*)$ http://site.org/$1 [R=301,L]

    I see that .htacces on 3.0 beta-1 now has one additional line:

    RewriteRule ^index\.php$ - [L]

    So I was trying to disable all my inintial 4 lines, thaen enable those, but disable RewriteRule ^index\.php$ - [L], but all variations gave me same result fail on FF, OK on IE.

    Can anyone give suggestions how to fix it?

    Website in question is http://www.starcraftlt.com

    now all rules are enabled:

    RewriteEngine On
    RewriteCond %{HTTP_HOST} .
    RewriteCond %{HTTP_HOST} !^site.org$ [NC]
    RewriteRule ^(.*)$ http://site.org/$1 [R=301,L]

    and

    RewriteRule ^index\.php$ - [L]

  2. Seeing as that's NOT a problem in Firefox 3.6.2 (using that right now, no issues), I'm thinking it's Firefox or your server.

    I'm downloading 3.6.3 now :) I do the same thing on one of my sites, so I'll find out fast!

  3. Tomas Mackevicius
    Member
    Posted 4 years ago #

    Thanks, will wait for your results! I don't know if it's really FF, because my five 2.8.4 blogs on the same server with the same .htaccess files redirect just fine??

  4. Okay, your site and mine are fine on 3.6.3

    This may be your computer....

    I'd re-download firefox.

  5. Tomas Mackevicius
    Member
    Posted 4 years ago #

    Ipstenu, thanks for your time, most likely you're right. When you said, that FF is OK on your PC, I thought it may be related with one of the FF add-ons, so I was disabling them one by one, restarting FF and checking again, but after disabling all of them, and even starting FF in safe mode, problem persisted...

    Finally I started FF as the administrator (I always work on simple user account) then everything was working as it should!

    So, most likely this is isolated problem on my machine. Thanks again for spending some time!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.