WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WWW issue with Multisite [Too Many Redirections] (6 posts)

  1. dexpositoromero
    Member
    Posted 1 year ago #

    Good evening everybody,

    We have recently moved a WP Network to a GoDaddy reseller. We found out the we have to create the subdomains manually (we have subdomain based Multisite).

    The problem is that none of the the domains work with "www"
    If I add the usual redirect in the htaccess, I get a "Too many redirections error"

    Curiously enough, the main site appear on the list of site as http://www.mainsite.org and thus, it's the other way around, I can't access it without www (I guess the previous admin created it with www?).

    I have contacted the support but there's not answer about it. Any ideas?

    Thank you very much in advance

  2. Are these subdomains with www or mapped domains?

  3. Go Daddy
    Go Daddy Support
    Posted 1 year ago #

    We could also take a look at this end if you can provide the domain name. If you aren't comfortable posting it publicly, you can submit a support ticket at http://go.me/WPemail

    Once you have ticket number, you can post that here instead and I can pull the ticket and have it reviewed for you.

    ^Cj

  4. dexpositoromero
    Member
    Posted 1 year ago #

    Hi Go Daddy!

    Thank you very much for the follow up. I have open a ticket with incident ID: 18109985

    Should I open a new one through that link )don't want to cause duplicated tickets, I know how annoying it is).

    Regards,

    Daniel

  5. Go Daddy
    Go Daddy Support
    Posted 1 year ago #

    It looks like our Support Team replied to your ticket recently. If the response you received does not fully resolve your issue, please reply to the email with what remains unresolved. This way the ticket will be reopened and our technicians can continue to assist.

    Thank you,

    Jeremi

  6. dexpositoromero
    Member
    Posted 1 year ago #

    After a few emails with the support I managed to make it work. I will leave the anser here for future searches.

    The automatic www redirect to non-www doesn't work. You can, however, create manual redirects for each subdomain.

    In order to do that you have to access your domain manager (in Resellers account it's under your account > Domain > Launch.

    Once there, select your domain and click on Forward > Forward Subdomain
    A lightbox window will open. Click on Add Subdomain

    You have to fill the first field with http://www.subdomain
    On the second row, select http or https and fill the field with the subdomain without www: subdomain.yourdomain.com

    If you go to advanced option you can change the default Permanent Redirect to a temporary one. Also chose "masking" (if you do so, you can enter a custom title, desc. and keywords).

    Click OK.

    It will take up to 48 hours to get live (when I created it, it took a while to get it working).

    Hope it helps ;)

    Dan

Topic Closed

This topic has been closed to new replies.

About this Topic