WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
Wrong title / description in Google (11 posts)

  1. Niels t.s
    Member
    Posted 1 year ago #

    WordPress version: WordPress 3.5.1
    WordPress SEO version: 1.4.1

    I did this:

    We have a problem with the indexation of our website http://www.hengelsportdeal.com in Google.

    I expected the plugin to do this:

    For example this page: http://www.hengelsportdeal.com/karperhengels/

    The Yoast title and description that u used (for this page) are:

    SEO title: Karperhengels | Informatie over soorten karperhengelsSEO description: Karperhengels zijn er in vele soorten en maten. Daarom moet je bij de aanschaf van een karperhengel eerst weten op welke manier je wilt gaan vissen.

    Instead it did this (when i search for this url in Google):

    SEO title: Karperhengels - Hengelsportdeal.com
    SEO description: Karperhengels zijn er in vele soorten en maten. Daarom moet je bij de aanschaf ... Go to: http://www.facebook.com/hengelsportdeal. Skip to content. Dagdeals ...

    Can someone please help me with this problem and explain what to do?

    Thanks in advance!

    Niels

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. THWIT
    Member
    Posted 1 year ago #

    I have also problems with the SEO page titles.
    Problems started with version 1.4.*

  3. Niels t.s
    Member
    Posted 1 year ago #

    It's strange because the source code for the page looks like this:

    <!-- This site is optimized with the Yoast WordPress SEO plugin v1.4.1 - http://yoast.com/wordpress/seo/ -->
    <title>Karperhengels | Informatie over soorten karperhengels</title>
    <meta name="description" content="Karperhengels zijn er in vele soorten en maten. Daarom moet je bij de aanschaf van een karperhengel eerst weten op welke manier je wilt gaan vissen."/>
    <link rel="canonical" href="http://www.hengelsportdeal.com/karperhengels/" />
    <meta name="robots" content="noodp,noydir"/>
    <!-- / Yoast WordPress SEO plugin. -->

    Does anybody know how to solve this problem?

    I have tried a lot of things but nothing seems to work..:(

  4. THWIT
    Member
    Posted 1 year ago #

    If I were you I would download the old version (1.3.4.4, it think this is the last version that worked or me).

    After I downloaded this old version everything worked again.

  5. Niels t.s
    Member
    Posted 1 year ago #

    Do you know where i can download this version (1.3.4.4)?

    I'd rather like to know what the cause of the problem is instead of using an old version.

  6. THWIT
    Member
    Posted 1 year ago #

    You can download the old version here: http://wordpress.org/extend/plugins/wordpress-seo/developers/

    I understand that you want to have a fixed version instead of an old one, but for a fix we have to wait for the developer to do something...

  7. robertallen
    Member
    Posted 1 year ago #

    Will removing the Yoast plugin and installing the old plugin delete all my settings? I'd have to go in and re-type all the Meta Description/Keywords for every page?

  8. THWIT
    Member
    Posted 1 year ago #

    If you open the plugin map in a FTP client (for example FileZilla) and overwrite that map with the old plugin, your settings will remain.

  9. Niels t.s
    Member
    Posted 1 year ago #

    I overwrite the plugin map with the old version, but it didn't work. In the WordPress admin it still says i'm using the new version (1.4.1).. very strange.

  10. robertallen
    Member
    Posted 1 year ago #

    Strange. It worked for me. Thank you THWIT for all your help.

    Now it'll take some time for Google to parse the changes, so crossing fingers that it works great.

    Hope you didn't mind me jumping into the conversation, Niels, as I, too had the same issue.

  11. Niels t.s
    Member
    Posted 1 year ago #

    No problem robertallen! Did you already see some (title) changes in Google? Unfortunately i still can't overwrite the plugin map, does anybody know how to do this?

    Will this title problem be solved in the new version and when can we expect a fix?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic