WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Wrong title appearing on blog page template (5 posts)

  1. Jacorre
    Member
    Posted 5 years ago #

    Hello,

    I have defined a static page as well as a posts page. The posts page just has a title "Blog" and a page template defined for it.

    When I visit the "Blog" page it works fine. It lists each blog post the way it should. However, when I click one of the posts, the article displays, but it does not display the title of the post. Instead it displays "Blog", which is the title of the posts page?

    Am I missing something in the setup or is there a tag I'm supposed to use or not use on the template?

    I've also tried not defining a template for the Blog page but it still does the same thing.

    Any help is appreciated. Thanks!

  2. Shane G
    Member
    Posted 5 years ago #

    HI,

    It seems thing kind of issue occurs in such themez..please set the correct blog URL and blog name and try it with different themez..

    Thanks,

    Shane G.

  3. Jacorre
    Member
    Posted 5 years ago #

    Hi Shane, thanks for your response. But I'm confused as to what you're asking? When you say Blog URL, do you mean the setting found in Settings > General. If so, that's defined correctly.

    I'm using my own theme that I created. Everything is working fine.

    The only issue I saw while using a static front page was that if I set a Posts page, the title of the posts page always displays on every post instead of the title of the post.

    So if I view a post called WordPress, it would actually display the title as Blog instead. Blog is the title I gave the posts page.

    Is this a bug with wordpress?

  4. Jacorre
    Member
    Posted 5 years ago #

    I think I found the issue. On my single post page, I was using the_title instead of single_post_title. Not sure if that would have made a difference but it seems to have corrected the issue.

  5. Jacorre
    Member
    Posted 5 years ago #

    Ok, still a problem though. Using the single_post_title fixed the issue with the wrong title displaying on single post pages. However, now my Similar Posts plugin is showing nothing ever since I defined the Blog page as my posts page.

    If I do not define a Posts Page, then the Similar Posts works fine.

    I think I may just create a blog archive page template and link to it instead of using the setting for a posts page.

Topic Closed

This topic has been closed to new replies.

About this Topic