WordPress.org

Ready to get started?Download WordPress

Forums

Media Library Assistant
[resolved] Wrong number of attachments to a tag in Att. Tags view (6 posts)

  1. stefanodotta
    Member
    Posted 1 year ago #

    Hello David,

    I have a problem with the Att. Tags view: the number of attachment associated to the Tag is wrong. Also, they numbers are aligned to the left.

    By clicking on the number of attachment for a particular tag, MLA brings you in a filtered view. Here the resulting number of "posts" is correct.

    The only temporary way to "correct" this issue: quick edit each Tag and save it. Weird, isn't it?

    Please check the following page, where I put some screen copy + some explanation: http://www.twoswisshikers.net/mla/

    Regards,
    Stefano Dotta

    http://wordpress.org/extend/plugins/media-library-assistant/

  2. David Lingren
    Member
    Plugin Author

    Posted 1 year ago #

    Stefano,

    Thank you for this report and especially for sending a link to your screen copy and explanation.

    The "quick edit" hint was helpful, too. I was able to reproduce the left-justify/right-justify behavior you noticed, although on my system all the Attachment counts are correct.

    I did notice that on your screen copy there are little icons (a pencil?) to the right of each entry in the Name column. These don't appear in my system. Can you tell me anything more about them? Are you running any other plugins that might contribute to the issue?

    I will do more investigation and I will keep you posted on my progress. Thanks again for your interest and for using the plugin.

  3. stefanodotta
    Member
    Posted 1 year ago #

    David,

    The little icon is indeed a pencil, and it's added by a plugin I use, named "Admin Management Xtended", available here: http://wordpress.org/extend/plugins/admin-management-xtended/

    Of course I have verified that even after having disabled this plugin (along with other plugins I use), the behaviour of Att. Tags view is consistent, as described in my previous post.

    I am actually able to reproduce the same issue with the Att. Tag view on another WordPress test site I use. Same behaviour, even with no other plugins than MLA enabled.

    Regards,
    Stefano Dotta

  4. David Lingren
    Member
    Plugin Author

    Posted 1 year ago #

    Stefano,

    Thank you for uncovering not just one, but three MLA defects which I have now fixed. You get the award for testing out the "Edit Tags" screen!

    First, you reported incorrect Attachments column counts. I have fixed a defect in the SQL query the plugin uses to get the counts (and I improved its performance as well).

    Second, you noticed and reported the odd "Quick Edit" behavior. The changing count and alignment happened because the plugin's code for the Attachments column was never called; the update came from the WordPress Posts/Media column handler. I've fixed this as well.

    Third, the left-aligned Attachments values have been changed to center-aligned; the same style used for the Posts/Media column. Not a defect, exactly, but cosmetics count.

    Your "Alternative solution: use the plugin 'Attachment Taxonomy Support' from Ben Huson..." does not solve the problem. It replaces the MLA Attachments column with the WordPress Posts/Media column, which does NOT report the correct figures in all cases (see the MLA FAQ page for more information).

    The only real solution is the set of fixes I've just completed. The defects have been in the plugin since version .30, and you're the first person to report them. Since the defects are relatively harmless, I'm going to hold off on a new release for a while and see if anything else comes up.

    If you want to get an updated version and try it out, send me your e-mail address and I will send you the latest code. Go to the "Contact Us" page at our web site:

    Fair Trade Judaica/Contact Us

    Thanks for your excellent reporting, your patience and for using the plugin. Thanks, too, for the link to "Admin Management Xtended", which looks like another great plugin.

  5. David Lingren
    Member
    Plugin Author

    Posted 1 year ago #

    I have released version 1.14, which corrects all three of the defects described above. Please let me know if you have any further trouble with the Attachments column, and thanks again for bringing it to my attention.

  6. stefanodotta
    Member
    Posted 1 year ago #

    David,

    Thank you for your feedback and the updated version.
    I confirm the latest version works like a charm!

    Thank you again for your commitment,

    Best regards,
    Stefano

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.