Ready to get started?Download WordPress


[resolved] Wrong MP3 location in podpress-generated feed (8.8.3 / WP 2.9.1) (6 posts)

  1. jimlau
    Posted 4 years ago #

    I have been using podpress for years for my podcast and just since upgrading to wordpress 2.9 I think something is going wrong in the podcast feed.

    My audio files play just fine on the embedded player and the download link works fine, but iTunes is giving errors and when I look at the feed, the url for each MP3s is missing the proper subdirectories.

    Under podpress general settings, I have URI for Media Files set to: http://f1show.com/wp-content/uploads
    and in each post I specifiy the URL for the MP3 files as /episodes/whatever.mp3
    But in the feed it just links to http://f1show.com/episodes/whatever.mp3 and does not include the rest of that path (wp-content/uploads).

    Has anyone else seen this issue? I think I have a workaround by adding a symlink on my server to forward /episodes to /wp-content/uploads/episodes but I would rather not rely on that as this used to work fine. Thanks!


  2. ntm
    Posted 4 years ago #

    I'm not sure, yet if it is related to another problem.
    The other problem is that the media file URLs in the feed are not complete if you have specified a "Local path to media files directory (optional)" (on podpress' General settings page).
    A patch for that problem is on the way. But the solution for that problem is relatively simple: remove the double slash "//" in front of line 455 in the podpress_feed_functions.php file. This file is in the main folder of the podPress plugin.

    I will look into the problem you have reported now and report back later.

  3. ntm
    Posted 4 years ago #

    jimlau, are you using the option "Local path to media files directory (optional)" (on podpress' General settings page)?

    Are you sure about the URLs of the media files have this format: http://f1show.com/episodes/whatever.mp3 ?
    I have looked into source code of the RSS feed of your show and the URLs there are like episodes/whatever.mp3 and that brings me to the conlusion that you are probably using the "Local path to media files directory (optional)" option. If it is right then please try to remove the double slash yourself until 8.8.4 is released.

    I'm really sorry for the chaos I have created!

  4. jimlau
    Posted 4 years ago #

    I removed the local path to media files (which was: /home/jimlau/public_html/f1show/wp-content/uploads) and I can't see as it's made a difference in the feed, so I'll try editing podpress_feed_functions.php.

    Thanks for your help!

  5. jimlau
    Posted 4 years ago #

    Alrighty, I have uncommented line 455, and now the links in the feed (when viewed in Safari) point to the podtrac address for tracking, and then onto the file in the correct location.

    iTunes is still showing an error when trying to download the files, but maybe it just hasn't cached the updated feed yet.

  6. ntm
    Posted 4 years ago #

    You RSS feed look good to me, too. I have tested the download of the last two episodes without a problem.

Topic Closed

This topic has been closed to new replies.

About this Topic