WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
wrong imagedate in database (7 posts)

  1. msebald
    Member
    Posted 6 months ago #

    I just noticed with the current 2.0.40 that the imagedate field in the database is not set correct for some pictures. (As I am importing all my pictures from Gallery3 to NGG I noticed that it works for some galleries, but not for others. So if it works, it works for all images, if not, for none.)

    When I view the meta data in the backend of NGG, everything looks fine. I see all kinds of information, also the correct image date and time. But not in the gallery overview, here I see the import date/time, which means today, NOW().

    Also I cannot sort with date/time because of this.

    http://wordpress.org/plugins/nextgen-gallery/

  2. msebald
    Member
    Posted 6 months ago #

    I just noticed that also some images in one gallery have the correct date/time and some not.

  3. photocrati
    Member
    Plugin Author

    Posted 6 months ago #

    @msebald - Since you are seeing this as inconsistent with your images where some are importing correctly and some are not, is the image meta data available for use in those images that are importing with the current date?

    If so, please submit a Bug Report (http://www.nextgen-gallery.com/report-bug/ ... please reference this topic) so we can try to help you get this sorted out.

    Thanks!

    - Cais.

  4. msebald
    Member
    Posted 6 months ago #

    Well, the Meta data is there for every image in all of my galleries. I see it (somehow encrypted in the database) but also when I click on "meta" of a single image.

    Example: https://www.sebald.com/wp-content/gallery/reisen/thailand-2010/thumbs/thumbs_IMGP2772.jpg

    Aperture	F 8
    Camera	PENTAX K10D
    Date/Time	16. März 2010 17:40
    Focal length	17.01 mm
    ISO	100
    Shutter speed	1/130 sec
    Flash	Not fired
    Image Width	1600
    Image Height	1071

    So the correct date/time is there, but in the gallery overview I see Jan/5/2014, the date I imported the image into the gallery. Sorting by date/time does not work then, that's the main reason why I brought this up here.

    So this sounds like a bug, doesn't it? I will open a bug report. Thanks for the link.

  5. photocrati
    Member
    Plugin Author

    Posted 6 months ago #

    @msebald - Thanks, I see the Bug Report but given these latest details can you give this a try:

    Under Gallery > Manage Galleries ... click on the gallery with the images that do not have meta data. Now, select the individual images (or all of them) then under the Bulk actions drop-down select Import metadata.

    Click Apply. Save Changes.

    Does this correct the issue?

    - Cais.

  6. msebald
    Member
    Posted 6 months ago #

    I already tried, now again, did not correct the issue.

    Now I see Jan/7/2014 in the image list for this image.

    But as I wrote: The meta data is there, see above. But the "imagedate" field of the wp_ngg_pictures database table seems to be get filled with NOW() anyhow...

  7. photocrati
    Member
    Plugin Author

    Posted 6 months ago #

    @msebald - Thank you, please see my response to your Bug Report. We can carry this conversation on there.

    - Cais.

Reply

You must log in to post.

About this Plugin

About this Topic