WordPress.org

Ready to get started?Download WordPress

Forums

Newsletter
[resolved] "Wrong email" when subscriber tries to sign up (18 posts)

  1. tcolling
    Member
    Posted 1 year ago #

    Hi - I'm trying to use the widget to sign up new subscribers, but when I test it it produces a blank page with only the phrase, "wrong email", and the email address is not added to the subscribers list. Can you tel me what I can do to fix that?

    Thanks!~

    http://wordpress.org/extend/plugins/newsletter/

  2. Stefano Lissa
    Member
    Plugin Author

    Posted 1 year ago #

    I need to see the widget to find the problem. Can you give me its address?

    Stefano.

  3. tcolling
    Member
    Posted 1 year ago #

    Of course! I should have thought of that to begin with!

    It's one our Blog page at https://www.ageassistance.com/blog/

    Thanks!

  4. Stefano Lissa
    Member
    Plugin Author

    Posted 1 year ago #

    Hi, may be you temporary removed the subscription box, since I'm not able to find it... :-)

    Stefano.

  5. tcolling
    Member
    Posted 1 year ago #

    Hi again -

    I'm very sorry, you're right, I did remove it. I have put it back, now it's in the sidebar on our blog page and blog posts, at the bottom of the sidebar.

    Thank you very much for your help. I really like this plugin and I appreciate your help.

  6. Stefano Lissa
    Member
    Plugin Author

    Posted 1 year ago #

    The form seems correct, you only need to change the labels from the subscription panel of Newsletter. But probably that won't solve the problem it seems that something is blocking the exection of the javascript control.

    Try to set the labels to see if something change.

    Stefano.

  7. tcolling
    Member
    Posted 1 year ago #

    I am beginning to suspect that this may be a result of conflicts with the theme that I'm using on http://www.AgeAssistance.com, which is the Avada theme. I'm using Avada version 1.0.9

    Are there known issues with the Avada theme when using the Newsletter plugin? I have been told by another plugin developer that they have encountered conflicts with the Avada theme due to some javascript issue(s).

  8. jeromel
    Member
    Posted 1 year ago #

    I just had the same problem.

    For me, it was the because I have changed the "name" attribute of the "email input" tag.
    You have to make sure, the name is "ne" (or like in the javascript function associated).

    I tried to suscribe on your newsletter and I don't find any javascript error. Did you change something in the newsletter source code ?

    Could you try with another theme like twenty ?

    Hope it'll help you !

  9. Stefano Lissa
    Member
    Plugin Author

    Posted 1 year ago #

    Names of input tag must be left as generated by Newsletter otherwise it is impossible for newsletter to extract subscriber data.

    Stefano.

  10. tcolling
    Member
    Posted 1 year ago #

    Stefano, if you could look at this proglam again I would certainly appreciate it.

    I upgraded to a new version of the theme that I'm using, the Avada theme from Theme-Fusion.net, and it's still occurring. My website is at http://www.AgeAssistance.com and the subscription form is in the page footer. This upgrading did not do any good in solving the problem.

    I disabled all plugins except for the Newsletter plugin. That did not solve the problem either. (Afterwards, I re-enabled all the plugins).

    The site runs SSL with https:// URLs. Is the SSL a problem?

    Is there anywhere in your code where the phrase "wrong email" is used?

    Thanks,
    Tim

  11. tcolling
    Member
    Posted 1 year ago #

    Hi again Stefano:

    Since I still need to solve this I did further experimentation and I discovered what is causing this problem.

    First, I tried a number of different themes. That didn't help the problem.

    THEN, I disabled SSL on the site. Bingo! That solved the problem.

    So now the question is, why is SSL causing this problem? I tried looking at your code in subscription.php and I found the two lines where the code echoes "wrong email" to the screen. Unfortunately, though, I don't know enough about php to know how to solve the problem. The two locations that I found were:

    1. line 115:
    if ($email == null) die('Wrong email');

    2. line 303:
    if (!$newsletter->is_email($_REQUEST['ne'])) die('Wrong email address.');

    I hope you can tell what's needed to fix this.

    Thanks!

    - Tim

  12. tcolling
    Member
    Posted 1 year ago #

    Hi again -

    Any chance of fixing this in time for the release of Newsletter 3.1?

    Thanks,
    Tim

  13. Stefano Lissa
    Member
    Plugin Author

    Posted 1 year ago #

    Hi, the PHP code that checks the email is only a protection since the check should be made by javascript... this is strange.

    Can you address me to the subscription form in your site?

    Stefano.

  14. tcolling
    Member
    Posted 1 year ago #

    The form is on my site at http://www.AgeAssistance.com in two places: it's on the footer of every page, using your widget, and it's also on a standalone subscription page at:

    http://www.ageassistance.com/senior-care-newsletter-subscription/

    I currently have SSL turned off in order to avoid the problem, but if you're going to be looking at it I will turn SSL back on in order for you to be able to reproduce the problem. I will do that right now after I send this reply.

    Thanks,
    Tim

  15. tcolling
    Member
    Posted 1 year ago #

    SSL is back on now.

  16. Stefano Lissa
    Member
    Plugin Author

    Posted 1 year ago #

    I found the problem. When I create the link to the subscription function, I use the wordpress base URL saved on main configuration of wordpress. There your URL is http:// (not https://).

    When you enable the SSL, your system intercepts every http:// calls and respond back with a redirect to https://. That creates two problems:

    1. a POST request is destroyed by a redirect, so the data is lost
    2. the subscription function is called without data and so it raises the error

    If you want the full blog in SSL is should be better to use https:// as protocol on wordpress main configuration.

    Anyway I can try to create a patch for this problem even if it's not obvious since change in one part of Newsletter may be it breaks things on other kind of installations.

    [ Signature moderated. ]

  17. tcolling
    Member
    Posted 1 year ago #

    Hi Stefano -

    THANK YOU, THANK YOU, THANK YOU!

    You said, "If you want the full blog in SSL is should be better to use https:// as protocol on wordpress main configuration."

    I foolishly forgot to change it to https when I installed SSL, which took place after the original WordPress installation took place. This was a good reminder!

    You said, "Anyway I can try to create a patch for this problem even if it's not obvious since change in one part of Newsletter may be it breaks things on other kind of installations."

    Thank you very much but no patch is necessary. I have changed the WordPress general settings fields to reflect the https protocol and everything works great now.

    Thanks again!
    - Tim

  18. Stefano Lissa
    Member
    Plugin Author

    Posted 1 year ago #

    You're welcome! :-)

    Stefano.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic