WordPress.org

Ready to get started?Download WordPress

Forums

Wrong dashboard showing (9 posts)

  1. erbrown777
    Member
    Posted 3 years ago #

    I recently updated from 3.05 to 3.12 with Buddypress 1.2.8

    Everything works fine until, while logged out, I log in to the dashboard via a subsite (and not the main site).
    Log in via http://www.mainsite.com/subsite1/wp-admin and not http://www.mainsite.com/wp-admin

    Now all the links related to subsite1's dashboard now point to mainsite's dashboard.

    This does not occur with subsite2 unless, while logged out, I log in to subsite2's dashboard.

    Examples of links now pointing to the mainsite dashboard:
    In mainsite/wp-admin/network/sites.php - when the dashboard of subsite1 is clicked the page opens on mainsite/wp-admin and not mainsite/subsite1/wp-admin

    When editing Posts/Pages in a subsite an error message "You attempted to edit an item that doesn’t exist. Perhaps it was deleted?" shows and the url is mainsite/wp-admin/post.php?post=2&action=edit and not mainsite/subsite1/wp-admin/post.php?post=2&action=edit

  2. Tim Moore
    Moderator
    Posted 3 years ago #

    Check your .htaccess file and also try resetting permalinks from the main site.

  3. Start disabling plugins.

  4. erbrown777
    Member
    Posted 3 years ago #

    @Tim. I checked the .htaccess - it is fine. The premalinks are also correct.

    @Andrea. I disabled the plugins in Network, mainsite and subsite (the one I was going to try log into the backend with to test).

    Same result.

  5. ReSAVE the permalinks - Yes they're fine, but just press the save button. It's stupid, but it may help.

  6. erbrown777
    Member
    Posted 3 years ago #

    @Ipstenu by correct, I meant I saved them - in the main site and the subsite I wanted to log into the backend into.

  7. What plugins were you running?

  8. erbrown777
    Member
    Posted 3 years ago #

    I am running a test site of the main site to test the update.

    I disabled all the plugins - same result.

  9. Right, but which ones DID you have? :) I wonder if one of them didn't disable cleanly (happens) or whatnot.

Topic Closed

This topic has been closed to new replies.

About this Topic