WordPress.org

Ready to get started?Download WordPress

Forums

  1. hehafner
    Member
    Posted 1 year ago #

    Hi, I am new to using BWPS so I still have a learning curve. But last night, I found that one of my sites with the plugin added had a ton of 404 errors. Upon researching the 404's I found that the pages weren't redirecting properly. So I went into my cpanel to correct and lay out more redirects but found out that BWPS will not allow for this to occur. I had to delete the plugin entirely in order to do anything toward redirects. I don't want to have to delete the plugin every time I need a to do a redirect. Is there a method of doing redirects without deleting the plugin? (I did try just deactivating but that didn't work.)

    Thank you,
    HafnerDesigns

    http://wordpress.org/extend/plugins/better-wp-security/

  2. Handoko
    Member
    Posted 1 year ago #

    Perhaps not much help. Just some information, hope can be useful.

    - This plugin will modify your .htaccess files it thinks good for security reasons (between # BEGIN Better WP Security and # END Better WP Security section).

    - It will perform the modification every time you activate, deactivate this plugin or save Better WP Security's settings.

    - You can disable this plugin to modify your .htaccess by goto menu > Security Security > System Tweaks > disable Write to WordPress core files. But by doing so, your website will become less protected.

  3. hehafner
    Member
    Posted 1 year ago #

    Wonder why I never received this answer... I just posted again ;-)

    I did go to Server Tweaks and unchecked Protect Files b/c it prevents access to the .htaccess. I also unchecked, Remove write permissions from .htaccess and wp-config.php... I also unchecked the Write to WordPress core files but now matter what, I get something like this.

    Apache detected an error in the Rewrite config.
    
    Syntax error on line 180 of /home/mydomain/public_html/.htaccess.gJZx7KYBlHhpXNdSyciA4AvOkNoQMbod:
    Invalid command 'suPHP_ConfigPath', perhaps misspelled or defined by a module not included in the server configuration
    
    Please try again.
  4. hehafner
    Member
    Posted 1 year ago #

    Ah... I figured it out!

    my .htaccess had a line in it

    suPHP_ConfigPath /home/mydomain/public_html

    When I removed that line and then unchecked

    Remove write permissions from .htaccess and wp-config.php

    I can now do redirects from my cpanel.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic