WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] writing options ping list 403 forbidden error (11 posts)

  1. webmyster
    Member
    Posted 8 years ago #

    Installed several wordpress sites on several different
    servers with no problems.
    This new server it has installed ok and will let me edit/change all except under the writing options ping list
    when you add or change anything and try to save it you get
    this page
    forbidden
    You don't have permission to access /wp-admin/options.php on this server
    No permisions for any files were changed from previous
    installs on other servers and all server settings seem
    the same, however I have several blogs setup on this server
    and they are all giving me the same error, so I beleive it
    is a server side setting that is different from the other
    servers. I have tried several solutions, including several
    403 error fixes for other problems I found in here, but
    still no fix. Can any one advise what this problem is
    and how I can fix it.
    Many thanks in advance
    Dave Underwood

  2. Chris_K
    Member
    Posted 8 years ago #

    Not sure what you've actually looked at or tried...

    Have you asked your host about mod_security? Is it on for that server? If it is, and you search around here for "403 mod_security" you'll hit a reasonably recent looong thread that culminates in a work-around.

  3. webmyster
    Member
    Posted 8 years ago #

    G'day Handysolo,
    What havn't I tried is more the question :-)
    All the posts in here I could find including
    mod_security one's related to posts and words
    used etc. I have a whm with 100 accounts on it
    and mod _security has not been setup as far as
    as I can tell, it is listed in the add-ons but
    has not been added.
    I tried chmod'n things different, I looked at what
    appache handlers are on this server and the work'n
    wp sites servers, I seem to have checked everything,
    I even reloaded wp and reinstalled it, but as I said
    I have a few wp sites on this server and they are all
    doin the same freak'n problem
    My other servers all install wp fine and all work
    this 1 lets me install em and all works except saving
    anything in the pinglist, sigh.
    As I had changed nothing in wp upload and install
    from 1 server to another I figure it has to be a
    problem on this server that maybe my host needs to fix.
    Just thought before I had a serious brain meltdown I
    should ask some other more knowlegdibled people :-)

    Thanks

    Dave Underwood

  4. whooami
    Member
    Posted 8 years ago #

    "I have a whm with 100 accounts on it
    and mod _security has not been setup as far as
    as I can tell, it is listed in the add-ons but has not been added."

    Listed in addons where, and what have you done to verify that it is not installed?

    This is an important question because you mentioned that other wp installs on the same box are behaving the same way.

    That ought to tell you straight-away that it's a box problem.

    Create a file, add <? phpinfo(); ?> to it, rename it to something that ends in .php (checker.php, etc..)

    Upload that file to your server and open it in your browser. Scroll down to where you see Apache in big letters.

    Look at the installed modules. Do you see mod_security listed? Yes? No?

  5. webmyster
    Member
    Posted 8 years ago #

    G'day,
    Well seems it must be this mod_security as
    that is not in the other servers whm
    Whooami I did as you sugested and made that
    file and put it in the root user for whm and
    1 of the accounts and could see most things
    except appache modules :-)
    blog.infertility.guide-for-you.com/checker.php
    I been at this problem for too long with no
    solution, so it is time to get the host to
    sort the box, get rid of that mod_security I
    beleive is the solution.

    Thanks heaps for your prompt and excellent support

    Dave Underwood

  6. whooami
    Member
    Posted 8 years ago #

    dave,

    I checked that file, and you are correct, oddly enough its not showing the Apache setup anywhere. Thats not normal either ;P

    You mentioned that you have a lot of domains on that box, if in fact thats the case, and if mod_security is the problem, your host should probably deal with it.

    There is a way to disable mod_security through your .htaccess but for multiple domains (100's?) it would be a pain in the arse to have edit all those .htaccess.

  7. webmyster
    Member
    Posted 8 years ago #

    G'day,
    "I checked that file, and you are correct, oddly enough its not showing the Apache setup anywhere. Thats not normal either ;P "
    Thanks Whooami I did a phpinfo for the root user too
    and IT had no apache info either, I'd used a phpinfo
    before and thought it should be there, nice to have
    others confirm things when you are work'n alone.
    Nice to know I am not completly insane.
    I just did 1 for a site on the other server and it has
    a whole heap of apache stuff in it
    I will hand this problem over to the box host.

    Thanks for all your help.

    Dave Underwood

  8. whooami
    Member
    Posted 8 years ago #

    you're welcome, sorry I couldn't help more. Good luck!

  9. treehousetim
    Member
    Posted 7 years ago #

    I just ran into this. I believe it has something to do with a domain name that has a slash in it.

    Here is a list I was saving...

    http://rpc.weblogs.com/RPC2
    http://rpc.pingomatic.com/
    http://api.moreover.com/RPC2
    http://api.feedster.com/ping
    http://ping.feedburner.com
    http://coreblog.org/ping/
    http://ping.cocolog-nifty.com/xmlrpc

    which failed
    403
    Forbidden
    You don't have permission to access /blog/timstidbits/wp-admin/options.php on this server.

    But, if I remove the last line (the only one with a dash in the domain) it works!

  10. Chris_K
    Member
    Posted 7 years ago #

    As I understand it, "xmlrpc" is often one of the "bad words" that mod_security won't like. And an unhappy mod_security often will explain HTTP 403 responses.

  11. treehousetim
    Member
    Posted 7 years ago #

    I'm not completely sure, but it also might have something to do with what I found, and documented on my blog:

    http://www.sunflowerroad.com/blog/timstidbits/2006/11/30/quick-solution-to-vexing-http-post-problem/

Topic Closed

This topic has been closed to new replies.

About this Topic