WordPress.org

Ready to get started?Download WordPress

Forums

WPZOOM Academica Homepage Slideshow question (46 posts)

  1. saz25
    Member
    Posted 2 years ago #

    Hi,
    I'm using the WPZOOM Academica theme. It seems that the online documentation on how to use the Homepage slideshow doesn't reflect what that theme configuration pages show. I am using the latest version of the theme, version 1.2.

    Any suggestions?

    Its not clear how I should set the custom field, wpzoom_slide_url. Does it expect a URL or path to an image or a page?

    What goes in the slide link field? What's the syntax?

    All I want to do is to add a slide show of many 2-3 slides (images) to the top of the home page.

    Thanks in advance,
    Steve

  2. srsars
    Member
    Posted 2 years ago #

    Did you ever figure it out cuz i'm having issues with it too.

  3. mattb3476
    Member
    Posted 2 years ago #

    I had the problem / confusion saz25 first mentioned. I posted in the WPZOOM help forums and a moderator, Dumitru, helped me resolve the issue.

    WPZOOM help forums: http://www.wpzoom.com/forum/index.php

    I would recommend anyone with the theme go there, because I included pictures in my post.

    The post:
    http://www.wpzoom.com/forum/viewtopic.php?f=133&t=6107&p=24673#p24673

    But, here's some info.

    ***ME***

    I am having the same problem with the Academica slideshow as this guy, as well as others that I have read on the WordPress forums.

    After a fresh install of both WordPress and Academica, I cannot get the slider to work. I have followed the minimal documentation, but with no success.

    Others with the problem: http://wordpress.org/search/academica?forums=1

    Error given when I try to click to "view" a slide from the Slideshow slide list:

    "Catchable fatal error: Object of class WP_Error could not be converted to string in /home/content/09/8614809/html/wp-content/themes/academica/functions/wpzoom-functions.php on line 328"

    Site URL: Only an "in construction" page is up currently, which displays on an alternate theme. I am using the Theme Test Drive plugin while I set up Academica. I have troubleshot my problems without the plugin enabled and all issues were the same. This is a hired job, and I cannot have a development site public.

    Theme Test Drive: http://wordpress.org/extend/plugins/theme-test-drive

    WordPress version: 3.2.1

    Theme Versions: Academica 1.2

    Here's what I did.

    I enabled the slideshow and selected for two frames.

    Image

    I added two slides.

    Image

    But when I click to view the slide, I get the error given above.

    Image

    And when I look at the source code for my homepage, there is nothing for a slideshow.

    And, fyi, the documentation for the slideshow seems inaccurate.

    Here's a screen grab.

    Image

    This is what I have.

    Image

    For the slide options, there is only a box for a "slide link." No "Slide Type" drop box or anything else.

    ====================

    ***MODERATOR***

    Open /functions/wpzoom-functions.php and find these lines (#328):

    Code:
    echo get_category_parents($cat, TRUE, ' ' . $delimiter . ' ');

    Replace with:

    Code:
    if ($cat) {
    echo get_category_parents($cat, TRUE, ' ' . $delimiter . ' ');
    }

    See if this helped.

    ====================

    ***ME***

    Thanks again for the speedy reply, Dumitru!

    I replaced the line you said. Now, when I click "View Slideshow Item,"

    Image

    a page comes up, but the slide image is not displayed.

    Image

    I have checked the link in the "Slide Options" "Slide Link" box, and it is correct. For kicks, I also am using an image with the same dimensions as the slideshow on the Academica Live Demo - in case it needs to be exact.

    Also, I don't see anything in my homepage source code for the slideshow.

    In the WPZOOM Live Demo, it follows the closing of the header div.

    Image

    There's nothing in mine.

    Image

    ====================

    ***ME***

    I got the slideshow wrapper to show up on my homepage. But, the images aren't there yet.

    In the "Reading" settings of the WordPress "Settings" bar, the "Front page displays" setting needs to be set to "your latest posts." If it is set to a static page, the slideshow container doesn't show up.

    Image

    Image

    I had set it to my "homepage" page, since I want a static page as my homepage, rather than posts.

    But, it looks like you need to do this only in the WPZOOM "Theme Options."

    Image

    ====================

    ***MODERATOR***

    When you create a slideshow item and set a featured image for it, it isn't shown on the page for the slideshow item (when you open it).

    You still have to insert it into the content body for the custom post, we don't enforce it to be displayed, as many customers prefer to keep it just on the homepage.

    If you don't provide a link to your website, we can't help much.

    ====================

    ***ME***

    Thank you for your help, Dumitru. I'm all set up!

    I am a videographer building a small business website. I am a competent hobbyist with web design and WordPress, but by no means is it my territory.

    For those having who have trouble with the same things I did, here's a little more information. It's embarrassing, but I'll admit that it confused me!

    When setting up a slideshow,

    Image

    the "Slide Link" in the "Slide Options" panel is what the slide links to when it's clicked. It's NOT a link to the slide to be included in the slideshow.

    Image

    Each slide is created by making separate slides with "Add a New Slide"

    Image

    and uploaded through the featured image panel in the "Edit Slideshow Item" page.

    Image

    If it uploads correctly, you'll see it in the content display of the page.

    Image

    I think the confusion for me came from the documentation, which did not mention the "Featured Image" panel and made it seem like all the slide information was contained in the "Slide Options" panel.

    Image

    Adding to the confusion is that the "Slide Options" panel in the documentation is for a video and includes an interface that does not resemble the one in the template.

  4. overcranked
    Member
    Posted 2 years ago #

    Thank you this did it for my site!

    Just when I was going to scrap the theme.

  5. Onyx_black
    Member
    Posted 2 years ago #

    Could you elaborate and explain each step in more detail?

    I created 4 slides using "Add a New Slide", for each slide I named them Slide 1, Slide 2, Slide 3 and Slide 4. I was told that titles are important, otherwise it won't work.

    Next for each slide I've created, I click on "Set feature image" and select one image file under "Media Library" (by clicking on "Show" for that particular image file of interest). Then keeping all the options at their default state, I select the "Use as featured image".

    After that I'm stuck, what should I do next? Did I missed out any important step?

    Do I need to attach the image files to their respective slides?

    Any assistance would be greatly appreciated.

  6. mattb3476
    Member
    Posted 2 years ago #

    Everything I learned is laid out as best I could in the WPZOOM support forums.

    Work through the stuff in this help thread (there's pictures!):

    http://www.wpzoom.com/forum/viewtopic.php?f=133&t=6107&p=24673&sid=1c2e08d0bdc085b522df3c0c81f27c74

    You'll need to sign up first.

  7. gyokusai
    Member
    Posted 2 years ago #

    Matt, you already helped me a lot, thank you. But like Onyx, I'm still stuck. What I did:

    - Checked if WP “Reading” settings "Front page displays" is set to “your latest post”
    - Enabled Slideshow in WPZOOM settings “Homepage Options” & set a static page
    - Added “New Slides” (Titles: "Slide One", "Slide Two" etc.), set a "Featured Image” for each, and published them

    What happens is:
    - Source code looks absolutely correct (like in the demo)
    - Image links, checked directly from source code, are fine
    - The Slide Wrapper shows up on the Home Page exactly as it should
    - The Images DON'T appear on the Home Page

    If I missed something obvious, please feel free to amend/correct.

    Also, I followed your advice and signed up to the WPZOOM support forums—but as I'm not a paying member, it turns out, I don’t have access to any of the threads you linked to. And while so many people have problems to get this slider to work, which really IS a defining feature for this theme, and the “documentation” not only skirts the issue but actively confuses it, I’m getting a little suspicious here that this whole thing might just be an elaborate honey pot. (I don’t mind paying for a theme, I actually would have bought Academica if it weren't free, but this annoys me to no end.)

  8. blazestudios23
    Member
    Posted 2 years ago #

    They seemed to have changed the theme, making simplifying it, but it does not work. All you are supposed is, "Set the absolute path to an image, will be used in the slider." I did that and nothing happens on the home page. And if you want to go on the forums you have to pay around $200 to sign up. I would happily have bought this for $50. But I am not willing to pay $200 plus a monthly fee.

    Anyone have any idea what is wrong with the new version? I am sure these is some kind of code error. But if it did work this theme would be very easy to use. Additionally any idea of the size of image you are supposed to use in this theme?

  9. gyokusai
    Member
    Posted 2 years ago #

    That "size of image" might actually relate to the problem.

    Whatever size you use, the images are resized via the timthumb script to 960x300 px (plus a bunch of slices for the transitions). And I suspect that it is here where generating the images fails.

    If you have a regular WP install, you’ll find the timthumb script at this location:
    /wp-content/themes/academica/scripts/

    What I did so far:
    - checked the folder and script permissions (set to 755)
    - checked if the PHP GD library is active on the server (it is)

    So everything looks okay, but I still suspect it’s got something to do with timthumb.
    Suggestions welcome.

  10. blazestudios23
    Member
    Posted 2 years ago #

    I figured out what the problem was, somehow I got version 1.0.2 and the current version is 1.2.0. I got the new version and did what is said above. The other problem is that in the setting/reading, you have to make sure that "Front page displays" is set to recent posts.

  11. gyokusai
    Member
    Posted 2 years ago #

    Wish it was that easy… I’ve got version 1.2.2 (I checked) and it still doesn’t work. (And yes, my “front page displays” setting is set to “your latest posts.”)

  12. blazestudios23
    Member
    Posted 2 years ago #

    Did you ad the code snippet form above? I did that too and made 5 slides and named them Slide-1, Slide-2 etc and made sure the page names where the same.

  13. blazestudios23
    Member
    Posted 2 years ago #

    I had 2.2 also.

    I also changed some of the folder permissions in the theme 777 as that will sometimes stops wp-press from being able to auto generate scripts. I had that happen with another theme from this company.

  14. blazestudios23
    Member
    Posted 2 years ago #

    The file permissions might do the trick for you.

  15. gyokusai
    Member
    Posted 2 years ago #

    Yes, I added the snippet (but it actually fixes a different problem).

    I also made 5 slides, and I named them exactly like you did, and the pages ditto. I also set theme folder permissions to 777 (and tried 755 for good measure, in case the server has a safety-catch for 777 permissions).

    Still zippo.

    Also, I keep wondering about timthumb. Usually, it needs a cache and a temp folder to work properly and generate the images, and usually they’re in the same directory as the script. But there aren’t any in the script folder. (I created them both there w/ 777 permissions, but to no avail.) Does anyone know where the timthumb cache/temp folders are for the Academica theme?

    Anyways, I gotta go to bed now (it’s almost 6 a.m. around here). I'll be back to work on this problem tomorrow.

  16. blazestudios23
    Member
    Posted 2 years ago #

    I made any folder that had any possibility of running the script 777, from the JS folder and each folder in it to the scripts folder. Not sure what else you could do.

    For me the thing that was stopping it was the weird way you have to set it up where the theme controls the home page and not word press.

    I have:

    "Show slideshow on homepage?" Yes
    "Homepage Slideshow Items" 5
    "Show static page on homepage?" Yes
    "Page to be displayed on homepage" "the name of the page"

    Then the WEB reading setting is set to:

    "Your latest posts"

    I have the SEO turned off as I use Yeost SEO.

    And I have the Navigation fully set up.

    Not sure if any of that will help, but the theme may be cause a conflict with a plug-in or something as well.

  17. blazestudios23
    Member
    Posted 2 years ago #

    One more thing, I have the featured images set for the slides and I put the pictures on the the pages of the slides just to be safe.

  18. gyokusai
    Member
    Posted 2 years ago #

    OK I didn’t go to bed. I wanted to, but I couldn’t. When it comes to tackling coding problems, I’m like a fracking Roman legion.

    And I GOT IT!

    I did all of the above and checked everything at least three times. Nothing worked. Then I suddenly remembered something ... just a wild guess. I placed an .htaccess file into the theme’s script folder — i.e., /wp-content/themes/academica/scripts/ — with these rewrite rules:

    RewriteEngine on
    RewriteRule .* - [E=HTTP_IF_MODIFIED_SINCE:%{HTTP:If-Modified-Since}]
    RewriteRule .* - [E=HTTP_IF_NONE_MATCH:%{HTTP:If-None-Match}]

    And man, suddenly the timthumb cache folder (that I had created, see my comment above) fills up with generated thumbs, and the slides are displayed on the homepage!

    Can’t tell what the problem was: my guess is that there's a serious flaw in the theme's installation script.

    But now I can go to sleep. (It's 8 a.m. now haha). Thanks everybody for your advice! And maybe someone will find this solution useful. But maybe not: it looks like we all have the same problem, but each of us needs different solutions. Decidedly weird.

  19. blazestudios23
    Member
    Posted 2 years ago #

    Yes, there is something wrong with the theme, that's for sure. I can't pinpoint exactly what I did that fixed it, but it works and that's all that matters.

  20. Onyx_black
    Member
    Posted 2 years ago #

    Thanks a bunch gyokusai! So, in essence, to make the slideshow work I have to do the following:

    1.)
    Open /functions/wpzoom-functions.php and find these lines (#328):

    Code:
    echo get_category_parents($cat, TRUE, ' ' . $delimiter . ' ');

    Replace with:

    Code:
    if ($cat) {
    echo get_category_parents($cat, TRUE, ' ' . $delimiter . ' ');
    }

    2.)
    Quote from gyokusai:
    I placed an .htaccess file into the theme’s script folder — i.e., /wp-content/themes/academica/scripts/ — with these rewrite rules:

    RewriteEngine on
    RewriteRule .* - [E=HTTP_IF_MODIFIED_SINCE:%{HTTP:If-Modified-Since}]
    RewriteRule .* - [E=HTTP_IF_NONE_MATCH:%{HTTP:If-None-Match}]

    3.)
    Checked if WP “Reading” settings "Front page displays" is set to “your latest post”.

    4.)
    Enabled Slideshow in WPZOOM settings “Homepage Options” & set a static page.

    5.)
    Click "Add a New Slide".

    6.)
    Create title for the slide.

    7.)
    Upload picture/photo via "Set featured image" under "Featured Image" panel.

    8.)
    Click on "Use as featured image".

    9.)
    Repeat steps 5 to 8 for any additional slides.

    Did I missed out anything?

  21. gyokusai
    Member
    Posted 2 years ago #

    Onyx, I don't think you missed anything but in case it still doesn’t work, two things come to mind (one trivial, one less so):

    Trivial (I'm sure you thought of that):
    WPZOOM/settings/Home page Options:
    Slide Show to "yes", choose number of slides
    Static Page "yes, choose page ("Home" is good choice, if it doesn’t exist, make one)

    Not so trivial:
    Go to this folder: /wp-content/themes/academica/scripts/
    make sure you have the latest timthumb.php version (for security reasons)
    - if not, get it here: http://code.google.com/p/timthumb/
    check if there's a cache folder within the "script" folder
    - I added a "temp" folder for good measure but I don’t think that’s necessary
    Make sure this "cache" folder is set to 777
    - try 755 in case your server is set to ignore 777 for security reasons
    check if your "wp-content", "themes," & "academica" folders have at least 755

    If all fails, you should also check if the "script" and "cache" folders and the "timthumb.php" file have the same "Owner" like most of the other files (that's often your FTP User ID; generated files within a given folder often have a different owner, i.e., "www-data").

    If it still fails, access your server's infophp.php file (in your browser) and check if the GD library is enabled! (It really should be, but even stranger things have happened.)

    Best of luck!

  22. Onyx_black
    Member
    Posted 2 years ago #

    I appreciate your detailed response gyokusai, just one more question though, all these are accomplished on WordPress ver 3.3 or 3.2?

  23. gyokusai
    Member
    Posted 2 years ago #

    Sadly, as my provider only runs MySQL 4.1.22 on their servers, I can’t update to WP 3.2 or 3.3. I’m running the lastest WP version that doesn't need a MySQL 5 upgrade, which is WP 3.1.4.

  24. Boothie75
    Member
    Posted 2 years ago #

    gyokusai - Thank you.

    For me in the end it was the timthumb.php that needed updating, however, i did follow your instructions. All Works now!! Yippee
    WP3.3.1

  25. gyokusai
    Member
    Posted 2 years ago #

    :-)

  26. ASBBIA
    Member
    Posted 2 years ago #

    I must be a complete newbie... I've done everything (as far as I know) that this thread has to offer. Also tried to reinstall everything with no luck - keep getting the problem. After using incredible amount of hours I can only conclude that I must be doing some of the steps wrong.

    I got the code for timthump and went to my ftp client, opened the timthump file and updated the code.

    Did the same for the echo get_category fix so the code looked like this: } elseif ( is_year() ) {
    echo $currentBefore . get_the_time('Y') . $currentAfter;

    } elseif ( is_single() ) {
    if (!is_attachment()) {
    $cat = get_the_category(); $cat = $cat[0];
    if ($cat) {
    echo get_category_parents($cat, TRUE, ' ' . $delimiter . ' ');
    }
    echo $currentBefore;
    the_title();
    echo $currentAfter; }

    I named the slides "Slide-1, Slide-2 ...Slide-5"

    I found the .htaccess in my root folder and have the following code:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule .* - [E=HTTP_IF_MODIFIED_SINCE:%{HTTP:If-Modified-Since}]
    RewriteRule .* - [E=HTTP_IF_NONE_MATCH:%{HTTP:If-None-Match}]
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    All my ftp folders are 755

    Finally I don't have any cache folder in my directory... is this something I need to create manually or is it a mistake if it isn't there?

    Since it seems like people have gotten success after trying the advices from this thread, I suspect that I'm messing up in the system. Could anybody verify specifically what the custom field should say and if you need to do something on the page you want the slider.

    I really really hope that somebody can offer me the last needed advice as my frustration has reached mountain high. Anybody with Skype and the 30 minutes to spare would also be greatly appreciated.

  27. geaves
    Member
    Posted 2 years ago #

    I would just like to say thank you to all that have contributed to this thread it resolved my problems.

    Using WordPress 3.3.2 and the latest Academica theme 1.2.2:

    I had to add the latest timthumb.php due to featured image in posts not displaying, also changed the code in the wpzoom-functions.php and it's all working. Had to do some image editing to get slide image to display correctly but that was a minor issue.

    Thanks again, Geoff.

  28. hiraiqbal
    Member
    Posted 2 years ago #

    Now I am having problem with academica theme 1.2.2 slideshow , it shows only featured image in slide show, i have also added latest version of timthumb.php, can any one tell me about how to create slideshow,
    geaves can you tell me what minor changes you made in image editing?

  29. geaves
    Member
    Posted 2 years ago #

    Hi, basically just resized the image file, or 'cut out' a section of the image and created a new one, but all the images are a different size on my site, just checked the image sizes on a couple of the slides.

    As there is only one image on each slide/page and that is the featured image, then that is correct.

    If you read all the posts particulary the additional code to the wpzoom-function.php, and this:
    WPZOOM/settings/Home page Options:
    Slide Show to "yes", choose number of slides
    Static Page "yes, choose page ("Home" is good choice, if it doesn’t exist, make one)
    Also in Settings/Reading make sure that Front page displays 'Your latest post' is checked, so do not select a home/front page in here.

  30. hiraiqbal
    Member
    Posted 2 years ago #

    Hi geaves,
    your trick
    As there is only one image on each slide/page and that is the featured image, then that is correct.
    worked for me but beside it i also followed all the instructions given before like function.php modification,placement of .htacess file and WPZOOM/settings/Home page Options,
    so a BIG thanks to you.

Topic Closed

This topic has been closed to new replies.

About this Topic