WordPress.org

Ready to get started?Download WordPress

Forums

WPtouch Mobile Plugin
WPtouch Using Deprecated argument (6 posts)

  1. Mary B.
    Member
    Posted 3 years ago #

    Using WP ver. 3.3.3, installed and activated WPtouch ver. 1.9.26. Upon activation, received the following notice/error message:

    Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /home/stopping/public_html/wp-includes/functions.php on line 3387

  2. Mary B.
    Member
    Posted 3 years ago #

    Correction: I'm using WP 3.1.3

  3. BraveNewCode Inc.
    Member
    Plugin Author

    Posted 3 years ago #

    We'll correct in the next release— depreciated functions are functions that will be emoved and cannot be depended on in WordPress. At this time, there are no functionality problems with the plugin.

  4. framness
    Member
    Posted 3 years ago #

    Hi BraveNewCode,

    I just ran into the same problem Mary B. reports. HOWEVER, I have three levels of the site and on my production site, I do not see warnings about the deprecated function use. However, on my test site I get those deprecated errors. I have not run or installed the plugin on my dev site.

    Both sites are using WP 3.1.3, but the prod site is using a theme I cribbed from the WP free themes section and my test site is a theme I am coding up mostly from scratch (but not quite 100% from scratch). I've been using your plugin on the Prod site for sometime and have been keeping it up to date. I just (within an hour of this post) installed the plugin on the test site.

    I saw the note about no broken functionality and the message WP throws is identical (except for paths & site specific items) to what Mary B. Reports.

  5. BraveNewCode Inc.
    Member
    Plugin Author

    Posted 3 years ago #

    Will be fixed in 1.9.27, should be out this week.

  6. BraveNewCode Inc.
    Member
    Plugin Author

    Posted 3 years ago #

    1.9.27 was released today, and includes the fix.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags