WordPress.org

Ready to get started?Download WordPress

Forums

WPtouch Mobile Plugin
WPTouch - no access to settings after upgrade (4 posts)

  1. dgdevil
    Member
    Posted 4 months ago #

    I just updated WP and WPTouch, and the plugin's settings link has disappeared. I also tried accessing from the Settings menu via yoursite.com/wp-admin. WPTouch does not show up there!

    It also irks me that "mobile version" is the default setting on the several desktops where I have accessed my site.

    And I occasionally get a "nonce failure" black screen when I access my site on mobile options.

    https://wordpress.org/plugins/wptouch/

  2. BraveNewCode Inc.
    Member
    Plugin Author

    Posted 4 months ago #

    It sounds as if there may be a Javascript conflict active in your installation as well as the need to configure caching software.

    To isolate which plugin(s) may be contributing to the trouble, deactivate all except WPtouch from within the WordPress Plugins area, clear your browser cache and local data then test.

    If WPtouch functions well, you may then enable the rest of your plugins one at a time, repeating the process, until you can identify which is/are causing the problem.

    You may choose to replace the conflicting plugin with another or upgrade to WPtouch Pro which has a feature that will allow you to disable the conflicting plugin within your mobile theme but leave your desktop theme intact.

    You may configure your caching plugin not to cache mobile pages nor to serve cached pages when mobile devices are detected. To do so, enter the user agents found in the documentation link below to the "rejected user agents" areas in your caching plugin's settings. Remember to clear your plugin, browser, and device caches before retesting.

    http://www.bravenewcode.com/support/knowledgebase/default-mobile-device-user-agents/#cacheuas

  3. dgdevil
    Member
    Posted 4 months ago #

    Thanks. Everything else disabled (except Jetpack - would not deactivate) ... Browser cache cleared ... Still defaults to mobile setting on desktop, and ipad will NOT click over to desktop.

    http://www.deangoodman.com

    I noticed this notification in Core settings: Extra configuration is required. The plugin must be configured to exclude the user agents that WPtouch Pro uses.

    But I already have these Custom User Agents Listed (quite a few!):

    iPhone & Mobile, iPod & Mobile, Android & Mobile, BB & Mobile Safari, BlackBerry & Mobile Safari, IEMobile/10.0 & Touch, Firefox & Mobile, IEMobile/7.0, IEMobile/9.0, webOS, acer\\\\ s100, archos5, docomo\\\\ ht\\\\-03a, dream, htc\\\\ hero, htc\\\\ magic, kindle, lg\\\\-gw620, liquid\\\\ build, maemo, mot\\\\-mb200, mot\\\\-mb300, nexus\\\\ one, opera\\\\ mini, samsung\\\\-s8000, series60.*webkit, series60/5\\\\.0, sonyericssone10, sonyericssonu20, sonyericssonx10, t\\\\-mobile\\\\ mytouch\\\\ 3g, t\\\\-mobile\\\\ opal, tattoo, AppleWebKit, MySiteApp, iphone, ipod, ipad, aspen, incognito, webmate, android, dream, cupcake, froyo, webos, s8000, bada, 2.0 MMP, 240×320, ASUS, AU-MIC, Alcatel, Amoi, Audiovox, AvantGo, BenQ, Bird, Blazer, CDM, Cellphone, DDIPOCKET, Danger, DoCoMo, Elaine/3.0, Ericsson, EudoraWeb, Fly, HP.iPAQ, Haier, Huawei, IEMobile, J-PHONE, KDDI, KONKA, KWC, KYOCERA/WX310K, LG, LG/U990, Lenovo, MIDP-2.0, MMEF20, MOT-V, MobilePhone, Motorola, NEWGEN, NetFront, Newt, Nintendo Wii, Nitro, Nokia, Novarra, O2, Opera Mini, Opera.Mobi, PANTECH, PDXGW, PG, PPC, PT, Palm, Panasonic, Philips, Playstation Portable, ProxiNet, Proxinet, Qtek, SCH, SEC, SGH, SHARP-TQ-GX10, SPH, Sagem, Samsung, Sanyo, Sendo, Sharp, Small, Smartphone, SoftBank, SonyEricsson, Symbian, Symbian OS, SymbianOS, TS21i-10, Toshiba, Treo, UP.Browser, UP.Link, UTS, Vertu, WILLCOME, WinWAP, Windows CE, Windows.CE, Xda, ZTE, dopod, hiptop, htc, i-mobile, nokia, portalmmm, Vodafone, Nokia6650d, SAMSUNG-SGH-A737, HTC_P3650, HTC_HD2_T8585, HTC-ST7377, htc_touch_pro2_t7373, HTC_Dream, HTC-P4600, HTC_Touch_Pro_T7272, HTCP3300, LG-CT810, LGE-MX380, BlackBerry7100i, BlackBerry7130e, BlackBerry7250, BlackBerry7230, BlackBerry7730, Cricket-A200, MOT-COOL0, MOT-V9mm, MOT-L6, MOT-V3r, MOT-V3i, MOT-A-1C, MOT-V620, MOT-V600, MOT-E398, mot-V3, Samsung-SPHM800, SAMSUNG-SGH-A867, SonyEricssonW595, SonyEricssonK800i, POLARIS, AdsBot-Google, Android, AppleWebKit, BB10, BlackBerry8330, BlackBerry8703e, BlackBerry8820, BlackBerry9000, BlackBerry 9350, BlackBerry 9360, BlackBerry 9370, BlackBerry 9380, BlackBerry 9780, blackberry9500, blackberry9520, blackberry9530, blackberry9550, BlackBerry9630, BlackBerry9650, BlackBerry9700BlackBerry 9790, BlackBerry 9800, BlackBerry 9810, BlackBerry 9850, BlackBerry 9860, BlackBerry 9900, BlackBerry 9930, BlackBerry9500, BlackBerry9520, BlackBerry9530, BlackBerry9550, CUPCAKE, Googlebot-Mobile, incognito, s8000, webOS

  4. BraveNewCode Inc.
    Member
    Plugin Author

    Posted 4 months ago #

    Still defaults to mobile setting on desktop, and ipad will NOT click over to desktop.

    It sounds as if you're reporting that the mobile theme is displaying in desktop browsers and vice-versa. If so, this is an issue with caching software and not WPtouch.

    You may configure your caching plugin not to cache mobile pages nor to serve cached pages when mobile devices are detected. To do so, enter the user agents found in the documentation link below to the "rejected user agents" areas in your caching plugin's settings. Remember to clear your plugin, browser, and device caches before retesting.

    http://www.bravenewcode.com/support/knowledgebase/default-mobile-device-user-agents/#cacheuas

Reply

You must log in to post.

About this Plugin

About this Topic