WordPress.org

Ready to get started?Download WordPress

Forums

WPtouch Mobile Plugin
[resolved] WPtouch loads my site but doesn't show any posts (15 posts)

  1. adamjwilliams
    Member
    Posted 2 years ago #

    I installed WPtouch on http://www.provoswimacademy.com/blog/ and when I visit the site with my smartphone, I don't see any of the posts. There is just one button "Home" that doesn't do anything. I checked the settings and tried changing WPtouch Home Page to Home instead of WordPress Settings and I couldn't pull up the site at all since it couldn't resolve the redirection. So I've left it set to WordPress Settings. My theme is Canvas by WooThemes.

    Any thoughts?

    http://wordpress.org/extend/plugins/wptouch/

  2. BraveNewCode Inc.
    Member
    Plugin Author

    Posted 2 years ago #

    Hi, sorry it's taken a bit to reply. I guess you've turned off the plugin? When I went to look WPtouch didn't show.

  3. adamjwilliams
    Member
    Posted 2 years ago #

    Hey,

    I just re-activated the plugin. I appreciate any help getting it working.

  4. forbairt
    Member
    Posted 2 years ago #

    Having the exact same problem. Also with the Canvas Theme.

    Custom Home page set to magazine template within Canvas (using a child theme) ...

    I've tried setting WP Touch Pro to use this "Home" page and nothing shows. ( Well I get the menu bar I can get to posts but not listed nicely in any way )

  5. forbairt
    Member
    Posted 2 years ago #

    played for another minute or two

    Basically in wordpress I originally setup a new page called Home

    This Home page used Canvas Magazine template.

    In wordpress
    Settings -> Reading - Front page -> I set this to this "Home"

    WP Touch Pro doesn't recognise this

    General -> Global General -> WPtouch Landing Page ... doesn't work no matter what I do here

    Instead go to

    Active Theme -> Theme General -> Miscellaneous Options and select the "Home" from "Custom latest posts page" ... and hey presto it's working fine

    Not 100% sure if this is the correct way of doing it ... something seems a bit borked somewhere but it seems to be working now

  6. teenshavechoices
    Member
    Posted 2 years ago #

    I'm having this issue with WPtouch, too, also running WooThemes' Canvas Theme: http://teenshavechoices.org/blog/

    Blog page displays as empty. It uses the Canvas Theme business template.

    I'm also having an issue with "too many redirects" keeping the site from displaying with WPtouch. It will work for a while, then I will get the redirects message. When I deactivate WPtouch, I can see my site again. I saw another post on this topic and responded there, too.

  7. teenshavechoices
    Member
    Posted 2 years ago #

    To clarify, the "too many redirects" message shows up after viewing the site with WPtouch on my iPhone for a while. It doesn't seem to affect the desktop view, but shuts me out entirely on my iPhone.

  8. adamjwilliams
    Member
    Posted 2 years ago #

    Hey forbairt,

    I'm trying to follow your instructions, but I can't find any of what you are describing below:

    Active Theme -> Theme General -> Miscellaneous Options and select the "Home" from "Custom latest posts page" ... and hey presto it's working fine

    Can you be a bit more specific where to go? Again, I'm using Canvas from Woo.

    Thanks!

  9. forbairt
    Member
    Posted 2 years ago #

    Hi Adam,

    Sorry only realised your post is related to the WPTouch plugin.

    My comments while related are to the WPTouch Pro plugin :(
    (Issue seems similar not sure what options there are in the standard plugin.)

    Just checked and we've the Developer license not sure if that makes any difference to the plugin

    James

  10. BraveNewCode Inc.
    Member
    Plugin Author

    Posted 2 years ago #

    adamjwilliams, it looks like your website is not accessible right now even from a desktop browser.

    teensavechoices,

    Make sure you do not have your WPtouch home page set to the Static front page in your WordPress Reading settings.

  11. teenshavechoices
    Member
    Posted 2 years ago #

    Thanks for the response, BraveNewCode Inc!

    Still having a problem and not sure how to correct it. I did have the WPtouch home page set to our Welcome page, which is the static front page in our WP Reading settings (we use a wordaround to display blog posts on our site's desktop home page with the business theme). I switched the WPtouch home page to another page - our blog - and, while I no longer received the "too many redirects" message, nothing but an empty Blog page shows up, either. Items in the drop down menu seem to work, but I can't find any blog content unless I click on tags or categories and continue from there.

  12. BraveNewCode Inc.
    Member
    Plugin Author

    Posted 2 years ago #

    Hi teenshavechoices,

    WPtouch Pro only, at this time, supports enabling a "Custom latests posts page" to allow you to display your latest posts on a page of your choice including a custom page template like you're currently using.

  13. teenshavechoices
    Member
    Posted 2 years ago #

    Thanks, BNC. You've confirmed what I suspected was the cause of the empty blog content problem. It's good to know that it works in the Pro version.

  14. nbloom
    Member
    Posted 1 year ago #

    If your news page on your desktop WP site uses a "blog page" template, and so there is no blog page on your (non-Pro) WPTouch mobile site, you can create a secondary News page (hide from your desktop WP site menu) that redirects to /category/news/. A bit of a workaround, but does the trick.

  15. larsstorm
    Member
    Posted 1 year ago #

    For users of the Classic WPtouch Pro theme:
    A slightly other approach I want to share is when using the ability to override the default landing page aka. "General -> Global general -> WPtouch Landing Page"

    This feature conflicts somehow with the "Active theme -> Theme general -> Custom latest posts page"

    When the information in these two places do not match no posts will be shown.

    Solution is to disable the override default landing page, then set the custom latest posts page to its correct value finish with re-enabling the override default landing page feature.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic