WordPress.org

Ready to get started?Download WordPress

Forums

WP Photo Album Plus
WPPA+ causing site slowness for all pages (9 posts)

  1. runBy
    Member
    Posted 1 year ago #

    Hi There, I am currently working with a site that has been using wppa+ from the beginning (http://pgjudo.ca), but recently started having problems with a 60 second delay in loading every page on the site whenever the wppa+ plugin is enabled. When it's enabled there is a consistent 60 second delay on all pages. Once the plugin is deactivated and any page on the site has been reloaded, the delay disappears. What's also interesting is that once the plugin is Activated again, the browser on which the page was "reloaded" is still quick, but any new browser instance on any other computer still sees the delay.

    I have read through your post at http://wordpress.org/support/topic/plugin-wp-photo-album-plus-slows-down-the-site-extremely and I have turned on debugging and tried the ?debug. The ?debug doesn't seem to produce any extra output, but enabling debugging prouduced two warnings "Notice: Undefined index: page in C:\inetpub\wwwroot\pgjudo.ca\wp-content\plugins\wp-phpmyadmin\wp-phpmyadmin.php on line 46" and "Notice: Undefined index: name in C:\inetpub\wwwroot\pgjudo.ca\wp-includes\capabilities.php on line 113" which are produced whether wppa+ is enabled or not. On googling the errors I found http://core.trac.wordpress.org/ticket/18461 in which you seem to address a similar issue, so I was wondering if that was related since your post was well after my initial install of wppa+.

    http://wordpress.org/extend/plugins/wp-photo-album-plus/

  2. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 1 year ago #

    1. Do not worry about "Notice: Undefined index: name in C:\inetpub\wwwroot\pgjudo.ca\wp-includes\capabilities.php on line 113". It is cosmetic.
    If you want to get rid of the unnamed role that causes this error, do the following:
    - install and activate the plugin 'Capability manager' Versie: 1.3.2 by Jordi Canals.
    - go to Users -> Capabilities.
    - select the unnamed role and delete it.

    2. You switched debugging on in wp-config. Nice, but not needed for me.
    I would like you to check Table IX-A3: Enable wppa+ debugging. This will produce the diagnostics when you add ?debug to the addressline.

  3. runBy
    Member
    Posted 1 year ago #

    Hi, thanks for the quick response. I can't seem to find the table your referring to. I have looked in both the information_schema and the pgjudowordpress databases. Am I missing something?

  4. runBy
    Member
    Posted 1 year ago #

    I was using the phpMyAdmin plugin to look at the tables btw.

  5. runBy
    Member
    Posted 1 year ago #

    Forget it, I found what I was supposed to do! :) The ?debug is now producint output (lots of output!).

    Thanks

  6. runBy
    Member
    Posted 1 year ago #

    Hi opajaap, do you need me to do anything else to help diagnose the problem? Unfortunately, with this plugin enabled like it is, the site is nearly unusable.

    Byron

  7. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 1 year ago #

    Are you sure your server has enough physical memory on board? I suppose you are self hostong on a windows server.

    I can only recommand to change to a different hosting provider.

  8. runBy
    Member
    Posted 1 year ago #

    The site is the sole site on a VMWare vm with 1 procesor and 2 GB of RAM running Server 2008 R2. However, it doesn't appear to be a physical resource issue. The server never reaches more than 55% of physical memory usage and about 27% of CPU cycles available. Also, in an attempt to troubleshoot it I actually restored the site to a brand new WordPress vm appliance running Debian and that exhibited the same behaviour, so it doesn't appear to be an OS related problem.

    In addition, if the problem were a physical limitation, they why would turning off wppa+ and "caching" the site without it on alleviate the problem for that browser once wppa+ is switched back on again? It would seem to me that it's almost like a file access problem for wppa+ that once the "file" gets read then wppa+ functions without timing out. I don't really know.

    The only real solution for me so far is to stop using wppa+ and go with some other plugin for managing the photos, which is *not* what I want to do but I need to get the site working properly again.

    Byron

  9. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 1 year ago #

    I really have no idea why you have these problems while others dont.

    The files wppa+ accesses are the image files in wp-content/uploads/wppa/, the files in wp-content/plugins/wp-photo-album-plus/images/ (and the pho and js files of course).

    The following db tables are used (maybe the db is a bottleneck):

    wp_wppa_albums, wp_wppa_photos, wp_wppa_rating, wp_wppa_comments, wp_wppa_exif and wp_wppa_iptc.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic