WordPress.org

Ready to get started?Download WordPress

Forums

wpng-calendar: shows nothing (8 posts)

  1. goldfischli
    Member
    Posted 6 years ago #

    hello

    i've been trying to get the google calendar plugin to work for hours but haven't suceeded so far.
    i installed the plugin, activated it, got an api from google, created a page and a custom field but the calendar entries are just not showing.

    the source looks like this:

    `<div class="entry">
    <div id="wpng-cal-events" style="display:none;"></div>
    <div id="wpng-cal-load-page" class="wpng-cal-loading">
    <img class="wpng-cal-image" src='/wp-content/plugins/wpng-calendar/images/loading_large.gif'/>
    </div>
    <div>
    <script type="text/javascript">
    weeks = 4;
    addLoadEvent(loadCalendarByWeeks);
    </script>
    </div>`

    i don't get an error msg or anything so i really don't know what's wrong.

    does anyone have an idea what the problem could be?
    thanks in advance!

  2. goldfischli
    Member
    Posted 6 years ago #

    when I check the page with ff/birebug i get the following error:

    addLoadEvent is not defined
    [Break on this error] addLoadEvent(loadCalendarByWeeks);

    any ideas?

  3. kalico
    Member
    Posted 6 years ago #

    The instructions are poor. Check to see if you've done the following:

    1. set up your calendar at Google
    2. Go to Settings
    -- Calendars
    -- Share This Calendar: Make This Calendar Public
    3. Click on Calendar Details tab
    4. Scroll to the Calendar Address section, toward the bottom.
    5. Click the XML button, and get the URL for your calendar feed.
    6. Go to your wpng calendar options (in WordPress admin) and paste the URL of the feed there (along with your API), making sure it ends with the word "full" not the word "basic"
    7. Be sure you configure the Wiki question. Just set to NO if you're not sure.
    8. Make sure you've set up a Page for your calendar, according to the instructions provided with wpng-calendar.

    This should work. If not, I'll try to help further.

  4. Anonymous
    Unregistered
    Posted 6 years ago #

    Kalico,

    Thank you so much. This fixed my problem after trying and re-trying for hours.

    Thank you!

  5. miffy
    Member
    Posted 5 years ago #

    I am having the same problem, but already followed all the steps. Still, calendar entries are not showing up. Help !!!

    I am running 2.6. The feed url shows up okay on Google Homepage with events.

  6. oh2bWP
    Member
    Posted 5 years ago #

    THANK YOU, kalico! I appreciate your clear instructions.

  7. soulsilver
    Member
    Posted 5 years ago #

    Thank you so much, our calendar is working now!
    http://ahe.org.nz/?page_id=24

  8. KostRev
    Member
    Posted 5 years ago #

    Hi,
    I'm having the same problem and have gone through the steps detailed above but to no avail. I'm wondering if the API key is an issue since I'm using a dev link. I used the dev link URL to generate the key. I also generated one for the domain.

    Here is my test page. I've attempted to add the calendar in the side bar as well as the page body:
    http://teen.mam.org.php5-9.websitetestlink.com/test/

    Any ideas?

  9. KostRev
    Member
    Posted 5 years ago #

    Hi,
    I'm having the same problem and have gone through the steps detailed above but to no avail. I'm wondering if the API key is an issue since I'm using a dev link. I used the dev link URL to generate the key. I also generated one for the domain.

    Here is my test page. I've attempted to add the calendar in the side bar as well as the page body:
    http://teen.mam.org.php5-9.websitetestlink.com/test/

    Any ideas?

Topic Closed

This topic has been closed to new replies.

About this Topic