WordPress.org

Ready to get started?Download WordPress

Forums

WPMU new install produces 404 posts (44 posts)

  1. meshmarketer
    Member
    Posted 3 years ago #

    My website is http://micuerpomilogr.com and it's a brand new install. Each new post produces a 404 error. Pages are OK. My other sites on this install appear fine. I don't yet know about brand new sites as I am about to test other new ones. Any help would be greatly appreciated.

    FOLLOW-UP: I think that there is some kind of problem I created when I deleted the site and now it doesn't work when I tried to create a new one.

  2. meshmarketer
    Member
    Posted 3 years ago #

    FOLLOW-UP 2: Is there now way to flush the cache of a deleted site?

  3. meshmarketer
    Member
    Posted 3 years ago #

    FOLLOW-UP 3: I discovered that if I were to try and delete the site, I get a warning telling me I'll never be able to use that URL again. That's weird because I should be free to delete and re-add sites when I want. Is there really no way to avoid the trap? I was using 3.1 before upgrading to 3.2 hoping that 3.2 might fix the problem. I guess I made the goof without a warning on 3.1, but now that I'm on 3.2, I see there is a warning.

  4. meshmarketer
    Member
    Posted 3 years ago #

  5. I discovered that if I were to try and delete the site, I get a warning telling me I'll never be able to use that URL again.

    where are you deleting it from? as best I can remember you ony get that message from the admin area of the sub site. that message is for users, not super admins.

    delete it out of the db, and yes of course you can use it again.

    or go to network admin -> sites and delete it there. that *really* deletes it.

    (thread also moved to multisite section).

    and if you're getting 404s go resave your permalinks. that's not related to deleting sites, it's an issue we've seen before where rewrite rules are getting flushed.

  6. meshmarketer
    Member
    Posted 3 years ago #

    Thanks, Andrea. I always appreciate your help.

    I am deleting it from the network side.

    I don't know how to resave permalinks. How do I do that?

  7. meshmarketer
    Member
    Posted 3 years ago #

    I went to my permalinks and saved it again under network and it didn't change anything. I also changed the permalinks on the sub-blog itself and no change.

  8. resaving permalinks always applies to the single site. there's nowhere in network admin that affects permalinks other than the setup page.

    http://micuerpomilogro.com/?page_id=2 this tells me you don;t even have pretty permalinks setup on that blog. is that a sub site that is domain mapped? Or is it the main iste?

    also you have no posts in that blog. you're getting a 404 on the main page because there's nothing to show.

  9. meshmarketer
    Member
    Posted 3 years ago #

    Andrea, thank you again for your support on this one. I know I'm in good hands.

    So, I do have a post at http://micuerpomilogro.com/uncategorized/hello-world/

    I get a 404 error there.

    I changed the permalinks BACK to the defaults and I still get the error.

  10. meshmarketer
    Member
    Posted 3 years ago #

    And it's domain mapped. I have success with all my other blogs (domain mapped) on the site. No other blogs exhibit this problem.

  11. meshmarketer - Please stop double posting. You can trip the spam filter doing that, which would suck. (Also it's MultiSite, not WPMU, which does matter ;) )

    ANDREA'S point is that if http://micuerpomilogro.com/?page_id=2 WORKS and does not redirect to a pretty URL, then you don't have Pretty Permalinks turned on.

    Go to ipstenu.org/?p=134 and it redirects you to http://ipstenu.org/blog/2004/a-winter-interlude/

    Yours ISN'T doing that :) Ergo permalinks ain't on.

  12. meshmarketer
    Member
    Posted 3 years ago #

    @Ipstenu, thanks for clarification re Multisite v. WPMU.

    As I had said up top, my pages DO work.

    The posts are the problem, not the pages. I tried creating a test post and even that didn't work.

    And I don't quite know what you mean by "permalinks ain't on" because I did have them on and reverted them back to defaults and it doesn't work either way.

    I appreciate the help, but is there something I can do about this? The error is pretty simple and shouldn't be so hard to fix. I deleted the site and brought it back and I got the same error.

  13. And I don't quite know what you mean by "permalinks ain't on" because I did have them on and reverted them back to defaults and it doesn't work either way.

    Default permalinks aren't pretty and they're not on.

    A pretty permalink:
    http://micuerpomilogro.com/uncategorized/hello-world/

    A Default Permalink:
    http://micuerpomilogro.com/?p=2

    What is the post ID for the 'hello world' post? It SHOULD be http://micuerpomilogro.com/?p=1 but it's not. Which is why Andrea said you didn't have any posts.

  14. meshmarketer
    Member
    Posted 3 years ago #

    I have turned on pretty permalinks back on again and there is something REALLY WEIRD with this.

    Now my hotlink looks like this: http://micuerpomilogro.beachheadcommunications.com/uncategorized/%posts%/

    ...and, of course, it throws an error (as Bad Request).

  15. What, exactly, is your permalink structure? Copy paste it from the permalinks page.

    Also, what is the post ID? When you press 'preview' it shows you. We need that.

  16. meshmarketer
    Member
    Posted 3 years ago #

    Permalink structure is /%category%/%postname%/ (I did have it set to /%category%/%posts%/ for a short while there...boneheaded mistake there... I don't know they just don't make pretty permalinks as a default option.)

    Link for the post in the admin:

    http://micuerpomilogro.beachheadcommunications.com/wp-admin/post.php?post=1&action=edit

    Link for the post as view:

    http://micuerpomilogro.beachheadcommunications.com/uncategorized/hello-world/

  17. http://micuerpomilogro.com/uncategorized/hello-world/

    and

    http://micuerpomilogro.com/?p=1

    are DIFFERENT 404 pages.

    And http://micuerpomilogro.beachheadcommunications.com/?p=1 (and http://micuerpomilogro.beachheadcommunications.com/uncategorized/hello-world/ ) redirtect you to the other domain.

    What the heck have you done with the domain mapping? Which site is the MAIN site and which is the subsite?

    There's a whole lot going on here :)

  18. meshmarketer
    Member
    Posted 3 years ago #

    I don't quite know what you mean. All of my working domains have the same structure for the links. They resolve to the proper domain (all eight domains) except for this one.

  19. This feed contains no entries.

    And that means no posts. we won't be able to help without a post.

  20. What URL is the base URL under which you installed WordPress?

    I'm GUESSING that beachheadcommunications.com is the MAIN domain, and http://micuerpomilogro.beachheadcommunications.com is a SUB domain site you have MAPPED to micuerpomilogro.com

    Is that correct?

    If so,

    1) what plugin did you use to map?
    2) Did you check if pretty permalinks worked BEFORE you mapped the subdomain?
    3) Does it work WITHOUT mapping?

    (also when I said the 404s were different pages, when I open them, side by side, in Chrome, they are, literally, NOT the same layout. The text is wrapped on one and not the other.)

  21. meshmarketer
    Member
    Posted 3 years ago #

    @Andrea, I have seven posts in this blog that were imported. This problem existed before I imported anything.

    @Ipstenu, You are correct on your assumptions about the main domain and the subdomain.

    1. The plugin is WordPress MU Domain Mapping (of which you have publicly spanked me for calling it a WPMU by the way).
    2. It did not working before pretty permalinks and it also didn't work after, nor after changing back and then back again.
    3. I don't know how it could work without mapping.

    Could you please REFRAIN FROM ALLCAPPING AS IF I WERE A MORON? I am asking for help not berating.

  22. @Andrea, I have seven posts in this blog that were imported. This problem existed before I imported anything.

    go look in the database for them, confirm they are there. You need to sort out what's messed up before domain mapping it. And rght now there's no evidence of any posts. Turn off all plugins on this site, revert to the default theme, go *make sure* you have custom permalinks enabled. I don't car which one, just something other than default.

    Isptenu uses caps for emphasis, not yelling.

  23. meshmarketer
    Member
    Posted 3 years ago #

    @Andrea, I don't know what you mean by "go look in the database for them" as I am able to edit the posts like I would if it were working. I would love to sort out what's messed up before domain mapping it, but I'm not exactly sure how I would go about doing that. It does work fine when I set the primary as http://micuerpomilogro.beachheadcommunications.com if that's what you mean.

    I get the error from the get-go. I am not turning anything on for the site. The error appears as soon as I set micuerpomilogro.com as the primary.

    Isptenu could use a lesson from you to *avoid allcaps* when he wants to empasize. I'm sure he means well and would save the world if given the opportunity, but it seems very rude and unkind and I'm not going to pretend that it's appreciated.

    @Andrea, if you want, I can set you up with an admin username/password and email it to you.

  24. http://micuerpomilogro.beachheadcommunications.com still redirects me to the mapped domain.

    No, I cannot go login to help. We're volunteers, not paid. I can help as much as I'm willing to here.

    Please unmap the site. I cannot help with anything as it is now.

    I don't know what you mean by "go look in the database for them" as I am able to edit the posts like I would if it were working.

    I wanted you to verify that the posts did indeed exists in the backend. If you can see them in the db then you can see them in the admin area.

  25. meshmarketer
    Member
    Posted 3 years ago #

    @Andrea, I have set the primary domain back to http://micuerpomilogro.beachheadcommunications.com and that is all I have done. You can see the posts just fine I'm sure.

    I do appreciate your help and your willingness to volunteer your time.

    I would like to think that something is always gained by being interested and wanting to help.

  26. I was on an iPad, which is nigh impossible to use the bold/em buttons without goobering it all.

    Mapping is still on. If I go to http://micuerpomilogro.beachheadcommunications.com and click on the first post, it takes me to http://micuerpomilogro.com/uncategorized/hello-world/

    That's totally wrong in every way. Did you go in and change the site name in the wp-admin/network edit screens? Something is really, crazy side, way wrong on your set up here. There's no way the domain mapping plugin (which predates MultiSite, and plugins can't be renamed, hence the silly name) should be changing the links.

    ETA Oooooh

    http://micuerpomilogro.beachheadcommunications.com/resultados/mis-resultados-hasta-la-fecha-y-una-nueva-foto/ works.

    Something's wrong with some of the posts. Now that's interesting.

    What other plugins are you running?

  27. I have set the primary domain back to http://micuerpomilogro.beachheadcommunications.com and that is all I have done. You can see the posts just fine I'm sure.

    Nope. I get a 404. and you still don;t have custom permalinks on that site. at least not when I checked. becasue I'm still getting redirected to http://micuerpomilogro.com/.

    http://micuerpomilogro.beachheadcommunications.com/resultados/mis-resultados-hasta-la-fecha-y-una-nueva-foto/ works for me, but shows a completely different site.

    I would like to think that something is always gained by being interested and wanting to help.

    there is, but at some point I need to pay bills. ;)

  28. meshmarketer
    Member
    Posted 3 years ago #

    @Ipstenu: Thanks for continuing to look into this.

    I'd love to know if there is some sort of cache I can clear to resolve this issue.

    @Andrea: I can do screen shots if you like, but I honestly *do* have custom permalinks turned on. Isn't proof of that in how the link that works for you is formed?

    And I know what you mean about paying the bills, so hopefully this will help you pay the bills down the road by helping to unfrack what I have obviously fracked.

  29. As soon as I try to go to the subdomain itself, it redirects to a domain using the Fresh Ink Magazine.

    all working posts I see are sing twentyEleven.

    Something's up with how you mapped http://micuerpomilogro.com/ to the server itself. not the wp or plugin part. that's my educated guess.

  30. I only see that smetimes, Andrea, like on the Hello World post, but not some of the others.

    Wich is why I asked what plugins are you using, mesh :) can you turn them all, yes all, off?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags