WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] wp.me shortlinks all stopped working (6 posts)

  1. doug123wp
    Member
    Posted 3 years ago #

    Re http://bitterdivorcee.com --

    Site has been working fine but I changed something somewhere so that all the wp.me shortlinks now lead to 404 dead ends at "localhost" instead of the bitterdivorcee domain.

    E.g., http://wp.me/pObOy-4U --> resolves to -> http://localhost/bitterdivorcee?p=304 [404 error]

    Recent changes -- upgraded WP 3.0.5 to 3.1 and set up local MAMP server to run site @ localhost (which works). Did not notice the problem right away, so I don't know when it started.

    I have checked wp_options and wp_config for weirdness, no luck. I tried moving .htaccess. I tried replacing wp_content with the most recent backup, and reverting the SQL database, no luck. I've wondered if I should downgrade to WP 3.0.5, and whether this would cause headaches.

    The broken links don't work on my iPhone (off wireless), either, so it's not a DNS issue. I flushed every cache I could think of and tried three browsers (Safari, Firefox, Chrome).

    I'm stumped. Help?

  2. doug123wp
    Member
    Posted 3 years ago #

    I should add that newly generated shortlinks (through the new post editor) also fail.

  3. doug123wp
    Member
    Posted 3 years ago #

    last comment -- problem appears to be with the way the site is registered with wordpress.com, I assume for the stats API activation. WP does shows the "localhost" URL. How to change it? I've asked support.

  4. doug123wp
    Member
    Posted 3 years ago #

    Solved: Deleted stats folder from plugins and reinstalled, re-entering API key.
    Problem apparently stemmed from WP stats plugin being active on a localhost installation unde MAMP. Deactivated all plugins on local copy that talk to the outside world.

  5. scottconnerly
    Member
    Posted 3 years ago #

    Doug, I tried your steps, and it doesn't seem to have worked for me.

    See also: https://wordpress.org/support/topic/plugin-wordpresscom-stats-wp-me-short-links-wrong-url

  6. doug123wp
    Member
    Posted 3 years ago #

    Maybe your problem is different--I noticed thru my wordpress.com account that the URL for one of the domains had been changed to localhost, because I made the mistake the tech identified below. Give them a shot if necessary, I was pleased to get a helpful, intelligent, quick reply. Here is the verbatim exchange (good luck!):

    For the self-hosted blog bitterdivorcee.com, the API key for stats I
    assume came from wordpress.com, where I have an account. all wp.me
    links there are now broken, routing to localhost.

    In my wordpress.com account, I see bitterdivorcee.com as a "linked
    account" with the wrong (localhost) URL. I don't know how I changed
    this by accident. How do I fix it now?
    ***
    Hi,

    Okay, can you try deactivating the stats plugin and then deleting the files from your server? Then, if you install the plugin again you should be able to reset the API key which will reset the site URL attached to your profile.

    Let me know if you have any other questions.

    Cheers,
    --
    Andrew | Happiness Engineer | WordPress.com

    and

    Hi,

    My money is on it being installed locally first. When you had it as a MAMP install for local development did you just do a straight database transfer to the live site?

    If so that would have preserved some settings from the local install. Generally if you're doing local development I'd recommend against installing things like stats and shortlink plugins that will rely upon your live URL.

    Best,
    --
    Andrew | Happiness Engineer | WordPress.com

Topic Closed

This topic has been closed to new replies.

About this Topic