WordPress.org

Ready to get started?Download WordPress

Forums

WPG2 Installation (11 posts)

  1. pcof
    Member
    Posted 8 years ago #

    Hi.
    I am trying to install WPG2_rc2 + Gallery 2.0 rc-2 and I got the following error message in Gallery2 init:

    Warning: Cannot modify header information - headers already sent by (output started at i:\WAMP\www\valve\wp-admin\admin-header.php:8) in i:\WAMP\www\valve\gallery2\main.php on line 30

    Fatal error: Call to undefined function GalleryInitFirstPass() in i:\WAMP\www\valve\gallery2\modules\core\classes\GalleryEmbed.class on line 80

    These two are ok:
    Gallery2 in G2 Path Success
    Embedded Page Found? Success

    I made a local installation first to test if everything is fine, before uploading to the web.
    My WP-Blog is still under construction and I hope it will be finished soon: http://www.insomnia.art.br/valve/

    Thanks for any help.

  2. pcof
    Member
    Posted 8 years ago #

    I tried all possibilities but I am still having the same problem. :-(

  3. Read "Interpreting the Error Message:" from the link above and try again. The blank line is on line 8 of admin-header.php. It must be removed.

  4. pcof
    Member
    Posted 8 years ago #

    This line only have information about the title.
    <title><?php bloginfo('name') ?> › <?php echo $title; ?> — WordPress</title>

    No spaces at the end of the line!!

    Thanks.

  5. Try downloading WordPress again, and replace your copy of admin-header.php with a fresh one from the new download.

  6. pcof
    Member
    Posted 8 years ago #

    I had already tried this possibility and nothing changed.
    Please send me your admin-header.php. My e-mail is pc@insomnia.art.br
    Thanks for your patience.

  7. If a fresh download made no change, then neither will my admin-header.php file. I'm out of ideas, hopefully someone else will stop by this thread.

  8. pcof
    Member
    Posted 8 years ago #

    Sorry! I didn't have installed the gallery2.
    Now I got 2 errors:
    Gallery2 Module: ImageBlock Active? Failed
    Gallery2 Module: ImageFrame Active? Skipped Due to Previous Error
    But I need to download imageblock. Ok?

  9. pcof
    Member
    Posted 8 years ago #

    Everything is ok now. I installed and activated ImageBlock and ImageFrame.... What I have to do now?
    The installation is 100%.

  10. tariq
    Member
    Posted 8 years ago #

    Assuming you have followed the information on the WPG2 page http://wpg2.ozgreg.com/index.php/Main_Page you should probably start adding some photos to your gallery install using either the wp-gallery2.php URI or the URI of your gallery install. Once some photos are installed you can link to the gallery image as described on the WPG2 page or add an ImageBlock to your sidebar or anything else.
    After that you can mess around with themes and permalinks and the like and you'll be set.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.