WordPress.org

Ready to get started?Download WordPress

Forums

WPG2 and WP 2.7 RC1 - WYSIWYG (9 posts)

  1. jelpesao
    Member
    Posted 5 years ago #

    I have upgraded to WP 2.7 RC1 and have found that the WYSIWYG breaks in WordPress when the WPG2 plugin is enabled. Was looking to see if anyone has gone thru this and maybe has a fix for it.

  2. civichonda
    Member
    Posted 5 years ago #

    I have the same problem. Help please!!

  3. alternateroute
    Member
    Posted 5 years ago #

    This might have something to do with the new version of TinyMCE used in version 2.7.
    It is a worthy starting point anyway.

  4. n4rf
    Member
    Posted 5 years ago #

    Hi at all,

    i updated to the newest wordpress version yesterday, and figured out that the WYSIWYG Bug depends on an obsolete function call in the language files of wpg2. It seems the original (english) lang file is already up to date, so the bug only affect to non english users like me. But it doesn't matter, here is a simple workaround...

    Just go to the folder "/wp-content/plugins/wpg2/g2image/langs/" of your wordpress installation, there should be a xx.js for your language. In my Case the german file de.js. Open the file in a text editor of your choice and replace:

    tinyMCE.addToLang

    with:

    tinyMCE.addI18n

    thats the new name of the new multilang function in tinymce. Don't touch everything before or after this string. Save / upload and replace the old file, and now the WYSIWYG should work fine.

    Rgds, Bjoern

  5. regenpfeifer-de
    Member
    Posted 5 years ago #

    Hello,

    I'm using WordPress 2.7.1 and have tried the above mentioned solution in order to fix my problems with WPG2. But it's still not working. It needs all other plugins to be deactivated in order to show all WPG2-option-pages. Furthermore, the insert window for adding pictures to posts in most cases stays blank.

    Any help would be appreciated,
    regenpfeifer

  6. verbal0rchid
    Member
    Posted 5 years ago #

    I have also noticed I don't have the visual editing capability since upgrading to 2.7.1 either.

    Also, my Headspace2 and Register Plus plugins don't work now. RP isn't compatible with the newest release of WP but Headspace2 should be, and it's not working. weird....

  7. verbal0rchid
    Member
    Posted 5 years ago #

    I think I managed to get mine to work at least.

    I deactivated ALL my plugins (there were only 5 I use), then clicked on the 'upgrade' link under Tools, which updated WP even though i *have* the newest release, it still updated automatically. Then reactivated each plugin and kept checking "add new post" to see if my visual editor was back, and eventually I got all five plugins reactivated and it's still going good. Don't know what the problem was but this seemed to fix it.

  8. Philippe Verhelle
    Member
    Posted 5 years ago #

    To regenpfeifer-de:
    I also had the same problem (blank pages for WPG2-options). I solved the problem by adding a line in the .htaccess file in the root directory of my WordPress installation.

    This line forces the use of PHP5 instead of PHP4 (well-known problem for an 1and1 hosting).

    #Force PHP5 at 1and1
    AddType x-mapp-php5 .php

    I'm not sure that this will be the right solution for you.

  9. danalongerdays
    Member
    Posted 5 years ago #

    I am having the same problem. I read a fix about reinstalling the tinyMCE file, which I've tried and it doesn't work. I also reinstalled the entire js file which also didn't work. It is extremely frustrating. Any help is greatly appreciated.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags