WordPress.org

Ready to get started?Download WordPress

Forums

WPBook - Stream permission issues - API Error Code: 100 (22 posts)

  1. mykesdes
    Member
    Posted 4 years ago #

    I think I am the only one I see with this problem. Not being familiar with FB apps, it took me a while to figure out what my specific problem was, but here's my best shot at describing it.

    This is my personal FB I trying to post to, not a fan page or anything like that.

    Plugin installs fine, followed instructions to setting up App in FB, everything went fine, seemingly. Went back to WPBook settings, and got to the "click here to grant WPBook the permission to publish to your stream."

    Initially when I clicked this it brought up a window asking
    "Allowing AppName access will let it pull your profile information, photos, your friends' info, and other content that it requires to work."

    Naturally I click "allow"

    And then I am presented with:
    ------------------------------------
    This page is just for the author of the blog to grant extended permissions.

    Your userid is XXXXX

    You will need to enter that number into WPBook's settings page on your WordPress install.

    Click here to trigger extended permissions dialog box
    ------------------------------------

    I enter the id into the WPBook settings.

    Then when I click "Click here to trigger extended permissions dialog box" I get a FB like modal window for Requesting Special Permissions that appears momentarily looking like it is attempting to load information into it and then I am redirected to a plain white page that is on my domain now, not FB, stating the same information above ^^^^

    So, I try clicking "Click here to trigger extended permissions dialog box" again, and this time the Requesting Special Permissions window pops in again, but I am met with the following error message inside the box

    ---------------------
    API Error Code: 100
    API Error Description: Invalid parameter
    Error Message: When enabling the profile selector, an app may not request user-only permissions
    ---------------------

    My only option at this point is click "ok" and it redirects back to my public facing app page, which has blog posts it, so everything seems to be working accept for the stream business.

    If I go to my app settings in my FB profile, I do see Additional Permissions, but the only option that is in there is "Publish recent activity (one line stories) to my wall"

    If I enable "Show errors posting to Facebook Stream" in my WPBook options, I of course get "Caught exception: The user hasn't authorized the application to perform this action"

    And this has been the extent of my troubleshooting. I couldn't find anyone else with this issue while searching, I can't imagine what I could have done incorrectly while setting this up, but apparently something is pissed at me ;)

    Thank you so much for even taking the time to read this, the plugin is excellent, and I appreciate all the support you have provided the community.

    Thanks!

  2. johneckman
    Member
    Posted 4 years ago #

    This API Error Code 100 just started this weekend - I think Facebook changed something on there end and I'm looking into it - at least one other user is getting the same problem.

  3. johneckman
    Member
    Posted 4 years ago #

    Based on this forum in Facebook http://forum.developers.facebook.com/viewtopic.php?pid=218171 this shoudl be fixe.

    Can you tell me if you're still experiencing it?

  4. mykesdes
    Member
    Posted 4 years ago #

    Hey, correct! it IS working now. FB hickup I guess.

    I love this plugin, again thank you so much for work you're doing for the community.

  5. jennhl
    Member
    Posted 4 years ago #

    please help me.. that link is broken and I need a solution for the same problem.

  6. mykesdes
    Member
    Posted 4 years ago #

    I wonder if that has anything to do with the new changes FB is implementing.

    http://mashable.com/2010/04/21/zuckerberg-video/

    I have not tested my blog to see if it still posts to wall or not.

  7. johneckman
    Member
    Posted 4 years ago #

    @jennhl - which link is broken?

    Are people still seeing this error?

    @jennhl - can you describe what issues you are experiencing?

  8. freejung
    Member
    Posted 4 years ago #

    I am still getting this error, at the same point in the process. I'm trying to enable stream.publish permissions for a fan page.

  9. freejung
    Member
    Posted 4 years ago #

    API Error Code: 100
    API Error Description: Invalid parameter
    Error Message: When enabling the profile selector, an app may not request permissions that do not apply to all profiles in the selector. Note: You are seeing this message because you are a developer of this application. For regular users, inapplicable permissions are silently ignored.

    I get this whenever I click the "click here to trigger the extended permissions dialogue box" link.

  10. johneckman
    Member
    Posted 4 years ago #

    @freejung -

    Before you click on the "trigger the extended permissions dialog" link, what is showing on the page on which that link appears?

    It should be telling you your FB profile ID and also telling you what pages you are the admin of AND have the app added. (In other words, it should be listing all the eligible pages).

    The only thing I can imagine is that somehow some of the pages in the profile selector aren't eligible for some of the permissions being requested?

  11. johneckman
    Member
    Posted 4 years ago #

    @freejung - Have you added the application to the fan page for which you're trying to grant stream.publish?

    That is, is the application already on that fan page, in the boxes tab or via the 'add to page' setting in the application page?

    WPBook is requesting 'offline access' and 'stream.publish' permissions in that dialogue - for some reason FB is saying that one of those permissions doesn't apply to one of the profiles requested.

  12. freejung
    Member
    Posted 4 years ago #

    This page is just for the author of the blog to grant extended permissions.

    Your userid is 1848528048

    You will need to enter that number into WPBook's settings page on your WordPress install.

    Click here to trigger extended permissions dialog box

    After you have granted permission, return to the main application: KPA

    You are also listed as the admin of these pages:

    •KPA (74667964859), This page has NOT granted stream.publish permissions to this app

    If you are the administrator of pages which do not show up in this list, you need to ensure you have added the application to the pages first.

    Follow the detailed directions included with the plugin.

  13. freejung
    Member
    Posted 4 years ago #

    Yes, I've added the app to the page, and there is a box added to the page which correctly lists all recent blog posts. I've entered my ID into the appropriate spot in the WP plugin settings. I have it set to publish both to my wall and to pages.

    In my applications list on the page, there is an "application settings" link. I tried that, and it gives me the option to give the application permission to publish recent activity to my wall. I've tried both with this checked and with it unchecked.

  14. johneckman
    Member
    Posted 4 years ago #

    Hmm. Curiouser and curioser. Maybe the recent facebook changes have changed the permission model in some way I'm not understanding.

    When you're in "edit page" mode, and click on "application settings" for your WPBook-powered FB app, there should be a "Profile" tab and an "Additional Permissions" tab.

    In the "Additional Permissions" tab, there should be an option which says "App Name has permission to:" followed by a checkbox labelled "publish content to my wall"

    Is that what you see for your app? (It should be checked).

    Do you have "Show errors posting to Facebook Stream" checked in your WPBook settings?

    Is it working for your personal profile but not for the fan page, or for neither?

    (I wonder if maybe the issue is that I'm asking for 'offline_access' AND 'stream.publish' permission for both the fan page AND the personal wall, but that doesn't any longer apply to both?)

    If I were to give you a link to a version with some changes would you test it for me?

  15. johneckman
    Member
    Posted 4 years ago #

    Those of you who are having issues, please update to 1.5.5 of the plugin (I just now checked it in and tagged release, so it may not be available for a short while yet).

    I changed how permissions requests are done - so I hope it will eliminate this problem.

  16. freejung
    Member
    Posted 4 years ago #

    Yes, yes, neither, and yes.

  17. freejung
    Member
    Posted 4 years ago #

    Interesting, now after upgrading I get this:

    Error while loading page from KPA Blog
    KPA Blog is under construction. Please try again later.

    Configuration errors:
    To fix this error, please set your Connect URL in the application settings editor. Once it has been set, users will be redirected to that URL instead of this page after logging in.

    I put in my connect URL, and tried again. Now when I click the "click here to grant permissions to your userID" link I get this:

    API Error Code: 100
    API Error Description: Invalid parameter
    Error Message: Param fbconnect must be a boolean

    However, I was able to add stream.publish permissions for my page. I'll test that with the next blog entry and let you know how that goes.

    This is definitely progress, thanks for the quick response to this issue!

  18. freejung
    Member
    Posted 4 years ago #

    Nope, still not publishing to my page, but I think you're on the right track!

  19. johneckman
    Member
    Posted 4 years ago #

    Hmm. Ok.

    Ah, the joys of FB. Seems they changed from "true/false" to "1/0"

    So I need to revise index.php again.

    If you're comfortable doing it yourself, open:

    wpbook/theme/index.php

    and edit line 69, from:

    <p><a href="http://www.facebook.com/login.php?api_key=<?php echo $api_key; ?>&connect_display=popup&v=1.0&next=http://www.facebook.com/connect/login_success.html&cancel_url=http://www.facebook.com/connect/login_failure.html&fbconnect=true&return_session=true&session_key_only=true&req_perms=read_stream,publish_stream,offline_access">Click here to grant permissions for your userid.</a> (This is required if you intend to publish to your personal wall OR any fan pages.)</p>

    to:

    <p><a href="http://www.facebook.com/login.php?api_key=<?php echo $api_key; ?>&connect_display=popup&v=1.0&next=http://www.facebook.com/connect/login_success.html&cancel_url=http://www.facebook.com/connect/login_failure.html&fbconnect=1&return_session=1&session_key_only=1&req_perms=read_stream,publish_stream,offline_access">Click here to grant permissions for your userid.</a> (This is required if you intend to publish to your personal wall OR any fan pages.)</p>

    (Basically just replacing the 'true' with '1' throughout that line.

  20. johneckman
    Member
    Posted 4 years ago #

    If you're not comfortable making the changes you should be able to download the "development version" from the bottom of the list on this page:

    http://wordpress.org/extend/plugins/wpbook/download/

    I believe that pulls from Trunk in SVN every 15 minutes or so

  21. freejung
    Member
    Posted 4 years ago #

    Whohoo, that worked! Thanks!

  22. johneckman
    Member
    Posted 4 years ago #

    @freejung - does this mean you've now been able to post new blog posts and have them show up on a wall / fan page?

Topic Closed

This topic has been closed to new replies.

About this Topic