WordPress.org

Ready to get started?Download WordPress

Forums

[WPBook ] Posts not published in my Wall (51 posts)

  1. luisj
    Member
    Posted 3 years ago #

    I installed the WPBook plugin aind all os ok, except two things.
    One is that my new posts are not published to my Facebook Wall, despite I have checked the option "Publish new posts to YOUR Facebook Wall" in the section "Stream/Wall Options" of the plugin.
    Can anyone help me to solve this problem?
    Thank you very much for your attention.
    Luis J.

  2. johneckman
    Member
    Posted 3 years ago #

    What does your "check permissions" page say? Have you granted the necessary permissions to your app?

  3. luisj
    Member
    Posted 3 years ago #

    OK, that´s it.
    I granted the permissions now and all's ok.
    But I have another issue: I can´t Invite my friends through the link in the app. I receive the message
    "Error
    Error while loading page from ligadosblog
    Empty response received.
    Find another app
    "
    Is there any solution?
    Thank you very much for your support.
    All the best.

  4. TraciBunkers
    Member
    Posted 3 years ago #

    Where do you check the permissions page to grant access to the app?

  5. TraciBunkers
    Member
    Posted 3 years ago #

    Never mind! I found the answer on another post. It's in the WPBook settings in WordPress.

  6. Vakantie Ameland
    Member
    Posted 2 years ago #

    In answer to luisj, I do have exactly the same problem. The "Invite Friends" link does give the same error. How to solve this?? Any ideas

  7. calendaruser
    Member
    Posted 2 years ago #

    Hello - setting up Page tab with Heroku server - to display wpbook feed. Not sure what urls to use. Also setting the post to wall function is not displaying on timeline page in Facebook. Any suggestions?

  8. johneckman
    Member
    Posted 2 years ago #

    @calendaruser What do you mean you are setting up a page tab? What is the url of your WordPress install?

    Are the posts to wall showing in the activity log?

  9. johneckman
    Member
    Posted 2 years ago #

    @luisj and @christianebuddy what is the address of your facebook application?

    Are your permissions otherwise correct, and your app is loading normally?

  10. luisj
    Member
    Posted 2 years ago #

  11. Vakantie Ameland
    Member
    Posted 2 years ago #

    It's this part of the problem:

    I can´t Invite my friends through the link in the app. I receive the message
    "Error
    Error while loading page from ligadosblog
    Empty response received.
    Find another app

    https://apps.facebook.com/vakantiehuisameland/

  12. johneckman
    Member
    Posted 2 years ago #

    @luisj @chrstianebuddy Just tried and it seemed to work for me.

    At what step of the process does it fail?

    When I click on invite friends I get a list of friends to invite

  13. calendaruser
    Member
    Posted 2 years ago #

    Hi everyone - After following the wpbook online instructions, it's working now. Need to figure out how to add app to page timeline now.

  14. luisj
    Member
    Posted 2 years ago #

    Hi John.
    My problem with Invite Friends issue is solved.
    What I would like to know now is how publish in my facebook wall, not the app wall, the posts I publish in my blog, in a automatically manner, ie, when I publish a post at my blog, it should appear automatically in my facebook wall (a digest with link, you know...). Is it possible with WPBook? I've done already this in the past, but I can´t remember if it was with WPBook or with another wordpress plugin.
    Thanks for your attention.

  15. johneckman
    Member
    Posted 2 years ago #

    @luisj Yes, this is entirely possible.

    Detailed directions here: http://wpbook.net/docs/install/stream-settings/

  16. luisj
    Member
    Posted 2 years ago #

    Thanks John.
    I´ll investigate later and will try.
    Then, I'll report.
    Now I have to go to dinner.
    Bye. All the best :-)

  17. Vakantie Ameland
    Member
    Posted 2 years ago #

    @johneckman tnx for checking, I do get this error instead of a list of friends when I click invite friends:

    Error
    Error while loading page from Vakantie huis Ameland
    Empty response received.

    Does it not work when you are the admin of the page?

  18. johneckman
    Member
    Posted 2 years ago #

    Mine works for me as the admin - though it isn't a page, it's an application canvas.

    Where are you clicking on the invite link - in the upper right of your application's canvas page?

    Can you copy the link address the invite link points to?

    Mine, for example, points here:
    http://apps.facebook.com/openparenthesis/index.php?is_invite=true&fb_force_mode=fbml

  19. Vakantie Ameland
    Member
    Posted 2 years ago #

    John, indeed it's an application canvas not a page

    I click the invite link in the upper right:

    http://apps.facebook.com/vakantiehuisameland/index.php?is_invite=true&fb_force_mode=fbml

  20. johneckman
    Member
    Posted 2 years ago #

    Well, it looks right to me, and it works for me.

    Can you ask others to try it?

  21. Vakantie Ameland
    Member
    Posted 2 years ago #

    Strange, asked others and they get exactly the same problem...

    Is it maybe the fact that they, same as me, use mandatory HTTPS... in Facebook. And when using the link, which is HTTP, Facebook does not automatically convert it to HTTPS?....

    No, tried the HTTPS version of the link and same error persists....

    What can it be?

  22. johneckman
    Member
    Posted 2 years ago #

    @christianebuddy - I may or may not have been using https before, but I just tried it now.

    Application canvas page loads in https, though I do a "mixed content" warning - presumably some of the content on your blog page is not called in https - images, for example?

    When the app page is loaded in https, the link for invite friends is non-https:

    http://apps.facebook.com/vakantiehuisameland/index.php?is_invite=true&fb_force_mode=fbml

    If I force that link to be https, and paste back into the browser:

    https://apps.facebook.com/vakantiehuisameland/index.php?is_invite=true&fb_force_mode=fbml

    I do get the error you describe.

    Is your blog accessible via https?

  23. johneckman
    Member
    Posted 2 years ago #

    @christianebuddy

    By any chance do you have access to the PHP error logs on your server?

    For some reason when called by Facebook inside an iFrame the 'invite friends' view is not returning data - I can try to determine what may be happening from the code, but it would be much easier if I could see the error

  24. Vakantie Ameland
    Member
    Posted 2 years ago #

    @johneckman. Content is mixed (some images and external urls (twitter, facebook, some plugins) are http instead https. The whole blog is accessible through https.

    I do have access to the error logs. When you provide me with your ip and/or access time I can filter out any access, error log from you actions

  25. Vakantie Ameland
    Member
    Posted 2 years ago #

    @johneckman unfortunately nothing can be seen in the logs (neither apache, nginx nor syslog) no php error occurs on the server side

  26. johneckman
    Member
    Posted 2 years ago #

    hmm.

    If I load the url in https *without* the fbml bit, the right code gets output:

    https://apps.facebook.com/vakantiehuisameland/index.php?is_invite=true

    though of course it isn't in FBML mode so it doesn't display correctly.

    Adding back in the &fb_force_mode=fbml which is necessary to get the friends selector to appear the right way then throws the empty response error.

  27. johneckman
    Member
    Posted 2 years ago #

    One thing we could try. Are you comfortable editing php?

    In wpbook/theme/config.php, lines 8 and 9 read currently like this:

    $auth_url = "http://www.facebook.com/dialog/oauth?client_id="
      . $api_key . "&redirect_uri=" . urlencode($canvas_page);

    If you change that to this:

    $auth_url = $proto ."://www.facebook.com/dialog/oauth?client_id="
      . $api_key . "&redirect_uri=" . urlencode($canvas_page);

    That will then try to authenticate using https back to facebook.

    If you're not comfortable editing php I could make a development version with the change

  28. johneckman
    Member
    Posted 2 years ago #

    Just checked in a development version with these changes.

    if you go to http://wordpress.org/extend/plugins/wpbook/download/

    you'll see the current 2.5.2 and "other versions" - at the bottom of the "other versions" list is a development version - 15-20 minutes after I post this that dev version should have my changes and you can try that.

  29. Vakantie Ameland
    Member
    Posted 2 years ago #

    Ok, I changed the php code on line 8/9. Did you change anything else? Want to know if I have to download development mode....

    The changes in php did not resolve the issue.

  30. Vakantie Ameland
    Member
    Posted 2 years ago #

    Trying the development version. Does not resolve the issue....

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags