WordPress.org

Ready to get started?Download WordPress

Forums

WPBlacklist 2.0 Released (12 posts)

  1. Fahim
    Member
    Posted 9 years ago #

    I've just released WPBlacklist 2.0 :-) This update to the WPBlacklist plugin includes better blacklist management (the ability to delete blacklist entries for instance); the ability to filter out comments based on not just a full IP but a partial IP as well; the ability to check a real-time blacklist for spam IP; the ability to search existing comments using the blacklist or a given IP or search expression and then delete the found comments if necesary and the ability to mass-delete comments in the moderation queue while harvesting details from those comments (such as poster IP, URL, e-mail address) and to add them to the blacklist. I find most of the new functionality to be pretty useful in dealing with all the new comment spam that we seem to be getting and hope others do as well :)
    Oh yeah, you can download the release from http://sm.farook.org/files/WPBlacklist20.zip

  2. lawtai
    Member
    Posted 9 years ago #

    heh, can you add instructions to that update?

  3. Fahim
    Member
    Posted 9 years ago #

    The instructions are in the included readme file inside the ZIP file :p

  4. Fahim
    Member
    Posted 9 years ago #

    Ugh ... my bad! Sorry, forgot to include the readme file :p I've added it and have re-uploaded the file - thanks for catching that one and letting me know!

  5. lawtai
    Member
    Posted 9 years ago #

    thanks :)

  6. Anonymous
    Unregistered
    Posted 9 years ago #

    Howdy folks!
    I'm pretty new to WordPress but so far things seem to be going fairly well - what a great piece of code!
    The only bummer has been a recent wave of 'comment spam' (and I haven't even made the blog public yet, lol). I installed WPBlacklist 1.2, but whenever I try to post a comment it gives a long list of errors ("Warning: Unknown modifier 't' in /home/XXXX/htdocs/wp/wp-content/plugins/blacklist.php on line 26", "Warning: Cannot modify header information - headers already sent by (output started at /home/XXXX/htdocs/wp/wp-content/plugins/blacklist.php:22) in /home/XXXX/htdocs/wp/wp-comments-post.php on line 89").
    I was hoping installing WPBlacklist 2.0 might correct whatever this error is, but the link in this thread (to farook's site) seems to be down. Is there another place I could download it? (or barring that, anyone know of a way I can fix the above error from 1.2?)
    Thanks all!

  7. Anonymous
    Unregistered
    Posted 9 years ago #

    Oops - should have mentioned that Blacklist 1.2 is actually working (comments containing blacklist.txt words get sent to moderation, others do not and are added normally), but all those error messages might make people think they have to resubmit - and resubmit - etc.

  8. Fahim
    Member
    Posted 9 years ago #

    The error is due to a URL or something which probably had gotten into your blacklist which has a / in it and is not escaped by a preceding \ to make it regex safe. This is a problem which has plagued WPBlacklist for a while. The latest release, WPBlacklist 2.61 hopefully has taken care of these problems finally. You will need to go through your blacklist table and get rid of the offending entry manually or drop all your entries in the blacklist table and reimport them from Jay Allen's central list before the errors would go away though.

  9. Anonymous
    Unregistered
    Posted 9 years ago #

    There seems to be an error, after clicking the submit button, warning sjow up. I deactivated it at the moment

  10. lazymonster
    Member
    Posted 9 years ago #

    i just got a hell lot of spam, i hope 2.6 works well :)

  11. autumnqiu
    Member
    Posted 9 years ago #

    Hmm... Just wondering.

    What is the difference between WPBlacklist and the "Common spam words" function in WP Options >> Discussion?

  12. timbearcub
    Member
    Posted 9 years ago #

    Installs and activates using 2.61, but on 1.5-gamma 2005-02-03 I get this when I click Configuration:

    Fatal error: main(): Failed opening required 'ABSPATHwp-includes/streams.php' (include_path='.:/usr/local/share/pear') in
    (My path)/wp-includes/wp-l10n.php on line 2

    So is it working Ok?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.