WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Wp_prettyphoto (1.6.1) plugin error when activating (6 posts)

  1. not2bug
    Member
    Posted 4 years ago #

    When trying to activate plugin, I get the error:

    Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /plugins/wp-prettyphoto/wp-prettyphoto.php on line 21

    I deactivated a bunch of other plugins thinking that may be the cause but still get errors.

    Any ideas?

  2. The wp-prettyphoto.php file that you downloaded was probably corrupt.

    If you manually installed the plugin, download it again and upload just the wp-prettyphoto.php file.

    If you installed it automatically via the admin panel, deactivate it, select "Delete" beneath the plugin's name, and install it again.

    If installing it automatically via the admin panel produces the same error, try installing it manually.

  3. not2bug
    Member
    Posted 4 years ago #

    Uploaded, via ftp program, the newly downloaded wp-prettyphoto.php file to wp-content/plugnins.

    I then, activated it through the wp admin.

    It gave me the same fatal error.

    Would I need to change the CHMOD setting?

    Also, I've deleted it and reinstalled it many times. Through wp and ftp program.

  4. Per the FAQ, it sounds like your server is running PHP 4. The plugin requires PHP 5. You should contact your hosting provider.

  5. not2bug
    Member
    Posted 4 years ago #

    Ah, yes PHP 5. Thank you, it worked.

  6. You're welcome!

Topic Closed

This topic has been closed to new replies.

About this Topic