WordPress.org

Ready to get started?Download WordPress

Forums

WP_NAV_MENU (2 posts)

  1. aprjnet
    Member
    Posted 2 years ago #

    Hi everybody! I have to add custom HTML ONLY when I have level-02 at my menu navigation. I was looking 3 days and can't find an answer for that!

    Can't find a solution either to show the level-03. Need help with this too! :-)

    Here's my code:

    <ul id="level-01">
              <li>
                        <a href="#">
                                  <!-- CUSTOM HTML AT LEVEL-01, IF I HAVE LEVEL-02 -->
                                  <span class="menu-item-hover">
    			      <span class="submenu-item-hover"></span>
    			      <span class="arrow-hover"></span>
    			      </span>
                                  <!-- TITLE OF MY MENU -->
                                  <span class="title">Home</span>
    			      <span class="arrow"></span>
                                  <!-- END OF CUSTOM HTML AT LEVEL-01, IF I HAVE LEVEL-02 -->
                        </a>
    		    <ul class="level-02">
    			      <li>
                                            <a href="#">With NivoSlider</a>
                                            <ul class="level-03">
                                                      <li><a>Subitem01</a></li>
                                                      <li><a>Subitem02</a></li>
                                             </ul>
                                  </li>
                        </ul>
              </li>
              <li><a href="#">Menu without Level-02</a></li>
              <li><a href="#">Other menu without Level-02</a></li>
    <ul>

    Well, I tried a lot of things, and can't find a solution. Custom Walkers, Custom classes. Please I need help to finish this project!

    I have a HTML to show this: http://aprj.net/etc/news

    Regards,
    Anderson Lucas.

  2. Kelvin Castelino
    Member
    Posted 1 year ago #

    I am a little confused in trying to understand your issue, you have added that code, and its not working you mean?
    If you could share the link that is working, it would be easier to help you out! The current link is going for 404 error page

Topic Closed

This topic has been closed to new replies.

About this Topic