WordPress.org

Ready to get started?Download WordPress

Forums

wp_head() not working properly in wp 2.7.1? (7 posts)

  1. hakre
    Member
    Posted 5 years ago #

    My theme has the <?php wp_head(); ?> template tag in it's header file and the blog has privacy options switched to being visible to search engines.

    the blogs output does _not_ (i repeat: it does not) place any meta tags related to robots in its head.

    is this function bogus in the latest version? as describben in codex, there must be robots meta tags output in place of the wp_head(); tag.

    what am i missing here?

  2. mdempfle
    Member
    Posted 5 years ago #

    I have the same problem

    I use:
    add_action('wp_head', array(&$dl_pluginSeries, 'addHeaderCode'));

    but addHeaderCode is never called.

    Any solution?

    - Michael

  3. iridiax
    Member
    Posted 5 years ago #

    Robots meta tags are not added by WordPress unless your blog is set to private. In that case, you get:

    <meta name='robots' content='noindex,nofollow' />

  4. mdempfle
    Member
    Posted 5 years ago #

    But I only want too add a css in the admin section.

  5. mdempfle
    Member
    Posted 5 years ago #

    Found it - i have to use admin_head.

    Thanks.

  6. Josh Fialkoff
    Member
    Posted 5 years ago #

    Can you please explain what you did to remove the noindex,nofollow code through wp_head()?

    Thanks,
    Josh

  7. chrism878
    Member
    Posted 4 years ago #

    go into settings > Privacy and click "I would like my blog to be visible to everyone, including search engines (like Google, Sphere, Technorati) and archivers

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags