WordPress.org

Ready to get started?Download WordPress

Forums

wp_get_archives displays all posts for any month (1 post)

  1. David Tierney
    Member
    Posted 5 years ago #

    I set up a custom wordpress blog for a client many months ago and it was working properly, I believe. Today, I clicked on one of the monthly archive links and realized that no matter what month I click on, the result is a display of all of the posts from when this client started posting in May. I have no idea what could cause this and was looking for some ideas, help.

    I thought I had used the proper code which I need to self generate the monthly links that point to the archive page. I do have the archive page working properly, or at least it seems so since when clicking on any of the monthly archive links does present the results in the page formatting of the file I created as archive. And if you try out the live link I gave, you can see that it does seem to display a properly formatted URL for the month, ie. http://www.zdwines.com/Wordpress/?m=200809, or http://www.zdwines.com/Wordpress/?m=200807, or etc. - but no matter what month is created in the URL, the results still show all posts rather than just those for the given month.

    The Worpress version is 2.5. The code used to create the monthly archive links is:
    <?php wp_get_archives('type=monthly&limit=12&format=text&after= | '); ?>

    The live site is http://www.zdwines.com/main.php - and the links are at the bottom of the one main "What's Happening" blog entry.

    Thanks as always.
    David

Topic Closed

This topic has been closed to new replies.

About this Topic