WordPress.org

Ready to get started?Download WordPress

Forums

wp_enqueue_script was called incorrectly (6 posts)

  1. pealo86
    Member
    Posted 2 years ago #

    I have installed WP 3.3.1 on my client's hosting account (not dealt with this hosting company in the past) and I keep getting the following errors when trying to add or edit a post:

    Notice: wp_enqueue_script was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or init hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.) in /home2/goburrit/public_html/dev/wp-includes/functions.php on line 3587

    I do not have any plugins enabled and these errors have been in place since I first installed WordPress.

    Has anyone else had this issue?

  2. marenm
    Member
    Posted 2 years ago #

    I'm having a similar problem.
    The enqueue error pops up at all times, and when I go to update/publish/trash a post I get a fatal error and the dreaded white screen.

    I've also deactivated all plugins and deleted everything from my functions.php file (am making a thematic child theme)

    What theme are you using? I seem to be only getting this error with Thematic.

  3. pealo86
    Member
    Posted 2 years ago #

    I'm using the premium theme 'Feast'. Could take a while to figure this one out I think

  4. markman1330
    Member
    Posted 2 years ago #

    I get the same error when I attempt to debug and would like to have a fix.

  5. faina09
    Member
    Posted 2 years ago #

    the issue is still present!! WP 3.3.2, thema twentyeleven. Please fix!!

    [28-May-2012 10:46:31 UTC] PHP Notice:  wp_enqueue_script was called <strong>incorrectly</strong>. Scripts and styles should not be registered or enqueued until the <code>wp_enqueue_scripts</code>, <code>admin_enqueue_scripts</code>, or <code>init</code> hooks. Please see <a href="http://codex.wordpress.org/Debugging_in_WordPress">Debugging in WordPress</a> for more information. (This message was added in version 3.3.) in ../wp-includes/functions.php on line 3587
    [28-May-2012 10:46:31 UTC] PHP Notice:  wp_enqueue_style was called <strong>incorrectly</strong>. Scripts and styles should not be registered or enqueued until the <code>wp_enqueue_scripts</code>, <code>admin_enqueue_scripts</code>, or <code>init</code> hooks. Please see <a href="http://codex.wordpress.org/Debugging_in_WordPress">Debugging in WordPress</a> for more information. (This message was added in version 3.3.) in ../wp-includes/functions.php on line 3587
  6. likeabikemike
    Member
    Posted 2 years ago #

    Same problem. Appeared as soon as I installed Download Manager plug-in, goes away as soon as I disable it. I'm brand new to WP, all my stuff is right out of the box and default so it's not like I have an old version of WP or the plug-in or some exotic theme. Not impressed. So, this has been around for 4 months? Find a solution?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.