WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] $wp_default_secret_key mismatching with AUTH_KEY (13 posts)

  1. jaunis
    Member
    Posted 5 years ago #

    Hi, I upgraded my cforms plugin and installed the last version of the qtranslate plugin and now I get this:

    Your $wp_default_secret_key is mismatchting with your AUTH_KEY. This might cause you not to be able to login anymore.

    (by the way mismatching is mispelled).

    I have no idead at all on how to fix this. HELP! :(

  2. jaunis
    Member
    Posted 5 years ago #

    FIXED! I just changed the auth_key on config.php and everywhing words fine now.

    Was pretty simple :S

  3. ArbuZz
    Member
    Posted 5 years ago #

    No luck here. Same error, but changing of AUTH_KEY doesn't help. In fact I use official key generator at: http://api.wordpress.org/secret-key/1.1/.

    I have qtranslate too. What's that $wp_default_secret_key variable anyway?

    Help appreciated.

  4. simbian
    Member
    Posted 5 years ago #

    same problem here :(

  5. ChrisHappens
    Member
    Posted 5 years ago #

    @ArbuZz

    I found same problem. Then I delete qtranslate and go to log in page. It works.

    Then re-upload the qtranslate.

  6. arsi
    Member
    Posted 5 years ago #

    same problem,

    new auth hey does not work
    removing qtranslate (2.2.1) does work
    reinstalling it (re uploading) does not work

    login is still possible, but the error-message sucks :)

  7. bassoprofondo
    Member
    Posted 5 years ago #

    same problem;
    new auth hey does not work
    removing qtranslate (2.2.1) does work

  8. didierstouten
    Member
    Posted 5 years ago #

    Guys,

    I fixed the problem:

    Open your wp-settings.php and just surf to the place where $wp_default_secret_key can be filled in. Take your AUTH_KEY from the wp-config.php and paste it in here. Your problem should be solved.

    I know, it is not a pretty solution, but it works for me.

    I did not remove qtranslate or anything.

  9. jaunis
    Member
    Posted 5 years ago #

    Search for the qtranslate-core.php in the plugins folder, and delete from line 106 to line 110:

    // Check for WP Secret Key Missmatch
    if($wp_default_secret_key != AUTH_KEY) {
    global $error;
    $error = __('Your $wp_default_secret_key is mismatchting with your AUTH_KEY. This might cause you not to be able to login anymore.','qtranslate');
    }

    That's what's causing the problem.

  10. didierstouten
    Member
    Posted 5 years ago #

    It is a security check, not a problem. So if you want to stay safe, use my method.

  11. jaunis
    Member
    Posted 5 years ago #

    A simple plugin making that kind of security checks. Unnecesary.
    A simple plugin not letting a user login on his blog. (n)

  12. chineseleper
    Member
    Posted 5 years ago #

    not really unnecesary, as it is trying to help users with these kind of problems. try solving this problem if you can't login anymore.

    see http://www.qianqin.de/qtranslate/forum/viewtopic.php?f=3&t=308&p=1450#p1450

  13. Graveto
    Member
    Posted 4 years ago #

    Same problem. I tried to change the Keys. But this did't help.
    Login is possible in the default language but not in any other language.

    And I don't have php-files in my language folder. Only *.po and *.mo files.

    Anybody here who solved this problem?

    thx in advance.
    Graveto

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags