WordPress.org

Ready to get started?Download WordPress

Forums

wp_content_url and force_ssl_admin (1 post)

  1. staze
    Member
    Posted 4 years ago #

    Odd issue for the crowd mind...

    I've moved my static content (css, js, images, etc) to a separate subdomain, and set wp_content_url, full url path to files, etc. I also have force_admin_ssl enabled.

    So, everything works, EXCEPT, in the Appearance Tab, the theme previews don't load because they're trying to load the images over HTTPS, which isn't enabled for that subdomain. This is quite confusing since I've set the wp_content_url to "http://subdomain.example.com/wp-content" and the "full url path to files" to "http://subdomain.example.com/wp-content/uploads".

    So, wordpress is replacing those "http://" entries with "https://" when it constructs the URLs for the appearance section.

    Now, I realize the browser is going to complain that some content is being served insecurely if these aren't over https, but right now it doesn't work period.

    Any advice on this? I would think this is a bug, since wordpress shouldn't be assuming something I didn't input, or rather, changing what I set in the config file thinking it knows better.

Topic Closed

This topic has been closed to new replies.

About this Topic