WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] wp_admin Warnings and page not reloading after submitting post (3 posts)

  1. catoui
    Member
    Posted 10 months ago #

    Hi Group,

    I need your help. I've created a custom theme. Locally, it worked perfectly but when I've pushed it only to mt host's server (hostpapa) it gived me those warning in the Admin:

    Warning: call_user_func_array() expects parameter 1 to be a valid callback, function 'menu_add_pages' not found or invalid function name in /home/mass4563/public_html/beta/wp-includes/plugin.php on line 406

    Warning: Cannot modify header information - headers already sent by (output started at /home/mass4563/public_html/beta/wp-includes/plugin.php:406) in /home/mass4563/public_html/beta/wp-includes/option.php on line 571

    Warning: Cannot modify header information - headers already sent by (output started at /home/mass4563/public_html/beta/wp-includes/plugin.php:406) in /home/mass4563/public_html/beta/wp-includes/option.php on line 572

    I've looked through the forum to get the answer to fix it but everyone was talking about a plugin causing the problem. The thing is, I don't have any plugin in my files.

    I've put the WP_DEBUG(false) in my wp_config but the warning are still showing. My site is running fine but I don't want to see those warning.

    Also, when I publish a post, it does save in my database and show on the website but my admin arrive to a blank page each time. It really annoying. I've work with wordpress for a few years and I never had any problem with the admin.

    I've tested with the Twenty Thirteen theme and the admin works fine. There is something in the code causing the bug.

    Can someone help me!? Thanks

  2. Lorenzo Orlando Caum
    Member
    Posted 10 months ago #

    Remove any existing debug macros. Then try adding the following macro towards the middle of your wp-config.php file:

    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors',0);
  3. catoui
    Member
    Posted 10 months ago #

    Wow!!! perfect, it works.

    Thanks a lot for your quick respond.

Reply

You must log in to post.

About this Topic