WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WP3.1-RC4 & Jquery Tabs : error (7 posts)

  1. grosbouff
    Member
    Posted 3 years ago #

    Hi; I use jquery tabs in my custom plugin.
    I had it working with wordpress 3; but seems the upgrade broke it.
    It tells me
    $(".oqp-tabs").tabs() is not a function.
    Like if the JS was not properly included.
    But I think it is :
    this code is located in my file oqp-tabs.js; which is included like this :

    <br />
    function oqp_single_oqp_post_scripts() {<br />
    	wp_enqueue_script('jquery-ui-tabs');<br />
    	wp_enqueue_script( 'oqp-post-admin-tabs', oqp_get_theme_url().'/_inc/js/oqp-tabs.js',array('jquery','jquery-ui-tabs'), OQP_VERSION ); //create and handle post tabs<br />
    }<br />
    add_action('wp_print_scripts','oqp_single_oqp_post_scripts');<br />

    So the dependencies (jquery, jquery-ui-tabs) are called.
    Any idea ?
    Thanks a lot

  2. @mercime
    Volunteer Moderator
    Posted 3 years ago #

  3. Gary Cao
    Member
    Posted 3 years ago #

    jQuery UI Tabs is working fine for me.

    Is there any other JS error?

  4. grosbouff
    Member
    Posted 3 years ago #

    Yes. The first error do not appear anymore, instead I have

    uncaught exception: jQuery UI Tabs: Mismatching fragment identifier.

    I checked, this error occurs when the link do not match an element ID.
    But that element exists..
    You can see here :http://dev.pellicule.org/classified-ads/ikea/#oqp-step-ad-pictures

  5. Andrew Nacin
    Lead Developer
    Posted 3 years ago #

    You're likely including jQuery 1.5, meanwhile jQuery UI is broken on 1.5.

  6. grosbouff
    Member
    Posted 3 years ago #

    no, it's jQuery JavaScript Library v1.4.4...
    Thanks !

  7. grosbouff
    Member
    Posted 3 years ago #

    FIXED with WP3.1RC5

Topic Closed

This topic has been closed to new replies.

About this Topic