WordPress.org

Ready to get started?Download WordPress

Forums

WP3 & twenty ten: changing URL breaks custom background & post images?? (5 posts)

  1. aaronoppenheimer
    Member
    Posted 4 years ago #

    Hi all,

    - I set up a 3.0 site on a local server, using "localhost" as base of URL, works fine
    - I changed the url on the Settings panel, using name of machine instead of "localhost"
    - background image reference, and post image references, still have "localhost" in URLs

    Something's not being updated properly? Or am I missing some step?

    thanks
    Aaron

  2. Chris_K
    Member
    Posted 4 years ago #

    If you have stuff set to "localhost" and then try to view the site from another machine, things will definitely not work as expected nor desired.

    Do keep in mind that everything machine thinks that its name is localhost. Thus, images won't be found since the machine you're viewing from is looking for images on itself...

    So, for your testing, either do all your viewing from the machine hosting the site or change the URLs under General Settings to be resolvable DNS names.

  3. aaronoppenheimer
    Member
    Posted 4 years ago #

    Yes, I understand. In fact, that's what showed the problem - when I changed the address in the settings pane from 'localhost' to something resolvable, not everything changed - the background image kept 'localhost' in its URL, as did any image in a page. Seems to me that if the URL of the site is changed, all references to media should change too. Interestingly, the URLs for thumbnails returned by 'get_the_post_thumbnail' did change properly.

    Aaron

  4. Chris_K
    Member
    Posted 4 years ago #

    At Settings -> General there are two URLs -- did you change both to a DNS name?

  5. aaronoppenheimer
    Member
    Posted 4 years ago #

    I did. Tried with both a resolvable name, and the ip address of the host, with the same results.

Topic Closed

This topic has been closed to new replies.

About this Topic