WordPress.org

Ready to get started?Download WordPress

Forums

WP2.3.2 Upgrade Doesn't Work - Not Completed Yet? (13 posts)

  1. c0y0te
    Member
    Posted 6 years ago #

    I performed the Wp2.3.2 upgrade (from WP2.3.1) as recommended, copied up the files and ran the upgrade.php script but basically it doesn't work.

    When I try to run the 'upgrade.php' script it tells me the DB is already up to date.

    When I login at the back end it tells me I'm still on WP2.3.1 and should update to 2.3.2 as soon as possible.

    When I look at http://trac.wordpress.org it tells me the 2.3.2 update is not yet complete

    WTF is the actual story with this release? Is it finished? Does it work?

  2. MichaelH
    Member
    Posted 6 years ago #

    If at the bottom of any admin panel it shows 2.3.1, that would suggest you have not uploaded a complete set of 2.3.2 files.

    I'd first consider deleting the WordPress files and reuploading as per Steps 7 and 8 in Upgrading_WordPress_Extended.

  3. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    Yes, 2.3.2 is finished and released. Upgrading to it is highly recommended, due to a minor security hole that was found in all previous versions.

    However, there are no database changes between 2.3.1 and 2.3.2. So running upgrade.php is not necessary for that case.

    But the version number you see should indeed change. So make sure you updated all the files and that all screens show 2.3.2. It will stop bugging you about upgrading after a successful upgrade.

    In point of fact, running upgrade.php manually is never actually necessary. After you upgrade, going to the wp-admin screen will cause it to check the database versions and it will then require you to run upgrade.php from there, if needed. So all you have to do is update your files and go to the WordPress Dashboard.

  4. elliekennard
    Member
    Posted 6 years ago #

    I am getting the following error message when I download your newest release (every time I download it, which is several times now - when I try to right click on it to extract):
    "This page has an unspecified potential security risk. Would you like to continue?"
    I am obliged to answer No as I cannot risk a security problem in the downloaded file.
    What do you advise.
    Thanks
    Ellie

  5. moshu
    Member
    Posted 6 years ago #

    Your antivirus software is probably wrong...
    See http://wordpress.org/support/topic/149623?replies=3

  6. elliekennard
    Member
    Posted 6 years ago #

    It is a windows message, not an antivirus warning. Definitely not from antivirus software. But must be a new windows warning as I now see it on all previous .zip downloads. Weird. Thanks Microsoft!
    ;o)

  7. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    That's an IE thing. You can turn it off. Or just stop using IE and switch to Firefox.

  8. elliekennard
    Member
    Posted 6 years ago #

    It was in Windows Explorer folder window in the folder containing the download. Nothing to do with the browser. I use Firefox.

  9. btard
    Member
    Posted 6 years ago #

    I also get the following

    "No Upgrade Required

    Your WordPress database is already up-to-date!"

    I have deleted *all* the files and moved the new ones over.

  10. djsteve
    Member
    Posted 6 years ago #

    I too am having this issue. I overwrote everything except "wp-content/plugins" and "wp-content/themes". The files on my server show they have been written with today's date, but my dashboard still says it's version 2.3.1 and needs upgrading... not everyone is experiencing this?

  11. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    I overwrote everything except "wp-content/plugins" and "wp-content/themes".

    No, you didn't. If it's telling you that it's a different version, then you failed to overwrite something. Or maybe you uploaded it to the wrong directory entirely. Or something else.

    Try again. Clear your browser cache too, just for good measure.

  12. cfgoulart
    Member
    Posted 6 years ago #

    I'm having the same problem. I just set up a new blog, took everything out, ftp'd everything back up with the new files and get the message that I am still on 2.3.1. I did this like 5 differant times, everything was uploaded, dashboard still says I'm using 2.3.1....

  13. Nyxks
    Member
    Posted 6 years ago #

    I am having same issue, only this is on a blank installation of WP

    As in first time its been installed for this particular web site ... The sites not even a week old yet.

    I've followed the instalation instructions and still get told that its been upgraded yet the Dashboard tells me I need to upgrade.

    I've trashed everything save the config.php file and uploaded the 2.3.2 update and still get the same deal, that I still need to update!

    if you please what is going WRONG?

Topic Closed

This topic has been closed to new replies.

About this Topic